Project

General

Profile

Bug #44383

When i open services it says (red exclamation) Sorry an error has occured

Added by Ryan Kelly about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When i open services in the legacy ui it says (red exclamation) Sorry an error has occured. Not only this but when i try and create a smb share it comes up with a dialougue saying an error has occured. The same happens in the new ui but a new message comes up for creating a share. table sharing_cifs_share has no column named cifs_default_permissions. When i try and enable smb in the freenas new ui it shows smb as crashed. Last but not least i also experience the memory usage going up and up until the system crashes after 30-60 minutes.

Running 11.1-u4
amd a8-7600
asus a78
430w psu
2x 1tb wd red hdd raid 1
8gb usb boot drive.

20180831_101006.jpg (4.33 MB) 20180831_101006.jpg Ryan Kelly, 09/04/2018 11:45 AM
20180906_173731.jpg (3.64 MB) 20180906_173731.jpg Ryan Kelly, 09/06/2018 09:39 AM
20180906_175847.jpg (3.97 MB) 20180906_175847.jpg Ryan Kelly, 09/06/2018 10:02 AM
20180914_180329.jpg (2.65 MB) 20180914_180329.jpg Ryan Kelly, 09/14/2018 10:09 AM
28279
28979
28986
30042

Related issues

Is duplicate of FreeNAS - Bug #41910: Fix system crash/freeze when deleting many filesDone
Has duplicate FreeNAS - Bug #46564: Can't boot into freenas at all including format of boot driveClosed

History

#1 Updated by Ryan Kelly about 2 years ago

  • Seen in changed from Unspecified to 11.1-U4

#2 Updated by Dru Lavigne about 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Ryan: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

#3 Updated by Ryan Kelly about 2 years ago

28279

I also find that when I boot into freenas I get these messages and will not continue to boot and this has happened on multiple occassions. Is this related? It takes two or three hard shutdowns when it reaches this stage to actually boot into freenas.

#4 Updated by Ryan Kelly about 2 years ago

28979

So just upgraded to 11.2 worked fine until I tried to copy something. The system crashed with no output and then came up with this screen. I'll try and get a debug for this if it will boot.

#5 Updated by Dru Lavigne about 2 years ago

  • Is duplicate of Bug #41910: Fix system crash/freeze when deleting many files added

#6 Updated by Dru Lavigne about 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue
  • Reason for Blocked deleted (Need additional information from Author)

Ryan: this is most likely due to the related bug that is fixed for BETA3 (due out early next week). If the issue persists for you after updating to BETA3 when it is available, please leave a comment on this ticket. Thanks!

#7 Updated by Dru Lavigne about 2 years ago

  • Private changed from Yes to No

#8 Updated by Ryan Kelly about 2 years ago

28986

Don't know how to add a picture to previous post. Now Anoter boot failure but further on into the boot process.

#9 Updated by Ryan Kelly about 2 years ago

Dru Lavigne wrote:

Ryan: this is most likely due to the related bug that is fixed for BETA3 (due out early next week). If the issue persists for you after updating to BETA3 when it is available, please leave a comment on this ticket. Thanks!

Thanks I will see about this. Thanks for your help!

#10 Updated by Ryan Kelly about 2 years ago

30042

Hi so I upgraded to 11.2 beta 3 where I promised it would be fixed. Now I've got this. It straight up won't let me boot into freenas or another of the freenas versions. I've formatted the disk to ntfs in Windows explorer with quick format unchecked and now i reinstall with freenas 9 and I get this error as pictured.

#11 Updated by Dru Lavigne about 2 years ago

It's possible your boot device died. Does a fresh install of BETA3 on a different USB stick allow the system to boot?

#12 Updated by Ryan Kelly about 2 years ago

Should i format the drive. Also what format should i format if i need to? NTFS? FAT32?

#13 Updated by Dru Lavigne about 2 years ago

The new stick does not need to be formatted, just perform a fresh install using the instructions in the Guide.

#14 Updated by Ryan Kelly about 2 years ago

Thanks Dru Lavigne. Ive done what you said but i now get a new message when installing a plugin. The message is Install
Worker call raised SystemExit exception
which opens in a dialogue option closed wit no traceback or option to do so.

#15 Updated by Ryan Kelly about 2 years ago

Also can you remove the status closed and duplicate issue as this issue has now developed further past the original issue.

#16 Updated by Dru Lavigne about 2 years ago

Ryan: please reproduce the plugin installation error then attach a debug (System -> Advanced -> Save Debug) to this ticket.

#17 Updated by Ryan Kelly about 2 years ago

  • File debug-Singapore-20180924163230.tgz added

Here we go.

#18 Updated by Dru Lavigne about 2 years ago

Thanks. Is this a fresh install of BETA3 on a new stick? You are getting messages that look like a bad config from a previous botched upgrade.

#19 Updated by Ryan Kelly about 2 years ago

Well I've done as mentioned in this bug. #46564. Formatted the usb checked the sha256 and fresh install of 11.2 beta 3. Is this ok or is it still a usb based issue.

I'll try and obtain a new usb and try this at the weekend.

Thanks

Ryan

#20 Updated by Dru Lavigne about 2 years ago

Go ahead and try a new USB as I suspect that is the issue.

#21 Updated by Dru Lavigne about 2 years ago

  • Status changed from Closed to Unscreened

#22 Updated by Dru Lavigne about 2 years ago

  • Reason for Closing deleted (Duplicate Issue)

#23 Updated by Dru Lavigne about 2 years ago

  • Has duplicate Bug #46564: Can't boot into freenas at all including format of boot drive added

#24 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug-Singapore-20180924163230.tgz)

#25 Updated by Dru Lavigne about 2 years ago

  • Status changed from Unscreened to Closed
  • Private changed from Yes to No
  • Reason for Closing set to Not Applicable

Also available in: Atom PDF