Project

General

Profile

Bug #44449

nfs server hangs or crash's?

Added by Greg Fitzgerald 11 months ago. Updated 6 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Sean Fagan
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Waiting for feedback
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Recently under heavy usage I have noticed my nfs server goes down. If I stop and start nfs in freenas gui it starts to work again. I see messages like this on my FreeBSD 12.0-alpha4 desktop.

nfs server 192.168.1.10:/mnt/srv: is alive again nfs server 192.168.1.10:/mnt/srv: is alive again nfs server 192.168.1.10:/mnt/srv: not responding nfs server 192.168.1.10:/mnt/srv: is alive again nfs server 192.168.1.10:/mnt/srv: not responding

History

#1 Updated by Greg Fitzgerald 11 months ago

  • File debug-freenas-20180904165109.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne 11 months ago

  • Assignee changed from Release Council to John Hixson

#3 Updated by Dru Lavigne 9 months ago

  • Assignee changed from John Hixson to William Grzybowski

#4 Updated by Greg Fitzgerald 9 months ago

This stopped happening as suddenly as it started to happen, so not sure if you can find any useful info or not in the debug tarball. If not just close it, because like I said I can't reproduce it any longer. Very strange.

#5 Updated by William Grzybowski 9 months ago

  • Category changed from Services to OS
  • Assignee changed from William Grzybowski to Alexander Motin

Alexander, over for your team.

#6 Updated by Alexander Motin 9 months ago

  • Assignee changed from Alexander Motin to Sean Fagan

#7 Updated by Sean Fagan 9 months ago

That can happen with severe packet loss. How is it mounted on the client -- specifically, does it have soft and intr or not?

#8 Updated by Greg Fitzgerald 9 months ago

I have the following in my /etc/fstab

192.168.1.10:/mnt/srv /mnt/storage nfs rw 0 0

#9 Updated by Sean Fagan 9 months ago

For some clarification: does the NFS server come back up again (as evidenced by the log messages on the client) on its own, or only after you restart it on the FreeNAS server through the GUI?

#10 Updated by Sean Fagan 6 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

#11 Updated by Sean Fagan 6 months ago

  • Status changed from Blocked to Closed
  • Reason for Closing set to Cannot Reproduce

Timing out.

#12 Updated by Dru Lavigne 6 months ago

  • File deleted (debug-freenas-20180904165109.txz)

#13 Updated by Dru Lavigne 6 months ago

  • Target version changed from Backlog to N/A
  • Private changed from Yes to No

Also available in: Atom PDF