Project

General

Profile

Bug #44735

Fix bug when installing Plugins without an underlying FreeBSD package

Added by Dru Lavigne almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The plugin fails with this error displayed in the UI:

local variable 'pkg_err' referenced before assignment

This traceback appears in middlewared.log:

[2018/09/05 15:06:08] (WARNING) application.call_method():182 - Exception while calling cache.get(['iocage_remote_plugins'])
Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 155, in call_method
result = await self.middleware.call_method(self, message)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 1033, in call_method
return await self._call(message['method'], serviceobj, methodobj, params, app=app, io_thread=False)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 987, in call
return await run_method(methodobj, *args)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 925, in _run_in_conn_threadpool
return await self.run_in_executor(self.
_threadpool, method, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 913, in run_in_executor
return await loop.run_in_executor(pool, functools.partial(method, *args, **kwargs))
File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
result = self.fn(*self.args, **self.kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/schema.py", line 668, in nf
return f(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/cache.py", line 34, in get
self.get_timeout(key)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/cache.py", line 74, in get_timeout
raise KeyError(f'{key} has expired')
KeyError: 'iocage_remote_plugins has expired'
[2018/09/05 15:06:08] (DEBUG) middlewared.logger.CrashReporting.report():102 - Sending a crash report...
[2018/09/05 15:06:08] (DEBUG) raven.base.Client.send_remote():716 - Sending message of length 3825 to https://sentry.ixsystems.com/api/2/store/
[2018/09/05 15:06:09] (WARNING) application.call_method():182 - Exception while calling cache.get(
['iocage_rpkgdict'])
Traceback (most recent call last):
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 155, in call_method
result = await self.middleware.call_method(self, message)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 1033, in call_method
return await self._call(message['method'], serviceobj, methodobj, params, app=app, io_thread=False)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 987, in call
return await run_method(methodobj, *args)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 925, in _run_in_conn_threadpool
return await self.run_in_executor(self.
_threadpool, method, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 913, in run_in_executor
return await loop.run_in_executor(pool, functools.partial(method, *args, **kwargs))
File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
result = self.fn(*self.args, **self.kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/schema.py", line 668, in nf
return f(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/cache.py", line 34, in get
self.get_timeout(key)
File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/cache.py", line 74, in get_timeout
raise KeyError(f'{key} has expired')
KeyError: 'iocage_rpkgdict has expired'
[2018/09/05 15:06:09] (DEBUG) middlewared.logger.CrashReporting.report():102 - Sending a crash report...
[2018/09/05 15:06:09] (DEBUG) raven.base.Client.send_remote():716 - Sending message of length 4436 to https://sentry.ixsystems.com/api/2/store/
[2018/09/05 15:06:19] (WARNING) middlewared.devd_listen():93 - Failed to parse devd message: !system=ZFS subsystem=ZFS type=misc.fs.zfs.history_event pool_name=pool1 pool_guid=13314904165466210743 history_hostname=freenas.local history_dsname=pool1/iocage/jails/bru-server/root history_internal_str=origin=pool1/iocage/releases/11.2-RELEASE/root@bru-server (3122) history_internal_name=clone history_dsid=3133 history_txg=149304 history_time=1536159979


Related issues

Related to FreeNAS - Feature #39573: Update iocage Plugins for BETA3Done

History

#2 Updated by Dru Lavigne almost 2 years ago

#3 Updated by William Grzybowski almost 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Please attach Debug.

#4 Updated by Dru Lavigne almost 2 years ago

  • File debug-freenas-20180905083053.tgz added
  • Status changed from Blocked to Unscreened
  • Private changed from No to Yes
  • Reason for Blocked deleted (Need additional information from Author)

#5 Updated by William Grzybowski almost 2 years ago

  • Assignee changed from William Grzybowski to Waqar Ahmed
  • Severity changed from New to Medium

Waqar, please try to reproduce and/or fix the pkg_err error.

It seems to be in ioc_create.py in iocage.

#6 Updated by Waqar Ahmed almost 2 years ago

  • Status changed from Unscreened to In Progress

#7 Updated by Dru Lavigne almost 2 years ago

#8 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-freenas-20180905083053.tgz)

#9 Updated by Dru Lavigne almost 2 years ago

#10 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from 11.2-RC1 to 11.2-BETA3

#11 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from BRU Server plugin fails on FreeNAS-11.2-MASTER-201809040858 to Fix bug when installing Plugins without an underlying FreeBSD package
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No

#12 Updated by William Grzybowski almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#14 Updated by Dru Lavigne almost 2 years ago

  • Needs Merging changed from Yes to No

#15 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Ready for Testing to Done
  • Needs QA changed from Yes to No

BRU-server successfully installs on FreeNAS-11.2-MASTER-201809070900.

Also available in: Atom PDF