Project

General

Profile

Bug #44834

Retry on pkg install failures to overcome transient network errors when installing Plugins

Added by Dru Lavigne almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Both of these plugins eventually install. However, I have not been able to get either to successfully install the first time, if no plex jail exists. Once an install fails, it makes a broken plex jail then the second installation attempt reliably succeeds (in plex_2, plex_3 and so on). Debug to be attached.

plex-eof.png (92.2 KB) plex-eof.png Warren Block, 09/05/2018 02:21 PM
28675

Related issues

Related to FreeNAS - Feature #39573: Update iocage Plugins for BETA3Done
Related to FreeNAS - Feature #44856: Update iocage Plugins for RC1Done
Related to FreeNAS - Bug #40420: Fix issue with updating jails in new UIDone
Has duplicate FreeNAS - Bug #45666: Installing plug-ins fails with EFAULTClosed

History

#1 Updated by Dru Lavigne almost 2 years ago

#2 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Plex Media Server install fails on FreeNAS-11.2-MASTER-201809050856 to Plex Media Server and Plexpass install fails on FreeNAS-11.2-MASTER-201809050856, then succeeds
  • Description updated (diff)
  • Category changed from OS to Middleware
  • Assignee changed from Martin Wilke to William Grzybowski

#3 Updated by Dru Lavigne almost 2 years ago

  • File deleted (plex.png)

#4 Updated by Dru Lavigne almost 2 years ago

  • File debug-freenas-20180905115932.tgz added

#5 Updated by Dru Lavigne almost 2 years ago

#6 Updated by Warren Block almost 2 years ago

28675

#7 Updated by William Grzybowski almost 2 years ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Severity changed from New to Med High

Brandon, I see at least 3 issues here:

1.
/usr/local/lib/python3.6/site-packages/iocage_lib/ioc_plugin.py\", line 723, in fetch_plugin_index\n self.plugin = input(\"\\nType the number of the desired

2.
File \"/usr/local/lib/python3.6/site-packages/iocage_lib/ioc_plugin.py\", line 172, in fetch_plugin\n sys.exit(1)

3.
Lots of download errors

These can be seen in the debugs, under system (there is a core.get_jobs output).

Regarding 3, we really need to do something about it. We have to accept the fact that downloads will fail and that connections are flaky (not everybody has a gigabit fiber).
We need a mechanism to retry in case of network failures.

#8 Updated by Bonnie Follweiler almost 2 years ago

  • Related to Bug #40420: Fix issue with updating jails in new UI added

#9 Updated by Brandon Schneider almost 2 years ago

  • Status changed from Unscreened to Not Started

1 - https://redmine.ixsystems.com/issues/39653 <-- Dupe of that ticket
2 - If the session is using an interactive middleware, they will see sys.exit, otherwise it should never happen
3 - Interesting, agreed.

Also of note is pkg-static missing on your jail dru, perhaps some other failure happened? That shouldn't be the case.

#10 Updated by Brandon Schneider almost 2 years ago

  • Status changed from Not Started to Blocked
  • Reason for Blocked set to Need verification

Couldn't reproduce on Dru's machine, a different bug got fixed that her machine ran into. Will verify with a different nightly.

#11 Updated by Brandon Schneider almost 2 years ago

  • Has duplicate Bug #45666: Installing plug-ins fails with EFAULT added

#12 Updated by Brandon Schneider almost 2 years ago

  • Status changed from Blocked to In Progress

#13 Updated by Brandon Schneider almost 2 years ago

  • Reason for Blocked deleted (Need verification)

#15 Updated by Brandon Schneider almost 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#16 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Plex Media Server and Plexpass install fails on FreeNAS-11.2-MASTER-201809050856, then succeeds to Retry on pkg install failures to overcome transient network errors when installing Plugins
  • Needs Doc changed from Yes to No

#17 Updated by Bonnie Follweiler almost 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreeNAS-11.2-MASTER-201809260704
It installed both on the first try

#18 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

#19 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-freenas-20180905115932.tgz)

#20 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug.tgz)

Also available in: Atom PDF