Project

General

Profile

Bug #4487

Auto Imported encrypted ZFS volumes are not visible in Volumes

Added by Pawel Urbanowski over 6 years ago. Updated about 3 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Build: FreeNAS-9.2.1.2-RELEASE-x64 (002022c)
Procedure:
1. Fresh installed 9.2.1
2. Created encrypted ZFS volume
3. Upgraded to 9.2.1.2
4. Expanded the volume
5. Factory reset
6. Auto import of the encrypted volume without the passphrase ("Step 3 of 3" progress bar running and running. After some time pressed "x" button to close the window. No traceback generated.).
7. The volume was mounted (visible as /mnt/L1) however not visible in the web ui under Volumes section.
8. Re-downloaded 9.2.1.2 and did a fresh install, but it did not help. I was suspecting ticket #4420.

Attached all.log file which contains logs generated during auto import operation.

History

#1 Updated by Pawel Urbanowski over 6 years ago

I selected the wrong release in "Seen in". Please change it to 9.2.1.2-RELEASE. Thanks.

#2 Updated by William Grzybowski over 6 years ago

  • Status changed from Unscreened to Screened
  • Assignee set to William Grzybowski
  • Priority changed from Important to Nice to have
  • Target version set to 79
  • Seen in changed from to 9.2.1.2-RELEASE

Did you try to just refresh the volume screen?

#3 Updated by William Grzybowski over 6 years ago

Ping!

#4 Updated by Pawel Urbanowski over 6 years ago

Sorry William, I missed your question. Yes, I tried to reload/refresh the web page. I even tried to reboot the system. But no luck.
Finally I've been able to auto import the volume, but I am not sure why it worked.
I did:
1. Auto import from GUI. Result: No volume visible in the GUI.
2. zpool export L1
3. zpool import L1 Dane
4. Auto import from GUI. Result: Failed. Database is locked.
5. reboot
6. Auto import from GUI. Result: OK.

I've been trying today to reproduce the issue on virtualbox without any success.
I will try to reproduce it on my real system, but it won't be able to do it within 2 weeks, so I think we should close the ticket and I will ping you in case of any updates.

#5 Updated by William Grzybowski over 6 years ago

  • Target version changed from 79 to 49

Marking as future as the reporter cannot reproduce the problem anymore.

#6 Updated by William Grzybowski over 4 years ago

  • Status changed from Screened to Closed: Cannot reproduce

Feel free to reopen if you found a way to reproduce.

#7 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Category set to Middleware
  • Target version changed from 49 to N/A

#8 Updated by Dru Lavigne almost 3 years ago

  • File deleted (all.log)

Also available in: Atom PDF