Project

General

Profile

Bug #45666

Installing plug-ins fails with EFAULT

Added by Ian Matyssik about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I always fail to complete any installation of the plug-ins after upgrading to 11.2-BETA3. Using new GUI the plugin only creates jail but nothing is installed inside. The error I received is: [EFAULT] jexec: execvp: pkg-static: No such file or directory


Related issues

Is duplicate of FreeNAS - Bug #44834: Retry on pkg install failures to overcome transient network errors when installing PluginsDone

History

#1 Updated by Ian Matyssik about 2 years ago

  • File debug-zeus-20180911052056.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to William Grzybowski

#3 Updated by William Grzybowski about 2 years ago

  • Target version changed from Backlog to 11.2-RC1
  • Severity changed from New to Medium

#4 Updated by William Grzybowski about 2 years ago

  • Status changed from Unscreened to Not Started

#5 Updated by Ian Matyssik about 2 years ago

Do you require any additional information?

#6 Updated by William Grzybowski about 2 years ago

  • Assignee changed from William Grzybowski to Brandon Schneider

We will let you know if anything is required once we start working on the issue.

#7 Updated by Brandon Schneider about 2 years ago

Ian: Was there a specific plugin that failed for you?

#8 Updated by Ian Matyssik about 2 years ago

I have tried 3 so far: Plex, Emby, rssi - all faild with the same error

#9 Updated by Brandon Schneider about 2 years ago

  • Is duplicate of Bug #44834: Retry on pkg install failures to overcome transient network errors when installing Plugins added

#10 Updated by Brandon Schneider about 2 years ago

  • Target version changed from 11.2-RC1 to N/A
  • Reason for Closing set to Duplicate Issue
  • Needs Merging changed from Yes to No

Alright Ian, this is the same as #44834 so we're going to track it there.

#11 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug-zeus-20180911052056.txz)

#12 Updated by Dru Lavigne about 2 years ago

  • Status changed from Not Started to Closed
  • Private changed from Yes to No

#13 Updated by Ian Matyssik about 2 years ago

Looking at the related issue it does not seem the same, the error message is different.

#14 Updated by William Grzybowski about 2 years ago

Ian Matyssik wrote:

Looking at the related issue it does not seem the same, the error message is different.

The debug in the related ticket has 3 different issues, one of them is exactly as this one.

Also available in: Atom PDF