Project

General

Profile

Bug #45699

Nextcloud - finishing installation fails

Added by Nikolai Udwari about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Martin Wilke
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

When installing nextcloud from the plugins section of the UI and trying to finish the installation with the given DB credentials I'm stuck in a redirect loop.

My solution to this problem:

1)

chown -R www:www /usr/local/

2)
As described by "https://help.nextcloud.com/t/freebsd-nextcloud-13-0-1-update-too-many-redirects-error-bug/30494/8":
in "/usr/local/www/nextcloud/fix-apps_paths.json"

{"system": {"apps_paths":
    [
        {
            "path": "\/usr\/local\/www\/nextcloud\/apps",
            "url": "\/apps",
            "writable": true
        },
        {
            "path": "\/usr\/local\/www\/nextcloud\/apps-pkg",
            "url": "\/apps-pkg",
            "writable": false
        }
    ]
}}

3)
As described in "https://help.nextcloud.com/t/freebsd-nextcloud-13-0-1-update-too-many-redirects-error-bug/30494/6":

cd /usr/local/www/nextcloud
su -m www -c "php ./occ config:import < /usr/local/share/nextcloud/fix-apps_paths.json" 

And the nextcloud magically works!


Related issues

Is duplicate of FreeNAS - Bug #34162: Fix Nextcloud iocage pluginDone

History

#1 Updated by Nikolai Udwari about 2 years ago

  • Private changed from No to Yes

#2 Updated by Nikolai Udwari about 2 years ago

  • Private changed from Yes to No

#3 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #34162: Fix Nextcloud iocage plugin added

#4 Updated by Dru Lavigne about 2 years ago

  • Category changed from GUI (new) to OS
  • Assignee changed from Release Council to Martin Wilke
  • Target version changed from Backlog to 11.2-RC1

#5 Updated by Dru Lavigne almost 2 years ago

  • Related to deleted (Bug #34162: Fix Nextcloud iocage plugin)

#6 Updated by Dru Lavigne almost 2 years ago

  • Is duplicate of Bug #34162: Fix Nextcloud iocage plugin added

#7 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from 11.2-RC1 to N/A
  • Reason for Closing set to Duplicate Issue

Nikolai: the work to fix this plugin will occur on the related ticket.

Also available in: Atom PDF