Project

General

Profile

Bug #45919

OpenVPN cannot allocate tun in jail

Added by Adam Best almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After upgrading from 11.2-BETA2 to 11.2-BETA3, OpenVPN cannot dynamically allocate a tunnel interface.

Previously a pre-init task of "devfs rule -s 4 add path 'tun*' unhide" was required to make this functional. I double checked and the task is still there, but now it doesn't appear to be working.


Related issues

Is duplicate of FreeNAS - Bug #40872: Add ability to allocate TUN devices dynamically in iocageDone

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Adam: please reproduce then attach a debug (System -> Advanced -> Save debug) to assist the dev in diagnosing the issue.

#2 Updated by Adam Best almost 2 years ago

  • File debug.tgz added

Before I generated the debug file, I did a hard restart of the jail and verified the service didn't stay running. I attempted to manually start the service a second time, with the same result.

#3 Updated by Dru Lavigne almost 2 years ago

  • Category changed from OS to Middleware
  • Assignee changed from Release Council to William Grzybowski

#4 Updated by William Grzybowski almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

#5 Updated by William Grzybowski almost 2 years ago

  • Is duplicate of Bug #40872: Add ability to allocate TUN devices dynamically in iocage added

#6 Updated by Adam Best almost 2 years ago

Can you point me in the direction of the other bug report? I did a search and couldn't find it, just the closed one that I used in BETA2 to resolve this issue.

#7 Updated by William Grzybowski almost 2 years ago

Adam Best wrote:

Can you point me in the direction of the other bug report? I did a search and couldn't find it, just the closed one that I used in BETA2 to resolve this issue.

It is private because it has sensitive information. Once its resolved you will be able to see it in related entries.

#8 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug.tgz)

#9 Updated by Dru Lavigne almost 2 years ago

  • Private changed from Yes to No
  • Reason for Blocked deleted (Need additional information from Author)

Also available in: Atom PDF