Project

General

Profile

Bug #46040

Nextcloud - libpcre not found

Added by Nikolai Udwari about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Martin Wilke
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After restarting the Nextcloud pluginv2 or restarting FreeNAS I cannot access the web interface of Nextcloud.

In Plugins > Installed it says that nextcloud is up and running.

Opening the jail plugin and checking if nginx is running reveals that the service is not running.
Trying to start nginx with

service nginx start
gives following error:

Performing sanity check on nginx configuration:
Shared object "libpcre.so.1" not found, required by "nginx" 
Starting nginx.
Shared object "libpcre.so.1" not found, required by "nginx" 
/usr/local/etc/rc.d/nginx: WARNING: failed to start nginx

Changes I made to the Nextcloud installation:
https://redmine.ixsystems.com/issues/45699

Please note the following:

/usr/local/lib
contains
libpcre.so.1
as a link to
libpcre.so.1.2.10


Related issues

Is duplicate of FreeNAS - Bug #34162: Fix Nextcloud iocage pluginDone

History

#1 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Martin Wilke
  • Target version changed from Backlog to 11.2-RC1

#2 Updated by Nikolai Udwari about 2 years ago

Without

chown -R www:www /usr/local/

Nginx starts normally.

#3 Updated by Dru Lavigne almost 2 years ago

  • Is duplicate of Bug #34162: Fix Nextcloud iocage plugin added

#4 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from 11.2-RC1 to N/A
  • Reason for Closing set to Duplicate Issue

Nikolai: the work to resolve this issue will occur on the related ticket.

Also available in: Atom PDF