Project

General

Profile

Bug #46641

Avatar?id=25780&size=50x50

Adjust safeUrl settings to allow Guide to display in new UI

Added by Ned Devine about 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Clicking on "Guide" in the left navigation does nothing. Shows the grey screen of death.

cannot-load-guide.png (10.1 KB) cannot-load-guide.png Browser console output Ned Devine, 09/14/2018 08:32 PM
guide.png (42.3 KB) guide.png Result Ned Devine, 09/14/2018 08:33 PM
Screen Shot 2018-10-25 at 2.01.15 PM.png (300 KB) Screen Shot 2018-10-25 at 2.01.15 PM.png Jeff Ervin, 10/25/2018 11:18 AM
Screen Shot 2018-10-25 at 2.33.55 PM.png (331 KB) Screen Shot 2018-10-25 at 2.33.55 PM.png Jeff Ervin, 10/25/2018 11:35 AM
30178
30185
36720
36726

Related issues

Related to FreeNAS - Feature #29578: Add API to allow user to select HTTPS for iocage jailsReady for Testing
Has duplicate FreeNAS - Bug #51447: After upgrading from 11.1-U6 to 11.2-x, the guide tab no longer worksClosed

History

#1 Updated by Dru Lavigne about 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Ned: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Avatar?id=25780&size=24x24 Updated by Ned Devine about 2 years ago

  • File debug.tgz added

Dru Lavigne wrote:

Ned: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

Done.

More info: The Guide works as expected when accessing the GUI via http. It fails when accessing the GUI via https because the iframe src contains a non-https URL.

#3 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Lola Yang
  • Target version changed from Backlog to 11.2-RC1
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by Lola Yang about 2 years ago

  • Assignee changed from Lola Yang to Dennis Mullen

#5 Updated by Dennis Mullen about 2 years ago

  • Status changed from Unscreened to Screened

#6 Updated by Dennis Mullen about 2 years ago

If I understand this issue correctly, I think we can't fix it until we enable https - as reflected in this ticket: https://redmine.ixsystems.com/issues/29578

The guide is indeed accessed by an internal http address which we will be able to change to https when we enable it across the board.

#7 Updated by Dennis Mullen about 2 years ago

  • Related to Feature #29578: Add API to allow user to select HTTPS for iocage jails added

#8 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from 11.2-RC1 to 11.2-RC2

#10 Avatar?id=25780&size=24x24 Updated by Ned Devine almost 2 years ago

Dennis Mullen wrote:

If I understand this issue correctly, I think we can't fix it until we enable https - as reflected in this ticket: https://redmine.ixsystems.com/issues/29578

The guide is indeed accessed by an internal http address which we will be able to change to https when we enable it across the board.

Actually I think it should be rather easy. Instead of

<iframe src="http://nashost/docs/freenas.html" width="100%" height="100%" frameborder="0"></iframe>

it could be

<iframe src="//nashost/docs/freenas.html" width="100%" height="100%" frameborder="0"></iframe>

or perhaps even

<iframe src="/docs/freenas.html" width="100%" height="100%" frameborder="0"></iframe>

then it will work over either http or https, whichever is currently being used.

#11 Avatar?id=25780&size=24x24 Updated by Ned Devine almost 2 years ago

  • File deleted (debug.tgz)

#12 Updated by Dennis Mullen almost 2 years ago

Hey Ned, your first recommendation

src="//nashost/docs/freenas.html
is a good one and probably the way we should spell out the link. However, it seems to give me the same results as before. If you are in a position to check out and test a GitHub branch here's one that drops the 'http' from the guide address.

https://github.com/freenas/webui/tree/fix-46641

BTW I have been testing this by using various browser extensions like HTTPS Everywhere that insist on https. If you are doing something else, I'd like to try it. -Dennis

#13 Updated by Dru Lavigne almost 2 years ago

  • Private changed from Yes to No

#14 Updated by Dru Lavigne almost 2 years ago

  • Has duplicate Bug #51447: After upgrading from 11.1-U6 to 11.2-x, the guide tab no longer works added

#15 Updated by Dennis Mullen almost 2 years ago

  • Status changed from Screened to In Progress

master PR: https://github.com/freenas/webui/pull/1393
11.2-stable PR: https://github.com/freenas/webui/pull/1405

This emoves the specific reference to 'http' to perhaps make our url more flexible; This will not, however, let an unencrypted link through a security filter.

#16 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Cannot load Guide to Adjust safeUrl settings to allow Guide to display in new UI
  • Status changed from In Progress to Ready for Testing
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#17 Updated by Jeff Ervin almost 2 years ago

36720

No issues loading guide.

Test Passed FreeNAS-11.2-INTERNAL28

#19 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF