Project

General

Profile

Bug #46678

Avatar?id=25780&size=50x50

Improve Dashboard loading time in new UI

Added by Ned Devine about 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Often the tiles on the "Dashboard" page load really slowly (as in, minutes). I haven't yet seen a tile never load. The longest I've seen it take for a tile to load is ~7 minutes.

"CPU Usage" and "Load Average" typically are the ones most likely to load slowly, but I've seen others load slowly as well.

Reproduced in Firefox and Chrome on a very quiet network.

slow-dashboard.png (117 KB) slow-dashboard.png Very slow Ned Devine, 09/14/2018 09:19 PM
cpu-temp-data-unavailable.png (81.9 KB) cpu-temp-data-unavailable.png CPU temperature data unavailable Ned Devine, 09/17/2018 06:11 PM
30273
30581

Related issues

Has duplicate FreeNAS - Bug #75730: UI default tiles for 'CPU usgae' and 'Load Average' issueClosed
Has duplicate FreeNAS - Bug #76143: Unresponsive UIClosed
Has duplicate FreeNAS - Bug #83435: Dashboard widgets are blank or show no data on their range.Closed

History

#1 Updated by Dru Lavigne about 3 years ago

  • Status changed from Unscreened to Blocked
  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Ned: is this only after a fresh reboot or at other times? The next time it happens, please create a debug (System -> Advanced -> Save debug) and attach it to this ticket. We'll need that info to see what is causing the holdup.

#2 Avatar?id=25780&size=24x24 Updated by Ned Devine about 3 years ago

30581

Dru Lavigne wrote:

Ned: is this only after a fresh reboot or at other times? The next time it happens, please create a debug (System -> Advanced -> Save debug) and attach it to this ticket. We'll need that info to see what is causing the holdup.

I took the screenshot of the behavior when the nas machine had been up 4 days. I had experienced the inconsistent, slow loading from boot up until that point.

But it's not happening now like it was. Today the "CPU Temperatures" graph is only kind of slow (~7 seconds as opposed to several minutes). The dashboard is loading more consistently, though while I was trying to replicate this I saw a new problem where the "CPU Temperatures" graph stopped trying to load after ~7 seconds and displayed "CPU temperature data unavailable". My attempt to replicate simply consisted of me clicking back and forth between the Dashboard and other pages at a normal non-rapid pace.

Debug info attached.

#3 Updated by Dru Lavigne about 3 years ago

  • Assignee changed from Release Council to Lola Yang
  • Target version changed from Backlog to 11.2-RC1
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by Lola Yang about 3 years ago

  • Assignee changed from Lola Yang to Damian Szidiropulosz

#5 Updated by Dru Lavigne about 3 years ago

  • Status changed from Blocked to Unscreened

#6 Updated by Dru Lavigne about 3 years ago

  • Target version changed from 11.2-RC1 to 11.2-U2

#8 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 11.2-U2 to 11.2-U3

#9 Updated by Dru Lavigne almost 3 years ago

  • File deleted (debug3.tgz)

#10 Updated by Dru Lavigne almost 3 years ago

  • Private changed from Yes to No

#11 Updated by Dru Lavigne almost 3 years ago

  • Has duplicate Bug #75730: UI default tiles for 'CPU usgae' and 'Load Average' issue added

#12 Updated by Damian Szidiropulosz almost 3 years ago

  • Status changed from Unscreened to In Progress

#13 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from Dashboard tiles often load slowly to Improve Dashboard loading time in new UI
  • Status changed from In Progress to Ready for Testing
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#14 Updated by Dru Lavigne almost 3 years ago

#19 Avatar?id=55038&size=24x24 Updated by Zackary Welch almost 3 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

The primary dashboard widgets loaded in a reasonable time in three different systems I tested. They didn't load at all for a vm, but I'm willing to account this is due to a lack of physical hardware.

#20 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Passed Testing to Done

#22 Updated by Dru Lavigne over 2 years ago

  • Has duplicate Bug #83435: Dashboard widgets are blank or show no data on their range. added

Also available in: Atom PDF