Project

General

Profile

Bug #46795

FreeBSD bootloader

Added by Andrey Gorbachev 10 months ago. Updated 8 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
Hardware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Dear all,

Not realising that 11.2 (STABLE) is actually a beta I have upgraded from GUI. I am running my small home server in a headless configuration and from GUI it looked like the upgrade was successful and the system rebooted. But the system did not boot. Connecting the monitor shows the console:

gptzfsboot: error 32 lba 30031240
gptzfsboot: error 32 lba 1 |
Can't find /boot/zfsloader

FreeBSD/x86 boot
Default: nas:/boot/kernel/kernel
boot:
/
Can't find /boot/kernel/kernel

My hardware:
Asus E45M1-I DELUXE (AMD Hudson M1) DDR3 mini ITX Motherboard
2*OcUK Value 4GB (1x4GB) DDR3 PC3-10666C9 1333MHz Low-Voltage Single Channel Module
2*Seagate Barracuda 2TB 64MB SATA 5900 RPM Hard Drive (in RAID1)
1*SanDisk Ultra Fit 16 GB USB Flash Drive USB 3.0 up to 150 MB/s (boot)

I have discussed the issue on the forum under the thread titled "Failed upgrade from 11 (STABLE) to 11.2 (STABLE)": https://forums.freenas.org/index.php?threads/failed-upgrade-from-11-stable-to-11-2-stable.69146/.


Related issues

Related to FreeNAS - Bug #65994: Merge in FreeBSD boot loader fixesReady for Testing

History

#1 Updated by Dru Lavigne 10 months ago

  • Description updated (diff)
  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Andrey: please attach a debug (System -> Advanced -> Save debug) from your U6 install to this ticket. It will give the dev a starting point wrt the system's hardware details.

#2 Updated by Andrey Gorbachev 10 months ago

Unfortunately I did not save that before the upgrade. Currently the machine is in a non-bootable 11.2-BETA3 stage. Do you want me to rebuild it again back to the U6 stage to get the info? Is there anything else I can do to help? (try to install the FreeBSD directly for example)

#3 Updated by Dru Lavigne 10 months ago

Yeah, go ahead and reinstall U6 and generate the debug from there. That way you have a usable system again and the dev has more info about your hardware.

#4 Updated by Dru Lavigne 10 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No

#5 Updated by Andrey Gorbachev 10 months ago

  • File debug-OPCNAS-20180929061338.tgz added

Sorry for the late reply - was away from the machine for couple of weeks.

I attach the file requested, pls consider re-opening the bug report?

#6 Updated by Dru Lavigne 10 months ago

  • Status changed from Closed to Unscreened
  • Assignee changed from Release Council to Alexander Motin
  • Target version changed from N/A to Backlog
  • Private changed from No to Yes

#7 Updated by Dru Lavigne 10 months ago

  • Reason for Blocked deleted (Need additional information from Author)

#8 Updated by Alexander Motin 10 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Unfortunately I don't think we can reproduce this without having the same motherboard. At the forum post I see you mention that you have the same problem after reinstalling BETA3 from the ISO. Could you specify please, in that case, have you had the problem with the reinstall itself or reinstall passed, but boot failed after that?

Also you could specify whether you used UEFI or BIOS installs in each case, since it seems strange to me that in your later debug data I see the system is booted in UEFI mode, while first after upgrade you've got gptzfsboot errors. gptzfsboot is used in legacy/BIOS mode, while should not be used in UEFI. It would be good it you could test both installation modes to try localize the problem.

#9 Updated by Alexander Motin 10 months ago

Also, as you have asked on the forum, you could try to run some recent FreeBSD 12.0-ALPHA snapshot on that system. While we worked on ISO loader for the installer, we haven't modified ZFS loader for installed system, so if you reproduce the problem with booting installed FreeBSD, you could report the issue there. If with 12.0 you find no problem, you could try FreeBSD 11.2 -- FreeNAS is based mostly on that, but has some updates past the release.

#10 Updated by Andrey Gorbachev 9 months ago

I'll try FreeBSD 12.0-ALPHA when I find a bit of time.

As for the other questions:

1) Re-installing the BETA3 from the ISO had the same issue as the previous attempt (BETA2 from GUI) - installation appears to complete normally, but the boot failed.

2) I have to say I have failed to keep notes about UEFI/BIOS selection during all the re-installs. As you say - current install uses UEFI, but well could be that the previous installs used BIOS. It could be that I have not actually tried installing BETA3 in UEFI mode - would it be something you recommend? (or would you say that either UEFI/BIOS should work and we should continue looking into it)

3) One more thing I have forgotten to mention is that during re-installation of 11.1 I have noticed that my BIOS was not up to date and updated that as well. So it could be that I have not tried BETA3 with the lasts BIOS for my motherboard (it went from version 0404 to 0504, so it was only 1 release behind).

#11 Updated by Alexander Motin 8 months ago

  • Status changed from Blocked to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Need additional information from Author)
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

I'm sorry, but not sure how to help with this without ability to reproduce it. You may try it on vanilla FreeBSD and if it also have a problem -- report the issue upstream.

#12 Updated by Dru Lavigne 8 months ago

  • File deleted (debug-OPCNAS-20180929061338.tgz)

#13 Updated by Dru Lavigne 8 months ago

  • Private changed from Yes to No

#14 Updated by Ryan Moeller 6 months ago

  • Related to Bug #65994: Merge in FreeBSD boot loader fixes added

Also available in: Atom PDF