Project

General

Profile

Bug #46986

UI does not unsubscribe vm.status calls

Added by William Grzybowski about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When on VM page the UI will make one call to vm.status for each VM.

When navigating away from that page it will keep doing vm.status calls.

If you go back to VM page it will add new calls to the queue, making 2 calls to vm.status per VM, periodically.

This will add up and DoS middleware with dozens of calls per second.

Additionally to unsubscribing when navigating away a single vm.query call could be made to get status of all VMs at once, instead of vm.status for each VM.


Related issues

Is duplicate of FreeNAS - Bug #46964: Fix sending multiple vm.clone calls when cloning a VMDone

History

#1 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Lola Yang
  • Target version changed from Backlog to 11.2-RC1

#2 Updated by Lola Yang about 2 years ago

  • Assignee changed from Lola Yang to Vaibhav Chauhan

#3 Updated by Vaibhav Chauhan about 2 years ago

  • Related to Bug #46964: Fix sending multiple vm.clone calls when cloning a VM added

#4 Updated by Vaibhav Chauhan about 2 years ago

  • Assignee changed from Vaibhav Chauhan to Damian Szidiropulosz

I think this ticket is also related to #46964

#5 Updated by Damian Szidiropulosz about 2 years ago

  • Status changed from Unscreened to Ready for Testing

PR 1253 fixes this

#6 Updated by Dru Lavigne about 2 years ago

  • Related to deleted (Bug #46964: Fix sending multiple vm.clone calls when cloning a VM)

#7 Updated by Dru Lavigne about 2 years ago

  • Is duplicate of Bug #46964: Fix sending multiple vm.clone calls when cloning a VM added

#8 Updated by Dru Lavigne about 2 years ago

  • Status changed from Ready for Testing to Closed
  • Target version changed from 11.2-RC1 to N/A
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF