Project

General

Profile

Bug #47151

Fix traceback when listing jails

Added by gerry the hat about 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In the UI I get an error when clicking on Plugins, see screenshot. Jails is empty. Listing the jails via CLI gives an error:

root@freenas:~ # iocage list
ifconfig: interface epair0b does not exist
Traceback (most recent call last):
File "/usr/local/bin/iocage", line 10, in <module>
sys.exit(cli())
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 722, in call
return self.main(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 697, in main
rv = self.invoke(ctx)
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/usr/local/lib/python3.6/site-packages/click/core.py", line 535, in invoke
return callback(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/iocage_cli/list.py", line 81, in cli
dataset_type, header, _long, _sort, plugin=plugins, quick=quick)
File "/usr/local/lib/python3.6/site-packages/iocage_lib/iocage.py", line 1143, in list
quick=quick
File "/usr/local/lib/python3.6/site-packages/iocage_lib/ioc_list.py", line 75, in list_datasets
_all = self.list_all(ds)
File "/usr/local/lib/python3.6/site-packages/iocage_lib/ioc_list.py", line 227, in list_all
out = su.check_output(full_ip4_cmd)
File "/usr/local/lib/python3.6/subprocess.py", line 336, in check_output
**kwargs).stdout
File "/usr/local/lib/python3.6/subprocess.py", line 418, in run
output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['jexec', 'ioc-emby', 'ifconfig', 'epair0b', 'inet']' returned non-zero exit status 1.

Bildschirmfoto 2018-09-18 um 22.21.52.png (34.7 KB) Bildschirmfoto 2018-09-18 um 22.21.52.png gerry the hat, 09/18/2018 01:28 PM
Blank Gui.jpg (136 KB) Blank Gui.jpg Christopher Manns, 11/17/2018 12:32 PM
pool view.jpg (138 KB) pool view.jpg Christopher Manns, 11/17/2018 12:32 PM
iocage list error.jpg (225 KB) iocage list error.jpg Christopher Manns, 11/17/2018 12:32 PM
30812
41172
41181
41190

Related issues

Related to FreeNAS - Bug #45838: Improve validation for iocage jail CRUD methods Done

History

#1 Updated by gerry the hat about 2 years ago

  • File debug-freenas-20180918202637.txz added
  • Private changed from No to Yes

#2 Updated by gerry the hat about 2 years ago

30812

#3 Updated by gerry the hat about 2 years ago

  • Private changed from Yes to No

#4 Updated by Dru Lavigne about 2 years ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Private changed from No to Yes

#5 Updated by William Grzybowski about 2 years ago

  • Assignee changed from William Grzybowski to Waqar Ahmed
  • Target version changed from Backlog to 11.2-RC1
  • Severity changed from New to Medium

#6 Updated by Waqar Ahmed about 2 years ago

  • Status changed from Unscreened to In Progress

#7 Updated by Waqar Ahmed about 2 years ago

  • Status changed from In Progress to Blocked
  • Reason for Blocked set to Waiting for feedback

Good Morning Gerry. I have been looking at the logs and your issue stems from a bug which was fixed recently. Could you kindly try

iocage stop emby

This should stop your emby jail. Now please don't start another jail and first upgrade your system to the latest nightlies to ensure that the patch exists on your system. Then you can start the jails/plugins and everything should work fine. I think another jail is also affected which you tried to run after emby. Once you perform a stop for emby, if another one is running you'll still be getting a traceback and you'll know which one it is from the traceback. Please try stopping that one as well and once you're done, starting them after updating to nightlies would clear your issue.
This is a temporary work around and we are working meantime to make the process more smoother so your other jails aren't affected by such issues. Kindly let us know if you run into any more issues. Many thanks for your time and effort!

#8 Updated by gerry the hat about 2 years ago

Well, something introduced a bug and somewhere somehow something removed it again. However, the problem is gone..

#9 Updated by Waqar Ahmed about 2 years ago

  • Related to Bug #45838: Improve validation for iocage jail CRUD methods added

#10 Updated by Waqar Ahmed about 2 years ago

  • Status changed from Blocked to In Progress

Yes we have taken note of the issue and it has been fixed in the latest nightlies. However if one jail fails, that shouldn't affect iocage's functionality, so we will be working on ensuring that iocage is functional at all times. If you have any other issues, please feel free to make a new ticket and we'll have it covered. Thank you!

#12 Updated by Waqar Ahmed about 2 years ago

  • Reason for Blocked deleted (Waiting for feedback)

#13 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug-freenas-20180918202637.txz)

#14 Updated by Dru Lavigne about 2 years ago

  • Private changed from Yes to No

#15 Updated by Waqar Ahmed about 2 years ago

  • Status changed from In Progress to Ready for Testing

#16 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Jails not visible in UI, can't start via CLI to Fix traceback when listing jails
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#18 Updated by Bonnie Follweiler almost 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreeNAS 11.2-INTERNAL24

#19 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

#20 Updated by Christopher Manns almost 2 years ago

41172
41181
41190

I don't think this is done, This continues to occur in RC2.
Specifically when migrating plex from a warden jail to the IOCAGE structure via the migrate_warden.py script.
"iocage list" from console reports the error messages as above.
Once the user leaves the web interface page the jail is no lo

#21 Updated by Dru Lavigne almost 2 years ago

Christopher: please open a new ticket with your RC2 information and a debug. Thanks!

Also available in: Atom PDF