Project

General

Profile

Bug #47598

Add banner to Plugins/Jails indicating that pre-11.2 installations will not appear in new UI

Added by Orion Mondragon over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When navigating to installed plugins and/or jails, either none or some are available to edit while most are not. I am unable to work in the new UI with my jails/plugins as I cannot see them in the UI but I am also limited because some settings are disabled in the new UI and require me to edit in the new UI where I cannot see them. Please assist in resolving this issue so I can properly manage my plugins and jails.

installed_jails_newUI.jpg (54.7 KB) installed_jails_newUI.jpg Orion Mondragon, 09/21/2018 06:50 AM
installed_jails_oldUI.jpg (40.6 KB) installed_jails_oldUI.jpg Orion Mondragon, 09/21/2018 06:50 AM
installed_plugins_newUI.jpg (33 KB) installed_plugins_newUI.jpg Orion Mondragon, 09/21/2018 06:50 AM
installed_plugins_oldUI.jpg (22.1 KB) installed_plugins_oldUI.jpg Orion Mondragon, 09/21/2018 06:50 AM
jails.png (49.3 KB) jails.png Warren Block, 10/22/2018 04:53 PM
31076
31087
31098
31109
36079

Related issues

Related to FreeNAS - Bug #53117: Plugins from 11.1 are not displayed in 11.2Closed

History

#1 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Orion: were the jails and plugins installed using the new UI or were they created on an earlier version of FreeNAS?

#2 Updated by Orion Mondragon over 1 year ago

Dru Lavigne wrote:

Orion: were the jails and plugins installed using the new UI or were they created on an earlier version of FreeNAS?

These jails were created via iocage prior to this beta and the installed apps were also installed previously. If I recall I was on 11.1-U2 when I created these jails/installed apps. Please let me know if there are any logs or other screenshots/outputs you would like to see and I would be happy to help. Thank you.

#3 Updated by Dru Lavigne over 1 year ago

  • Private changed from No to Yes

Orion: any jails/plugins created using iocage should appear in the UI. Please attach a debug (System -> Advanced -> Save debug) to this ticket.

#4 Updated by Orion Mondragon over 1 year ago

  • File debug.tgz added

Dru Lavigne wrote:

Orion: any jails/plugins created using iocage should appear in the UI. Please attach a debug (System -> Advanced -> Save debug) to this ticket.

Yes I agree that this should show up as well. Here is the log requested. Please let me know if there is anything else needed.

#5 Updated by Dru Lavigne over 1 year ago

  • Category changed from GUI (new) to Middleware
  • Status changed from Blocked to Unscreened
  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#6 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.2-RC2

#7 Updated by William Grzybowski over 1 year ago

Orion, how did you create the iocage plugins in 11.1?

Or did you only create the jails and installed the softwares by yourself?

#8 Updated by Orion Mondragon over 1 year ago

  • File nginx_certbot_conf.txt added
  • File radarr_config1.txt added
  • File radarr_config2.txt added
  • File sonarrConfig_1.txt added
  • File sonarrConfig_2.txt added
  • File tautulli_config.txt added

William Grzybowski wrote:

Orion, how did you create the iocage plugins in 11.1?

Or did you only create the jails and installed the softwares by yourself?

I have attached the configurations I used to create the jails in question. Please keep in mind that the plugins installed were simply done through the 11.1 UI by selecting the available plugins.

#9 Updated by William Grzybowski over 1 year ago

Orion Mondragon wrote:

William Grzybowski wrote:

Orion, how did you create the iocage plugins in 11.1?

Or did you only create the jails and installed the softwares by yourself?

I have attached the configurations I used to create the jails in question. Please keep in mind that the plugins installed were simply done through the 11.1 UI by selecting the available plugins.

Plugins installed in 11.1 UI are not supposed to show in new UI. Thats by design.

Now I am wondering if the ones installed via CLI should, since they are not official. I would think not?

#10 Updated by Orion Mondragon over 1 year ago

William Grzybowski wrote:

Orion Mondragon wrote:

William Grzybowski wrote:

Orion, how did you create the iocage plugins in 11.1?

Or did you only create the jails and installed the softwares by yourself?

I have attached the configurations I used to create the jails in question. Please keep in mind that the plugins installed were simply done through the 11.1 UI by selecting the available plugins.

Plugins installed in 11.1 UI are not supposed to show in new UI. Thats by design.

Now I am wondering if the ones installed via CLI should, since they are not official. I would think not?

So the two I am not seeing from the "jails" page are my "Jackett" jail and my "nginx-reverse" jail. Please see below:

root@Dragonfreenas:~ # jls
JID IP Address Hostname Path
1 jackett /mnt/vol0/jails/jackett
2 nginx-reverse /mnt/vol0/jails/nginx-reverse
3 plexmediaserver_2 /mnt/vol0/jails/plexmediaserver_2
4 transmission_1 /mnt/vol0/jails/transmission_1
8 sonarr /mnt/iocage/jails/sonarr/root
9 tautulli /mnt/iocage/jails/tautulli/root
10 radarr /mnt/iocage/jails/radarr/root

These jails were created by using the (old) UI to create a base jail. Then from CLI I created the two jails. I still find it odd that you would not allow me to see my installed plugins in the new UI. Basically you are telling me that I need to manage any older plugins by reverting to the old UI and then switching back to the new UI for anything else? I find it hard to understand why this would be a "solution" from any vendor. Also why would the jails under "/mnt/iocage/jails/*" show up and not jails created under "/mnt/vol0/jails/*"?

#11 Updated by William Grzybowski over 1 year ago

Orion Mondragon wrote:

William Grzybowski wrote:

Orion Mondragon wrote:

William Grzybowski wrote:

Orion, how did you create the iocage plugins in 11.1?

Or did you only create the jails and installed the softwares by yourself?

I have attached the configurations I used to create the jails in question. Please keep in mind that the plugins installed were simply done through the 11.1 UI by selecting the available plugins.

Plugins installed in 11.1 UI are not supposed to show in new UI. Thats by design.

Now I am wondering if the ones installed via CLI should, since they are not official. I would think not?

So the two I am not seeing from the "jails" page are my "Jackett" jail and my "nginx-reverse" jail. Please see below:

root@Dragonfreenas:~ # jls
JID IP Address Hostname Path
1 jackett /mnt/vol0/jails/jackett
2 nginx-reverse /mnt/vol0/jails/nginx-reverse
3 plexmediaserver_2 /mnt/vol0/jails/plexmediaserver_2
4 transmission_1 /mnt/vol0/jails/transmission_1
8 sonarr /mnt/iocage/jails/sonarr/root
9 tautulli /mnt/iocage/jails/tautulli/root
10 radarr /mnt/iocage/jails/radarr/root

These jails were created by using the (old) UI to create a base jail. Then from CLI I created the two jails. I still find it odd that you would not allow me to see my installed plugins in the new UI. Basically you are telling me that I need to manage any older plugins by reverting to the old UI and then switching back to the new UI for anything else? I find it hard to understand why this would be a "solution" from any vendor. Also why would the jails under "/mnt/iocage/jails/*" show up and not jails created under "/mnt/vol0/jails/*"?

Jails/Plugins in legacy UI are managed by warden
Jails/Plugins in new UI are managed by iocage

There is documentation and a script to convert warden jails to iocage jails but that is not going to be made automatically.

#12 Updated by Orion Mondragon over 1 year ago

William Grzybowski wrote:

Orion Mondragon wrote:

William Grzybowski wrote:

Orion Mondragon wrote:

William Grzybowski wrote:

Orion, how did you create the iocage plugins in 11.1?

Or did you only create the jails and installed the softwares by yourself?

I have attached the configurations I used to create the jails in question. Please keep in mind that the plugins installed were simply done through the 11.1 UI by selecting the available plugins.

Plugins installed in 11.1 UI are not supposed to show in new UI. Thats by design.

Now I am wondering if the ones installed via CLI should, since they are not official. I would think not?

So the two I am not seeing from the "jails" page are my "Jackett" jail and my "nginx-reverse" jail. Please see below:

root@Dragonfreenas:~ # jls
JID IP Address Hostname Path
1 jackett /mnt/vol0/jails/jackett
2 nginx-reverse /mnt/vol0/jails/nginx-reverse
3 plexmediaserver_2 /mnt/vol0/jails/plexmediaserver_2
4 transmission_1 /mnt/vol0/jails/transmission_1
8 sonarr /mnt/iocage/jails/sonarr/root
9 tautulli /mnt/iocage/jails/tautulli/root
10 radarr /mnt/iocage/jails/radarr/root

These jails were created by using the (old) UI to create a base jail. Then from CLI I created the two jails. I still find it odd that you would not allow me to see my installed plugins in the new UI. Basically you are telling me that I need to manage any older plugins by reverting to the old UI and then switching back to the new UI for anything else? I find it hard to understand why this would be a "solution" from any vendor. Also why would the jails under "/mnt/iocage/jails/*" show up and not jails created under "/mnt/vol0/jails/*"?

Jails/Plugins in legacy UI are managed by warden
Jails/Plugins in new UI are managed by iocage

There is documentation and a script to convert warden jails to iocage jails but that is not going to be made automatically.

Okay...could you maybe pass this information along? I'd be happy to run the scripts and verify that everything is working after.

#13 Updated by Orion Mondragon over 1 year ago

Orion Mondragon wrote:

William Grzybowski wrote:

Orion Mondragon wrote:

William Grzybowski wrote:

Orion Mondragon wrote:

William Grzybowski wrote:

Orion, how did you create the iocage plugins in 11.1?

Or did you only create the jails and installed the softwares by yourself?

I have attached the configurations I used to create the jails in question. Please keep in mind that the plugins installed were simply done through the 11.1 UI by selecting the available plugins.

Plugins installed in 11.1 UI are not supposed to show in new UI. Thats by design.

Now I am wondering if the ones installed via CLI should, since they are not official. I would think not?

So the two I am not seeing from the "jails" page are my "Jackett" jail and my "nginx-reverse" jail. Please see below:

root@Dragonfreenas:~ # jls
JID IP Address Hostname Path
1 jackett /mnt/vol0/jails/jackett
2 nginx-reverse /mnt/vol0/jails/nginx-reverse
3 plexmediaserver_2 /mnt/vol0/jails/plexmediaserver_2
4 transmission_1 /mnt/vol0/jails/transmission_1
8 sonarr /mnt/iocage/jails/sonarr/root
9 tautulli /mnt/iocage/jails/tautulli/root
10 radarr /mnt/iocage/jails/radarr/root

These jails were created by using the (old) UI to create a base jail. Then from CLI I created the two jails. I still find it odd that you would not allow me to see my installed plugins in the new UI. Basically you are telling me that I need to manage any older plugins by reverting to the old UI and then switching back to the new UI for anything else? I find it hard to understand why this would be a "solution" from any vendor. Also why would the jails under "/mnt/iocage/jails/*" show up and not jails created under "/mnt/vol0/jails/*"?

Jails/Plugins in legacy UI are managed by warden
Jails/Plugins in new UI are managed by iocage

There is documentation and a script to convert warden jails to iocage jails but that is not going to be made automatically.

Okay...could you maybe pass this information along? I'd be happy to run the scripts and verify that everything is working after.

specifically can you pass me the updated script? I see many bugs (now closed) related networking issues with the script so having the most updated version would be nice.

#15 Updated by Brandon Schneider over 1 year ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Behaves as Intended
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Orion: So the issue you're facing here is that you used quite old code to create these plugins far before they were stabilized :)

The easiest path forward is to recreate these plugins in BETA3 or newer. Otherwise, you can manually change /mnt/iocage/jails/<JAILNAME>/config.json's type to pluginv2 for each of those plugins. Though you will face significant issues in the future as they are not truly that type. Which means updating/upgrading will not function correctly. So I strongly urge you to recreate these plugins.

Thanks for the issue!

#16 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug.tgz)

#17 Updated by Dru Lavigne over 1 year ago

  • File deleted (nginx_certbot_conf.txt)

#18 Updated by Dru Lavigne over 1 year ago

  • File deleted (radarr_config1.txt)

#19 Updated by Dru Lavigne over 1 year ago

  • File deleted (radarr_config2.txt)

#20 Updated by Dru Lavigne over 1 year ago

  • File deleted (sonarrConfig_1.txt)

#21 Updated by Dru Lavigne over 1 year ago

  • File deleted (sonarrConfig_2.txt)

#22 Updated by Dru Lavigne over 1 year ago

  • File deleted (tautulli_config.txt)

#23 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Freenas installed plugins and Jails not all visible to Add banner to Plugins/Jails indicating that pre-11.2 installations will not appear in new UI
  • Category changed from Middleware to GUI (new)
  • Status changed from Closed to Screened
  • Assignee changed from Brandon Schneider to Release Council
  • Private changed from Yes to No

#24 Updated by Dru Lavigne over 1 year ago

  • Related to Bug #53117: Plugins from 11.1 are not displayed in 11.2 added

#25 Updated by Warren Block over 1 year ago

  • File jails.png jails.png added
  • Status changed from Screened to Unscreened
  • Assignee changed from Release Council to Dennis Mullen
36079

Add a note to Jails header explaining that legacy jails must be managed from the legacy web interface (which is a link).

Add a similar note for "legacy plugins" to the header on Plugins/Installed (but not Plugins/Available).

#26 Updated by Warren Block over 1 year ago

  • Needs Doc changed from No to Yes
  • Needs Merging changed from No to Yes

#27 Updated by Dennis Mullen over 1 year ago

  • Status changed from Unscreened to In Progress

#28 Updated by Dru Lavigne over 1 year ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#29 Updated by Bonnie Follweiler over 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Seen in FreeNAS-11.2-INTERNAL28 in both Installed Plugins and in the Jails screens: "Note: Legacy jails created before FreeNAS 11.2 must be managed from the legacy web interface."

#30 Updated by Timothy Moore II over 1 year ago

  • Needs Doc changed from Yes to No

Docs PR: [angulargui] https://github.com/freenas/freenas-docs/pull/414 . Warnings about jail and plugin management are already present in [master] branch guide, so no docs changes necessary.

#31 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF