Project

General

Profile

Bug #47884

replacing a failed USB device, member of freenas-boot, does not work from the GUI

Added by Bogdan Motoc 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

  • freenas-boot is a mirror of /dev/da0p2 and /dev/da1p2
  • /dev/da1 fails completely (not detected by OS anymore)
  • I plug in a new device, which is assigned /dev/da1
  • in the GUI I try to replace the failed device. The popup stays there for a good 15 seconds or so with "please wait" but then nothing really happens.

Here's what appears in /var/log/daemon.log
Sep 24 09:41:05 nas-steven zfsd: DEVFS: Notify cdev=da1p1 subsystem=CDEV timestamp=1537774865 type=CREATE
Sep 24 09:41:29 nas-steven zfsd: DEVFS: Notify cdev=da1p2 subsystem=CDEV timestamp=1537774889 type=CREATE

Here's /var/log/middlewared.log
[2018/09/24 07:40:53] (DEBUG) ZFSPoolService.get_disks():91 - Could not find disk for da1p2

And here's what appears in /var/log/debug.log
Sep 24 09:40:35 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: zpool status array1
Sep 24 09:40:35 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: zpool status freenas-boot
Sep 24 09:40:35 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: /usr/sbin/diskinfo da2
Sep 24 09:40:35 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: /usr/sbin/diskinfo ada0
Sep 24 09:40:35 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: /usr/sbin/diskinfo ada1
Sep 24 09:40:35 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: /usr/sbin/diskinfo da1
Sep 24 09:40:47 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: zpool status array1
Sep 24 09:40:47 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: zpool status freenas-boot
Sep 24 09:40:47 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: /usr/sbin/diskinfo da2
Sep 24 09:40:47 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: /usr/sbin/diskinfo ada0
Sep 24 09:40:47 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: /usr/sbin/diskinfo ada1
Sep 24 09:40:47 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: /usr/sbin/diskinfo da1
Sep 24 09:41:06 nas-steven /alert.py: [ws4py:360] Closing message received (1000) 'b'''
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: zpool status freenas-boot
Sep 24 09:41:30 nas-steven uwsgi: [freeadmin.navtree:114] Unable to import 'freenasUI.api' 'nav': No module named 'freenasUI.api.nav'
Sep 24 09:41:30 nas-steven uwsgi: [freeadmin.navtree:402] App freenasUI.api has no nav.py module, skipping
Sep 24 09:41:30 nas-steven uwsgi: [freeadmin.navtree:114] Unable to import 'freenasUI.freeadmin' 'nav': No module named 'freenasUI.freeadmin.nav'
Sep 24 09:41:30 nas-steven uwsgi: [freeadmin.navtree:402] App freenasUI.freeadmin has no nav.py module, skipping
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [common.warden:406] warden_base.__init__: cmd = list - flags = 0x00000001
Sep 24 09:41:30 nas-steven uwsgi: [common.warden:437] warden_base.__init__: args = -v
Sep 24 09:41:30 nas-steven uwsgi: [common.warden:443] warden_base.__init__: leave
Sep 24 09:41:30 nas-steven uwsgi: [common.warden:449] warden_base.run: enter
Sep 24 09:41:30 nas-steven uwsgi: [common.warden:458] warden_base.cmd = /usr/local/bin/warden list -v
Sep 24 09:41:30 nas-steven uwsgi: [common.cmd:189] cmd_pipe.__init__: cmd = /usr/local/bin/warden list -v, kwargs = {'pipeopen_kwargs': {}}
Sep 24 09:41:30 nas-steven uwsgi: [common.cmd:219] cmd_pipe.__init__: leave
Sep 24 09:41:30 nas-steven uwsgi: [common.warden:467] warden_base.run: leave
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [middleware.notifier:185] Popen()ing: route -nv show -inet6 default|grep 'interface:'|awk '{ print $2 }'
Sep 24 09:41:30 nas-steven uwsgi: [freeadmin.navtree:114] Unable to import 'freenasUI.documentation' 'nav': No module named 'freenasUI.documentation.nav'
Sep 24 09:41:30 nas-steven uwsgi: [freeadmin.navtree:402] App freenasUI.documentation has no nav.py module, skipping
Sep 24 09:41:30 nas-steven uwsgi: [freeadmin.navtree:114] Unable to import 'freenasUI.support' 'nav': No module named 'freenasUI.support.nav'
Sep 24 09:41:30 nas-steven uwsgi: [freeadmin.navtree:402] App freenasUI.support has no nav.py module, skipping
Sep 24 09:41:30 nas-steven uwsgi: [services.forms:1167] Failed to decrypt DDNS password
Traceback (most recent call last):
File "./freenasUI/services/models.py", line 1165, in _decrypt_password
self.ddns_password = notifier().pwenc_decrypt(self.ddns_password)
File "./freenasUI/middleware/notifier.py", line 3862, in pwenc_decrypt
encrypted = base64.b64decode(encrypted)
File "/usr/local/lib/python3.6/base64.py", line 87, in b64decode
return binascii.a2b_base64(s)
binascii.Error: Incorrect padding
Sep 24 09:42:06 nas-steven /alert.py: [ws4py:360] Closing message received (1000) 'b'''

These are the only files in /var/log that change.

I tried then the detach button. The error is in the attached screen capture.

What worked though, was to detach the dead device from command line and then add the new device via the GUI, as described in this forum thread:
https://forums.freenas.org/index.php?threads/cannot-replace-drive-on-boot-volume.59943/

1.png (57.2 KB) 1.png detach error message Bogdan Motoc, 09/24/2018 12:48 AM
31399

Related issues

Is duplicate of FreeNAS - Bug #29277: Wait for zfs.pool.extend to complete so we can propagate errors when adding a mirrored USB driveDone

History

#1 Updated by Dru Lavigne 8 months ago

  • Assignee changed from Release Council to William Grzybowski

#2 Updated by William Grzybowski 8 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

This seems like a duplicate of #29277

#3 Updated by William Grzybowski 8 months ago

  • Is duplicate of Bug #29277: Wait for zfs.pool.extend to complete so we can propagate errors when adding a mirrored USB drive added

Also available in: Atom PDF