Project

General

Profile

Bug #47965

Ensure an interface is selected when setting a jail's IP address in the new UI

Added by Bert Santema about 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When creating a jail and an IP address is entered, an IP interface must be chosen or the jail will not get an IP address as the default value is a text entry, not a valid interface. The GUI does not enforce setting an interface.

It is very easy to overlook setting the interface (as I've discovered).

The current jail creation screen allows you to enter an IP address without selecting an interface. This will never work.

I only tested with IPv4, but assume the behavior is the same for IPv6.

Logged this first (without recognizing the cause) on the forums: https://forums.freenas.org/index.php?threads/second-jail-with-vnet-get-no-ip-address-or-internet-access-11-2-beta-3.70106/#post-483928

IPv4 address without interface.png (49.1 KB) IPv4 address without interface.png Screen shot Bert Santema, 09/24/2018 12:55 PM
Screen Shot 2018-10-04 at 4.12.33 PM.png (59.9 KB) Screen Shot 2018-10-04 at 4.12.33 PM.png Bonnie Follweiler, 10/04/2018 01:14 PM
31582
33494

History

#1 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Lola Yang
  • Target version changed from Backlog to 11.2-RC1

#2 Updated by Lola Yang about 2 years ago

  • Status changed from Unscreened to In Progress

#3 Updated by Lola Yang about 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#4 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Jail creation: Interface dropdown should not accept empty/default value if an IP address is entered to Ensure an interface is selected when setting a jail's IP address in the new UI
  • Needs Doc changed from Yes to No

#5 Updated by Bonnie Follweiler almost 2 years ago

33494

FN FreeNAS-11.2-INTERNAL21 let me put in an IP and netmask with no interface. It saved and ran

#6 Updated by Lola Yang almost 2 years ago

Bonnie Follweiler wrote:

FN FreeNAS-11.2-INTERNAL21 let me put in an IP and netmask with no interface. It saved and ran

The interface is required only if VNET is checked and DHCP is unchecked, otherwise, the interface is optional

#7 Updated by Bonnie Follweiler almost 2 years ago

  • Status changed from Failed Testing to Passed Testing
  • Needs QA changed from Yes to No

After further discussion with Lola, I retested and it test passed in FreeNAS-11.2-INTERNAL21

#8 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF