Project

General

Profile

Bug #48075

Display passphrase field in new UI when replacing an encrypted disk

Added by Aaron St. John almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Seen in FreeNAS-11.2-MASTER-201809250855

Steps to reproduce:
1. Create a mirrored pool
2. Encrypt it and set a passphrase for it. Do not lock it.
3. Offline one of the disk.
4. Try to replace the disk.
5. Observe the bug. See screenshot.

It shows the text saying the field is required, but no field is present.

replace_pool_bug.png (34.4 KB) replace_pool_bug.png Aaron St. John, 09/25/2018 07:02 AM
Screen Shot 2018-10-30 at 1.13.08 PM.png (23.1 KB) Screen Shot 2018-10-30 at 1.13.08 PM.png Bonnie Follweiler, 10/30/2018 10:14 AM
31663
37473

Related issues

Related to FreeNAS - Bug #48107: replacing encrypted disk will not work because GELi provider is left in RAMClosed
Blocked by FreeNAS - Bug #48600: Fix APIv1 bug when replacing an encrypted diskDone

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Related to Bug #48107: replacing encrypted disk will not work because GELi provider is left in RAM added

#2 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from Erin Clark to Lola Yang
  • Target version changed from Backlog to 11.2-RC1

#3 Updated by Lola Yang almost 2 years ago

  • Blocks Bug #48600: Fix APIv1 bug when replacing an encrypted disk added

#4 Updated by Lola Yang almost 2 years ago

  • Blocks deleted (Bug #48600: Fix APIv1 bug when replacing an encrypted disk)

#5 Updated by Lola Yang almost 2 years ago

  • Blocked by Bug #48600: Fix APIv1 bug when replacing an encrypted disk added

#6 Updated by Lola Yang almost 2 years ago

  • Status changed from Unscreened to Blocked

#7 Updated by Dru Lavigne almost 2 years ago

  • Reason for Blocked set to Dependent on a related task to be completed

#8 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from 11.2-RC1 to 11.2-RC2

#9 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Blocked to Not Started
  • Reason for Blocked deleted (Dependent on a related task to be completed)

#10 Updated by Lola Yang almost 2 years ago

  • Status changed from Not Started to In Progress

#11 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Replacing a disk that has a passphrase set does not show passphrase fields to Display passphrase field in new UI when replacing an encrypted disk
  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#12 Updated by Bonnie Follweiler almost 2 years ago

37473

Test Passed in FreeNAS-11.2-INTERNAL31

#13 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF