Project

General

Profile

Bug #4843

samba won't show as started when configured as a domain controller

Added by Josh Paetzel over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

If I switch directory services from ---- to domain controller:

If CIFS is running when I do the switch then the GUI reports that it can't be stopped. If CIFS isn't running then it reports that it can't be started, however I can access CIFS shares, and the domain controller works.

In reality, it does start, however the GUI reports that the service could not be started, and the slider stays off. This causes a problem when rebooting the system, because then it doesn't try to start the service at boot.

Associated revisions

Revision 60f4c076 (diff)
Added by John Hixson over 5 years ago

Don't allow cifs to be stopped while running in DC mode Ticket: #4843

Revision 65b8e7fb (diff)
Added by John Hixson over 5 years ago

Don't allow cifs to be stopped while running in DC mode Ticket: #4843

History

#1 Updated by John Hixson over 5 years ago

  • Status changed from Unscreened to Screened

JOSH I AM UNABLE TO REPRODUCE THIS, HELP ME FIND THE WAY

#2 Updated by Josh Paetzel over 5 years ago

We looked at this yesterday. CIFS won't start because the domain controller starts the old samba server. However my anonymous shares broke.

#3 Updated by John Hixson over 5 years ago

  • Status changed from Screened to Resolved

Joshy-poo! I have a fix for you! 60f4c076cb6491daf0e01bbd186ab421f196ecca.

#4 Updated by Josh Paetzel over 5 years ago

  • Target version changed from 79 to 9.2.1.5-RELEASE

Also available in: Atom PDF