Project

General

Profile

Bug #4846

Update from 9.2.1.3 Fails

Added by Mark McBride over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Josh Paetzel
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I get the following in the web dialog when trying to upgrade from 9.2.1.3 to 9.2.1.4(.1):

Environment: Software Version: FreeNAS-9.2.1.3-RELEASE-x64 (dc0c46b) Request Method: POST Request URL: https://10.0.1.201/system/firmwizard/?X-Progress-ID=a33ce0d3-4c06-4899-899b-aeb6be1a9efd Traceback: File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response 107. response = middleware_method(request, callback, callback_args, callback_kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view 158. return login_required(view_func)(request, *view_args, **view_kwargs) File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in _wrapped_view 22. return view_func(request, *args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/views/generic/base.py" in view 69. return self.dispatch(request, *args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/contrib/formtools/wizard/views.py" in dispatch 236. response = super(WizardView, self).dispatch(request, *args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/views/generic/base.py" in dispatch 87. return handler(request, *args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/contrib/formtools/wizard/views.py" in post 297. return self.render_done(form, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/contrib/formtools/wizard/views.py" in render_done 350. done_response = self.done(final_form_list, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/system/forms.py" in done 170. retval = notifier().validate_update(path) File "/usr/local/www/freenasUI/../freenasUI/middleware/notifier.py" in validate_update 2513. stderr=subprocess.STDOUT, File "/usr/local/lib/python2.7/subprocess.py" in check_output 566. process = Popen(stdout=PIPE, *popenargs, **kwargs) File "/usr/local/lib/python2.7/subprocess.py" in init 709. errread, errwrite) File "/usr/local/lib/python2.7/subprocess.py" in _execute_child 1326. raise child_exception Exception Type: OSError at /system/firmwizard/ Exception Value: [Errno 2] No such file or directory

Turning off the "Use system dataset for syslog" in the advanced settings (per dlavigne's suggestion in irc) had no effect.


Related issues

Is duplicate of FreeNAS - Bug #4574: GUI Upgrades Fail (9.2.1.3) - TracebacksClosed: Duplicate2014-03-15

History

#1 Updated by Josh Paetzel over 5 years ago

  • Status changed from Unscreened to Screened
  • Assignee set to Josh Paetzel

You're a victim of the 9.2.1.3 reroll that happened hours after it was released to address this exact issue.

I'm on my phone and can't link a ticket right now, however there is a ticket with instructions on how to resolve this as well as a forum post in the 9.2.1.3 announcement thread.

#2 Updated by Josh Paetzel over 5 years ago

  • Status changed from Screened to Closed: Duplicate
  • Seen in changed from to 9.2.1.3-RELEASE

#3 Updated by Mark McBride over 5 years ago

I'm not sure this is a duplicate. The error in the original bug doesn't match mine. I was able to upgrade from 9.2.1.2 to 9.2.1.3. The failure was to .4 ... I tried the "fix" script noted in the .2 release notes and these didn't help.

#4 Updated by William Grzybowski over 5 years ago

  • Status changed from Closed: Duplicate to Investigation

That is indeed another error.

It seems like the extract is not working. Do you have enough space in the pool for the upgrade? (paste zfs list)
Can you attach the output of "ls -l /var/tmp/firmware/" as well?

Thank you

#5 Updated by Mark McBride over 5 years ago

zfs list shows 690G available.

as for /var/tmp/firmware/ ...

# ls -l /var/tmp/firmware/
total 163615
drwxr-xr-x  8 www     1011           11 Apr 21 22:14 ./
drwxr-xr-x  6 nobody  nobody          6 Apr 21 22:13 ../
drwxr-xr-x  2 root    1011            2 Apr 20 14:57 .mount/
-rw-r--r--  1 1011    1011           70 Mar 10 21:37 .mount.conf
-rw-r--r--  1 root    1011    167341228 Apr 20 14:50 FreeNAS-x64.img.xz
drwxr-xr-x  7 root    wheel          45 Apr 20 14:58 boot/
drwxr-xr-x  2 root    1011            3 Apr 20 14:58 data/
drwxr-xr-x  2 root    1011            2 Apr 20 14:57 dev/
-rw-r--r--  1 root    1011            0 Mar 29 10:09 firmware.img
drwxr-xr-x  2 root    1011            2 Apr 20 14:57 mnt/
drwxr-xr-x  2 root    1011            2 Apr 20 14:57 tmp/

#6 Updated by William Grzybowski over 5 years ago

That sounds awfully wrong. What is the exact image you're using to upgrade?

Also, please send the output of "mount" command.

Thank you

#7 Updated by Mark McBride over 5 years ago

I've tried to upgrading to ...

FreeNAS-9.2.1.4-RELEASE-x64.iso
FreeNAS-9.2.1.4.1-RELEASE-x64.iso

My build is (from the System Information tab) ...

FreeNAS-9.2.1.3-RELEASE-x64 (dc0c46b)

mount yields (where Hitachi_2009 is my zfs volume) ...

/dev/ufs/FreeNASs2a on / (ufs, local, read-only)
devfs on /dev (devfs, local, multilabel)
/dev/md0 on /etc (ufs, local)
/dev/md1 on /mnt (ufs, local)
/dev/md2 on /var (ufs, local)
/dev/ufs/FreeNASs4 on /data (ufs, local, noatime, soft-updates)
Hitachi_2009 on /mnt/Hitachi_2009 (zfs, NFS exported, local, nfsv4acls)
Hitachi_2009/.system on /mnt/Hitachi_2009/.system (zfs, local, nfsv4acls)
Hitachi_2009/.system/cores on /mnt/Hitachi_2009/.system/cores (zfs, local, nfsv4acls)
Hitachi_2009/.system/samba4 on /mnt/Hitachi_2009/.system/samba4 (zfs, local, nfsv4acls)
Hitachi_2009/.system/syslog on /mnt/Hitachi_2009/.system/syslog (zfs, local, nfsv4acls)
Hitachi_2009/jails on /mnt/Hitachi_2009/jails (zfs, local, nfsv4acls)
Hitachi_2009/jails/.warden-template-pluginjail on /mnt/Hitachi_2009/jails/.warden-template-pluginjail (zfs, local, nfsv4acls)

#8 Updated by William Grzybowski over 5 years ago

You need to upgrade using the GUI_Upgrade.txz images, not .iso files.

#9 Updated by Mark McBride over 5 years ago

son of a ...

thanks :)

#10 Updated by Josh Paetzel over 5 years ago

  • Status changed from Investigation to Resolved
  • Target version set to 9.2.1.5-RELEASE

We've added logic to deny gui upgrades using the iso file.

Also available in: Atom PDF