Project

General

Profile

Bug #4849

Error produced when trying to wipe a hard drive in the GUI under view disks page

Added by Lane Campbell over 5 years ago. Updated over 5 years ago.

Status:
Closed: Duplicate
Priority:
Important
Assignee:
-
Category:
-
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Here is a link to see a picture of the popup window that we see with all the error messages: http://clicky.strapr.com/image/0o2P3V1V2S3R

This is the body of the error:

@Environment:

Software Version: FreeNAS-9.2.1.4-BETA-3d250fe-x64
Request Method: POST
Request URL: http://10.80.8.30/storage/disks/wipe/da0/

Traceback:
File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
107. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view
158. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
22. return view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/storage/views.py" in disk_wipe
869. for geom in notifier().disk_get_consumers(devname):
File "/usr/local/www/freenasUI/../freenasUI/middleware/notifier.py" in disk_get_consumers
4558. provid = geom0.xpath("./provider/@id")[0].text

Exception Type: AttributeError at /storage/disks/wipe/da0/
Exception Value: '_ElementStringResult' object has no attribute 'text'
@


Related issues

Is duplicate of FreeNAS - Bug #4833: Traceback doing a disk wipeResolved2014-04-18

History

#1 Updated by Josh Paetzel over 5 years ago

  • Status changed from Unscreened to Closed: Duplicate
  • Target version set to 92

Already reported and fixed. Update to version 9.2.1.4.1

http://download.freenas.org/9.2.1.4.1/RELEASE/x64/

#2 Updated by Lane Campbell over 5 years ago

Roger that. I'll make the upgrade happen now.

#3 Updated by Jordan Hubbard over 5 years ago

  • Target version changed from 92 to 9.2.1.5-RELEASE

Also available in: Atom PDF