Project

General

Profile

Feature #48658

API to set/update wedav certifcate

Added by c56ebc82 632b 10 months ago. Updated 8 months ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

I'm currently using deploy-freenas to automate certificate renewals and it would be nice to have the possibility to set a new certificate for the webdav service as well.

http://api.freenas.org/resources/system.html#certificate
https://github.com/danb35/deploy-freenas


Related issues

Is duplicate of FreeNAS - Feature #32472: Convert Sharing:WebDav to MiddlewaredDone

History

#1 Updated by Dru Lavigne 10 months ago

  • Assignee changed from Release Council to William Grzybowski

#2 Updated by William Grzybowski 10 months ago

  • Status changed from Unscreened to Not Started
  • Target version changed from Backlog to 11.3
  • Severity changed from New to Medium

#3 Updated by William Grzybowski 8 months ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.3 to N/A
  • Reason for Closing set to Duplicate Issue

This will be possible in v2 API.

#4 Updated by William Grzybowski 8 months ago

  • Is duplicate of Feature #32472: Convert Sharing:WebDav to Middlewared added

Also available in: Atom PDF