Project

General

Profile

Bug #49565

Add autofs kernel module to build

Added by Janus Ng 11 months ago. Updated 5 months ago.

Status:
Done
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

autofs is malfunction.

  • Procedures to reproduce:
    1. add the following line to /conf/base/etc/rc.conf
      autofs_enable="YES" 
      
    2. uncomment the following line in /conf/base/etc/auto_master
      /media -media -nosuid,noatime
      
    3. restart FreeNAS
    4. plug a USB thumb drive into the server
    5. issue the following command in ssh
      $ ls -l /media
      
  • Expected result:
    1. the content of the USB thumb drive is listed.
  • Actual result:
    1. total 0
    2. the following lines are added to the /var/log/messages
      Oct  3 16:10:15 freenas root: /etc/rc: WARNING: Unable to load kernel module autofs
      Oct  3 16:10:15 freenas root: /etc/rc: WARNING: failed precmd routine for automountd
      Oct  3 16:10:15 freenas root: /etc/rc: WARNING: Unable to load kernel module autofs
      

Associated revisions

Revision e37fc50d (diff)
Added by Alexander Motin 10 months ago

Add autofs kernel module to the build.

Ticket: #49565

History

#1 Updated by Janus Ng 11 months ago

Additional information.

# service automount restart
kldload: can't load autofs: No such file or directory
/etc/rc.d/automount: WARNING: Unable to load kernel module autofs

#2 Updated by Dru Lavigne 10 months ago

  • Assignee changed from Release Council to Alexander Motin

#3 Updated by Alexander Motin 10 months ago

  • Status changed from Unscreened to Ready for Testing
  • Target version changed from Backlog to 11.3
  • Severity changed from New to Low
  • Needs Merging changed from Yes to No

I've added autofs kernel module to the build: https://github.com/freenas/build/commit/e37fc50d3ca4b5a18b5efeaaa09e1a818ccae51a . Janus, you may try it in some following nightly build of 11.3.

Also `autofs_enable="YES"` variable can be set via WebUI, no need to modify the rc.conf file.

QA: Minimal testing for this could be just `kldload autofs` not failing. We don't plan to provide deeper support for this functionality now.

#4 Updated by Dru Lavigne 10 months ago

  • Subject changed from autofs failed to Add autofs kernel module to build

#5 Updated by Janus Ng 10 months ago

I don't have spare machine for installing 11.3 nightly build yet. Let me find get a virtual machine to test it out later.

Thanks!

#6 Updated by Janus Ng 10 months ago

On a second look, 11.3 is still 10 months away.

As this fix has already been done, is there any particular reason not to put it onto 11.2?

#7 Updated by Alexander Motin 10 months ago

We do not expect 11.3 to take 10 month, hoping for 3. I do not hurry to merge this to 11.2, since it is already in RC stage now, and this is a very rare functionality. I think I could merge this into some later 11.2 update.

#8 Updated by Dru Lavigne 7 months ago

  • Target version changed from 11.3 to 11.3-BETA1

#9 Updated by Alexander Motin 6 months ago

  • Status changed from Ready for Testing to Passed Testing

QE:

root@freenas:~ # service automount onestart
root@freenas:~ # kldstat |grep autofs
26    1 0xffffffff82e27000 4028     autofs.ko

#10 Updated by Dru Lavigne 5 months ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No

#11 Updated by Dru Lavigne 5 months ago

  • Target version changed from 11.3-BETA1 to 11.3-ALPHA1

Also available in: Atom PDF