Project

General

Profile

Bug #4974

Freenas 64 bit is not working

Added by Damian Tomaszewski about 5 years ago. Updated about 5 years ago.

Status:
Closed: Behaves correctly
Priority:
Nice to have
Assignee:
Damian Tomaszewski
Category:
OS
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi
Freenas 64 bit version is not working. After installing it on usb and booting from it, system is not starting. There is some error about data base. Its on latest version 9.2.1.5.
Please check this its frustrating. I downloaded file using different PC, diffrent internet connection, installed it on two different usb's. All the time I'm getting same error

IMG_1585[1].JPG (1.75 MB) IMG_1585[1].JPG Damian Tomaszewski, 05/09/2014 05:03 PM
829

History

#1 Updated by Anonymous about 5 years ago

  • Status changed from Unscreened to Closed: Insufficient Info
  • Priority changed from Critical to Nice to have

This ticket isn't actionable unless you can provide more information.

Can you please post the error message you are receiving about the database and a summary of your system configuration?

#2 Updated by Damian Tomaszewski about 5 years ago

829

My system set up is AMD Athlon 2.6GHz 64bit 6GB 1333MHz DDR3 RAM 500gb sata hdd. Screen shot of error is attached.I'm getting same error if I install freenas from USB image.

#3 Updated by Anonymous about 5 years ago

That message doesn't have anything about the database, its a disk mount error (can't find the installation once the kernel boots). I can see the stick was detected as da0.

Looks like you used the USB stick for something else that used a GPT type partition table. FreeNAS is finding the backup table and thinks the USB stick is corrupted and won't mount it so it doesn't destroy something by accident. Can you try completely erasing the stick (zero over all the blocks or delete the GPT partition table) and install FreeNAS again? If you can boot a FreeBSD live CD or USB image, you can remove it by running:

gpart recover da1
gpart destroy -F da1

assuming da1 is the stick you are trying to install FreeNAS to.

#4 Updated by gear head about 5 years ago

Damian, are you using a usb 3.0 port? if so try a usb 2.0 port.

#5 Updated by hans magnusson about 5 years ago

The screen shot is something I see too with versions 9.2.1.3, 9.2.1.4. I attributed the failure to the XHCI driver problem mentioned somewhere. After power cycling once or twice I usually get past this. There is no information to get out of the machine when the failure occurs since there is no logging to disk nor can you type in any commands at the mountroot> prompt.

On another note I have tried 9.2.1.5 from a 8GB USB stick and it does not work on my setup. There's nothing in the log files to look at. Is there some way to get more log messages saved to disk?

#6 Updated by Damian Tomaszewski about 5 years ago

Doug White advice was correct. After deleting GPT table Freenas did boot up. This case can be closed now, however NAS4free works much better. Maybe later I will switch to freenas. Thank you for your all help.

#7 Updated by Josh Paetzel about 5 years ago

  • Status changed from Closed: Insufficient Info to Closed: Behaves correctly

Broken GPT table from a previous install was horking FreeNAS.

Also available in: Atom PDF