Project

General

Profile

Bug #49851

Update default "Size of Docker Disk File" in legacy UI to 20 GiB

Added by Timothy Moore II over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Timothy Moore II
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm testing creating and configuring a Docker VM with Rancher. I created Docker VM "Rancher UI" and verified the VM devices were configured correctly. I started the VM, opened the Shell, and tried to connect to the VM with the cu -l /dev/{com port} command. The command returns "Connected", but the Shell freezes at this point and nothing else happens. I also set up SSH and tried to connect to the VM using SSH, but I see the same behavior. Connecting to a Docker VM created in the new functions as expected.

Attempting to restart the VM and reconnect results in an "all ports are busy" message.

Discuss with Kris and one suggestion is to disable all Docker VM functionality in the legacy UI.

History

#1 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Dru Lavigne to William Grzybowski
  • Seen in set to Master - FreeNAS Nightlies

#2 Updated by William Grzybowski over 1 year ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Why are you mentioning legacy UI? Does it work on new UI?

It doesnt really make sense, the implementation is the same.

Are you running in a bare metal machine?

#3 Updated by Timothy Moore II over 1 year ago

William Grzybowski wrote:

Why are you mentioning legacy UI? Does it work on new UI?

It doesnt really make sense, the implementation is the same.

Are you running in a bare metal machine?

I tested it with a bare metal FreeNAS system that is on an RC1 Internal release now, but was most likely on the 10-2 or 10-3 FreeNAS 11 nightly at the time.

I was documenting the process to create and configure a Docker Host with Rancher on the New UI, which did work for me when I tested it. Because of the goal of feature parity for the 11.2 release, I have to check the legacy UI to see if the same functionality exists in legacy and update our legacy UI documentation if the legacy implementation has changed. All of the Docker VM functionality appears to be present in the legacy UI, so I attempted to get Rancher up and running using only the legacy UI. It didn't work and as you pointed out, doesn't really make sense that it didn't work, so I reported what happened and provided a debug.

#4 Updated by William Grzybowski over 1 year ago

Timothy Moore II wrote:

William Grzybowski wrote:

Why are you mentioning legacy UI? Does it work on new UI?

It doesnt really make sense, the implementation is the same.

Are you running in a bare metal machine?

I tested it with a bare metal FreeNAS system that is on an RC1 Internal release now, but was most likely on the 10-2 or 10-3 FreeNAS 11 nightly at the time.

I was documenting the process to create and configure a Docker Host with Rancher on the New UI, which did work for me when I tested it. Because of the goal of feature parity for the 11.2 release, I have to check the legacy UI to see if the same functionality exists in legacy and update our legacy UI documentation if the legacy implementation has changed. All of the Docker VM functionality appears to be present in the legacy UI, so I attempted to get Rancher up and running using only the legacy UI. It didn't work and as you pointed out, doesn't really make sense that it didn't work, so I reported what happened and provided a debug.

I dont see anything in the logs and cant reproduce it. Rancher does start up just fine for me. How much RAM did you use?
Can you reproduce and give remote access?

#5 Updated by Timothy Moore II over 1 year ago

  • Status changed from Blocked to Closed
  • Reason for Closing set to User Configuration Error
  • Reason for Blocked deleted (Need additional information from Author)

I dont see anything in the logs and cant reproduce it. Rancher does start up just fine for me. How much RAM did you use?
Can you reproduce and give remote access?

Went back and retested and discovered that it does work, I just had the raw file size set too low.

#6 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-megamini-20181004113909.tgz)

#7 Updated by Dru Lavigne over 1 year ago

  • Target version changed from Backlog to N/A
  • Private changed from Yes to No

#8 Updated by William Grzybowski over 1 year ago

  • Status changed from Closed to In Progress
  • Target version changed from N/A to 11.2-RC2
  • Reason for Closing deleted (User Configuration Error)

Lets use this ticket to update the default size as you suggested.

https://github.com/freenas/freenas/pull/1881
https://github.com/freenas/freenas/pull/1882

#9 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Timothy Moore II

#10 Updated by Timothy Moore II over 1 year ago

  • Subject changed from Legacy UI: Docker VM freezes after connecting with cu -l command to Legacy UI: update initial suggested value for a Docker VM raw file
  • Assignee changed from Timothy Moore II to William Grzybowski
  • Target version changed from 11.2-RC2 to Backlog
  • Reason for Closing set to User Configuration Error

#11 Updated by Timothy Moore II over 1 year ago

  • Assignee changed from William Grzybowski to Timothy Moore II
  • Target version changed from Backlog to 11.2-RC2
  • Reason for Closing deleted (User Configuration Error)

#12 Updated by William Grzybowski over 1 year ago

  • Status changed from In Progress to Ready for Testing

#13 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Legacy UI: update initial suggested value for a Docker VM raw file to Update default "Size of Docker Disk File" in legacy UI to 20 GiB
  • Needs Merging changed from Yes to No

#14 Updated by Dru Lavigne over 1 year ago

  • Needs Doc changed from No to Yes

#16 Updated by Jeff Ervin over 1 year ago

36297

Test Passed FreeNAS-11.2-INTERNAL27

#17 Updated by Timothy Moore II over 1 year ago

  • Needs Doc changed from Yes to No

Docs PR: [master] https://github.com/freenas/freenas-docs/pull/416/files, no [angulargui] PR necessary.

#18 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF