Project

General

Profile

Bug #5018

Can't boot upgrade to 9.2.1.5

Added by Horacio B over 5 years ago. Updated over 5 years ago.

Status:
Closed: Behaves correctly
Priority:
Nice to have
Assignee:
-
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have FreeNAS-8.0.4-RELEASE-p1-x86 (11059) trying to upgrade to 9.2.1.5. I have confirmed that I have a good 9.2.1.5 x86 iso by checking the SHA256 number. When I boot from the CD I would eventually get this error message and it repeats a few times:

(cd0:ata0:0:0:0) Error 6, Unretryable error
(cd0:ata0:0:0:0) cddone: got error 0x6 back
(cd0:ata0:0:0:0) Read(10) 28 00 00 01 99 6d 00 00 01 00
(cd0:ata0:0:0:0) CAM status: SCSI status Error
(cd0:ata0:0:0:0) SCSI status: Check Condition
(cd0:ata0:0:0:0) SCSI sense: Illegal Request asc:64, 0 (Illegal mode for this track)

There are no SCSI hard drives only SATA hard drives.

GEOM_MIRROR : Cancelling unmapped because of ada1
GEOM_MIRROR : Cancelling unmapped because of ada0

It eventually boots into the upgrade/install screen.
I follow the direction from the Upgrading FreeNas guide from doc.freenas.org.
When I confirm to upgrade I get this error:

install_worker2.sh: ERROR: could not load the avatar.conf file from the destination directory (/var/tmp/data/etc)
The FreeNAS upgrade on ada2 has failed. Press any key to continue...

Computer Specs:
Dell GX280
Intel Pentium 4 2.8 GHz
RAM 4 GB DDR2
SAMSUNG CD-ROM SC-148A B403 is IDE
40 GB Western Digital SATA Hard Drive <- FreeNAS 8.0.4 installed; ada2
Fasttrak TX4310 PCI Raid Card
- 2 Seagate 1TB SATA hard drives in Raid 1(same model number); ada0 and ada1

History

#1 Updated by Anonymous over 5 years ago

Your CD drive is having trouble reading the install disc. All other problems are subsequent to that issue.

Try re-burning the disc, ensuring you use Disc-at-once mode, or try a different type/brand of blank disc.

You might also check with your hardware vendor (Dell) for a ODD firmware update.

#2 Updated by Anonymous over 5 years ago

  • Status changed from Unscreened to Closed: Behaves correctly

#3 Updated by Horacio B over 5 years ago

I re-burn the disk using Disc-at-once mode.
This time I did not get the CD errors.
Again I follow the direction from the Upgrading FreeNas guide from doc.freenas.org.
When I confirm to upgrade I still get this error:

install_worker2.sh: ERROR: could not load the avatar.conf file from the destination directory (/var/tmp/data/etc)
The FreeNAS upgrade on ada2 has failed. Press any key to continue...

I looked up the directory on the machine and /var/tmp exist but there is no sub-directory data or etc.

Also available in: Atom PDF