Project

General

Profile

Bug #5024

Cannot install any plugin on FreeNAS 9.2.1.5

Added by Frits Jalvingh about 5 years ago. Updated about 5 years ago.

Status:
Closed: Cannot reproduce
Priority:
Nice to have
Assignee:
-
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Just installed FreeNAS 9.2.1.5 and trying to install any plugin.

I first ran into bug# 4903, and used the "arden template create -nick pluginjail -tar xxx" command to create the jail template.

But any plugin I try to install (except transmission which has a download failure) does create a jail but then aborts with:
Environment:

Software Version: FreeNAS-9.2.1.5-RELEASE-x64 (80c1d35)
Request Method: POST
Request URL: http://192.168.1.19/plugins/plugin/install/648f4e421046815ae764ae7700df9150d8b505aa6e5ab974aeaf54155d08899d/

Traceback:
File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response
107. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view
158. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
22. return view_func(request, *args, **kwargs)
File "/usr/local/www/freenasUI/../freenasUI/plugins/views.py" in install_available
254. jail = new_default_plugin_jail(plugin.unixname)
File "/usr/local/www/freenasUI/../freenasUI/jails/utils.py" in new_default_plugin_jail
644. with open('%s/.plugins/PLUGIN' % jaildir, 'w') as f:

Exception Type: IOError at /plugins/plugin/install/648f4e421046815ae764ae7700df9150d8b505aa6e5ab974aeaf54155d08899d/
Exception Value: [Errno 2] No such file or directory: u'/mnt/pool0/jails/maraschino_1/.plugins/PLUGIN'

I also tried 9.2.1.6 beta but it has the same trouble.

History

#1 Updated by Joe Maloney about 5 years ago

Not yet sure if this is related as I haven't had time yet to test on bare-metal system and I've been testing to see how functional bhyve was. This is when trying to install a plugin in a bhyve FreeNAS instance running 9.2.1.6 beta:

May 18 22:57:10 files01 manage.py: [common.pipesubr:58] Popen()ing: /sbin/ping -q -t 2 -o 10.11.0.30
May 18 22:57:15 files01 manage.py: [common.pipesubr:58] Popen()ing: /sbin/ping -q -t 2 -o 10.11.0.30
May 18 22:57:24 files01 manage.py: [middleware.exceptions:38] [MiddlewareError: Failed to download plugin]
May 18 22:58:24 files01 manage.py: [common.pipesubr:58] Popen()ing: /sbin/ping -q -t 2 -o 10.11.0.30
May 18 22:58:29 files01 manage.py: [common.pipesubr:58] Popen()ing: /sbin/ping -q -t 2 -o 10.11.0.30
May 18 22:58:58 files01 manage.py: [middleware.exceptions:38] [MiddlewareError: Failed to download plugin]

#2 Updated by Jordan Hubbard about 5 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce

I'm able to install plugins on 9.2.1.6-BETA (FreeNAS-9.2.1.6-BETA-e57badf-x64) without problems. Suspect some local misconfiguration issue.

#3 Updated by Frits Jalvingh about 5 years ago

That's odd, because it was done in clean installations and failed in 9.2.1.5, 9.2.1.6, 9.2.1.3. Plugin installation works properly in 9.2.0, which I am now using (also to fix a very bad zfs incompatibility that is in the newer versions).

#4 Updated by jvd-nl - about 5 years ago

I got the same issue after upgrading from 9.1.1 to 9.2.1.5 (GUI upgrade using the .txz file).

First I did the trick with renaming the ZFS mountpoint after upgrading:
zfs rename storage/jails/.warden-template-9.1-RELEASE-amd64-pluginjail storage/jails/.warden-template-pluginjail
zfs inherit mountpoint storage/jails/.warden-template-pluginjail

After this, installing plugins failed with the error above.

Also available in: Atom PDF