Project

General

Profile

Bug #5028

Issues using pkg add

Added by Peter Capp over 5 years ago. Updated over 5 years ago.

Status:
Closed: Behaves correctly
Priority:
Nice to have
Assignee:
-
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Raising this as a bug bug now as more people are reporting this problem.

Raised on the FreeNAS forum under http://forums.freenas.org/index.php?threads/issues-using-pkg-add.19313/#post-121213

Hi all

Having issues using pkg add command, can anyone shed a light on this error "no manifest found"?

root@mythweb:/ # pkg add ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8.4-release/multimedia/mythtv-0.26.0.tbzmythtv-0.26.0.tbz 100% 153MB 1.2MB/s 740.4KB/s 02:12
pkg: /tmp/mythtv-0.26.0.tbz.C41AP is not a valid package: no manifest found
It is clear that I did not request the package as detailed above so I am wondering where the mix up is?
Failed to install the following 1 package(s): ftp://ftp.freebsd.org/pub/FreeBSD/ ports/amd64/packages-8.4-release/multimedia/mythtv-0.26.0.tbz
when I look in /tmp/ I see the package but it's been renamed somehow to
mythtv-0.26.0.tbz.91yuA

I have tried all 3 commands

pkg add
pkg install
pkg fetch
and none work, I even printed the responses after the command is executed...
But the old command version of pkg_add -r mythtv worked (until the package was removed from the pkg list) and pkg_add -r ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-8.4-release/multimedia/mythtv-0.26.0.tbz still works!
I am just trying to use the replacement command set and telling you it does not work in this case.
Whether you want to fix that or not is up to you guys, I'll just carry on using the old version until you remove it in a future build.

History

#1 Updated by Peter Capp over 5 years ago

Sorry but some of this was copied from the issue raised.

The problem still persists in 9.1.2.5 release

#2 Updated by Jordan Hubbard over 5 years ago

  • Status changed from Unscreened to Closed: Behaves correctly

You are attempting to use 9.x package tools with 8.x packages. The package format in FreeBSD has changed. See "pkgng" discussions on Google.

Also available in: Atom PDF