Project

General

Profile

Bug #5036

Update BTSync Plugin to 1.3.105

Added by Joshua Ruehlig over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Nice to have
Assignee:
Sean Fagan
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Please update this plugin; PBI is attached.
Thanks,

  • BTSync 1.3.94 > 1.3.105 - Updated to latest version of BTSync

Note
Upgrades may or may not work because I changed the user this service runs as from 'btsync' to 'sync'. The UID of said user didn't change (still 817) so file permissions shouldn't be an issue. I changed the username because I am working on another plugin for 'Syncthing' and these two plugins will both use the user/group='sync' and UID/GID=817.

btsync-1.3.105-amd64.pbi (19.6 MB) btsync-1.3.105-amd64.pbi Joshua Ruehlig, 05/19/2014 08:06 PM
btsync-1.3.106-amd64.pbi (19.6 MB) btsync-1.3.106-amd64.pbi Joshua Ruehlig, 06/19/2014 01:11 AM
btsync-1.3.106-amd64.pbi (19.6 MB) btsync-1.3.106-amd64.pbi Joshua Ruehlig, 07/02/2014 11:31 PM

Related issues

Is duplicate of FreeNAS - Feature #5437: Btsync - please update to 1.3.106Closed2014-07-04

History

#1 Updated by Jordan Hubbard over 6 years ago

  • Category set to 33
  • Assignee set to Sean Fagan
  • Target version set to 49

Not sure how the plugin upgrade process permutes the password database of the jail it's installed in, so that's hard for me to say. Over to Sean to investigate both updating this and figuring out how upgrades will work.

#2 Updated by Sean Fagan over 6 years ago

  • Status changed from Unscreened to Screened

I'd avoid a name like "sync", since it's too generic, too ripe for conflict, and, worst of all, is the name of a unix command.

#3 Updated by Joshua Ruehlig over 6 years ago

Sean Fagan wrote:

I'd avoid a name like "sync", since it's too generic, too ripe for conflict, and, worst of all, is the name of a unix command.

how about 'syncuser', otherwise do you have a suggestion? I can recompile this and the syncthing plugin once we decide on something.

or I could just leave it as 'btsync'. it shouldn't make a difference cause outside of the jail the user is just a UID

#4 Updated by Sean Fagan over 6 years ago

  • Assignee changed from Sean Fagan to Joshua Ruehlig

Do you want to make that change, or should I just update this one? I've held off on syncthing because of the user issue.

Thanks.

#5 Updated by Joshua Ruehlig over 6 years ago

let's figure out a name before uploading thing pbi. I'll think about this tonight.

#6 Updated by Joshua Ruehlig over 6 years ago

@Sean Fagan
Ok here's what I have thus far..

syncuser ~ a group named the same thing might look weird
_sync ~ almost like sync but not exactly so people don't get confused, I've seen some other ports use this
syncd ~ specifying the user runs a daemon that syncs stuff
syncer / syncy / syncie ~ these are all cute

I am leaning with 'syncd', what do you think?

#7 Updated by Joshua Ruehlig over 6 years ago

actually I think I'll go with the user and group 'syncer' unless you don't like it. I'll recompile and re-upload soon.

#8 Updated by Joshua Ruehlig over 6 years ago

Ok I..
  • changed the user to 'syncer', same UID/GID=817
  • updated to the latest version 1.3.106
  • added the newish 'external port' setting to this plugin's menu

Please use the attached PBI, thanks

#9 Updated by Joshua Ruehlig about 6 years ago

Actually, please use the attached PBI.
I ended up still using the 'btsync' user, UID/GID=816. This is because this is how it was recommended when my port was reviewed for the FreeBSD ports tree (it got added a few days ago).

This PBI shouldn't cause any issues when users update because the ones using the 'syncer' user/group never hit the repos.

#10 Updated by Sean Fagan about 6 years ago

  • Is duplicate of Feature #5437: Btsync - please update to 1.3.106 added

#11 Updated by Sean Fagan about 6 years ago

  • Status changed from Screened to Closed

Okay, working on 5036 right now. Closing this one as a duplicate, thanks :).

#12 Updated by Sean Fagan about 6 years ago

  • Status changed from Closed to Fix In Progress
  • Assignee changed from Joshua Ruehlig to Sean Fagan

Working on it now.

#13 Updated by Sean Fagan about 6 years ago

Okay, it should show up "soon." (I truly have no idea how any of this works, you know ;).)

I'll remind myself to check from home later tonight.

#14 Updated by Sean Fagan about 6 years ago

  • Status changed from Fix In Progress to Closed

And there it is.

#15 Updated by Joshua Ruehlig about 6 years ago

Sean Fagan wrote:

And there it is.

Hmm, I still only see 1.3.94 even after refreshing the repo.
I don't see 1.3.106 on this page > http://www.freenas.org/downloads/plugins/9/x64/
Also this file still mentions 1.3.94 > http://www.freenas.org/downloads/plugins/9/x64/pbi-meta/pbi-index-9.bz2

Might be an issue with my local mirror? Either way, thanks for the effort.

#16 Updated by Sean Fagan about 6 years ago

Might be; as I said, I'm not sure how it all works :).

I checked on my FreeNAS boxes at home, and it saw 1.3.106.

#17 Updated by Joshua Ruehlig about 6 years ago

Sean Fagan wrote:

Might be; as I said, I'm not sure how it all works :).

I checked on my FreeNAS boxes at home, and it saw 1.3.106.

No worries, I'm in no rush.

#18 Updated by Jordan Hubbard about 6 years ago

I also see 1.3.106. I suspect a local misconfiguration problem.

#19 Updated by Joshua Ruehlig about 6 years ago

Jordan Hubbard wrote:

I also see 1.3.106. I suspect a local misconfiguration problem.

K, I believe you guys. I'm guessing something going on weird with some proxy somewhere.

#20 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

Also available in: Atom PDF