Project

General

Profile

Bug #5054

sam_sid_to_name:possible deadlock

Added by Craig Schappacher over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Reading Bug #4771 if seems I'm getting the same error.
Was on 9.2.1.5, upgraded to 9.2.1.6-BETA-a1a260d-x64 and can't access windows shares.

After I restart CIFS service, I can access the shares but get the sam_sid_to_name:possible deadlock error and have to restart almost every time I want to connect.

This was fine in 9.2.1.5


Related issues

Related to FreeNAS - Bug #4432: sam_sid_to_name: possible deadlockResolved2014-03-01

History

#1 Updated by Josh Paetzel over 4 years ago

  • Category set to 57
  • Status changed from Unscreened to Screened
  • Assignee set to Josh Paetzel
  • Target version set to 95

Can you attach the samba core files please?

#2 Updated by Craig Schappacher over 4 years ago

Trying to locate samba core files.
A different thread states they are in /mnt/Media/.system/cores
It isn't there.
Where else can I look?

Thank you.

#3 Updated by Craig Schappacher over 4 years ago

  • File samba.gdb added
  • File smb4.conf added

Here are some files, let me know if you need more.

Thank you.

#4 Updated by Craig Schappacher over 4 years ago

  • File samba added

#5 Updated by Craig Schappacher over 4 years ago

  • File samba_dnsupdate added
  • File samba_kcc added
  • File samba_spnupdate added
  • File samba_upgradedns added

#6 Updated by Craig Schappacher over 4 years ago

  • File smbd added
  • File log.smbd added

#7 Updated by Josh Paetzel over 4 years ago

I don't see any of the sid deadlock errors in the log file you provided. I see a whole bunch of:

[2014/05/23 10:54:46.198727,  1] ../source3/smbd/service.c:550(make_connection_snum)
create_connection_session_info failed: NT_STATUS_ACCESS_DENIED

which is pretty straightforward and shouldn't be related to an upgrade. Can you provide logs of the problem you are having?

#8 Updated by Craig Schappacher over 4 years ago

May 23 11:41:22 freenas generate_smb4_conf.py: [common.pipesubr:58] Popen()ing: /usr/local/bin/net groupmap add unixgroup='jpatron' ntgroup='jpatron'
May 23 11:41:22 freenas generate_smb4_conf.py: [common.pipesubr:58] Popen()ing: /usr/local/bin/net groupmap add unixgroup='btsync' ntgroup='btsync'
May 23 11:41:22 freenas generate_smb4_conf.py: [common.pipesubr:58] Popen()ing: /usr/local/bin/net groupmap add unixgroup='tfeury' ntgroup='tfeury'
May 23 11:41:22 freenas generate_smb4_conf.py: [common.pipesubr:58] Popen()ing: /usr/local/bin/net groupmap add unixgroup='test' ntgroup='test'
May 23 11:41:23 freenas generate_smb4_conf.py: [common.pipesubr:58] Popen()ing: /usr/local/bin/net groupmap add unixgroup='jdevenny' ntgroup='jdevenny'
May 23 11:41:23 freenas generate_smb4_conf.py: [common.pipesubr:58] Popen()ing: /usr/local/bin/net groupmap add unixgroup='gmorris' ntgroup='gmorris'
May 23 11:41:23 freenas notifier: winbindd not running? (check /var/run/samba/winbindd.pid).
May 23 11:41:23 freenas notifier: smbd not running? (check /var/run/samba/smbd.pid).
May 23 11:41:23 freenas notifier: nmbd not running? (check /var/run/samba/nmbd.pid).
May 23 11:41:23 freenas notifier: Performing sanity check on Samba configuration: OK
May 23 11:41:23 freenas notifier: winbindd not running? (check /var/run/samba/winbindd.pid).
May 23 11:41:23 freenas notifier: smbd not running? (check /var/run/samba/smbd.pid).
May 23 11:41:23 freenas notifier: nmbd not running? (check /var/run/samba/nmbd.pid).
May 23 11:41:23 freenas notifier: Performing sanity check on Samba configuration: OK
May 23 11:41:23 freenas notifier: Starting nmbd.
May 23 11:41:24 freenas notifier: Starting smbd.
May 23 11:41:24 freenas notifier: Starting winbindd.
May 23 11:41:24 freenas winbindd29825: [2014/05/23 11:41:24.176927, 0] ../source3/winbindd/winbindd_cache.c:3196(initialize_winbindd_cache)
May 23 11:41:24 freenas winbindd29825: initialize_winbindd_cache: clearing cache and re-creating with version number 2
May 23 11:41:38 freenas winbindd29827: [2014/05/23 11:41:38.727141, 0] ../source3/winbindd/winbindd_samr.c:769(sam_rids_to_names)
May 23 11:41:38 freenas winbindd29827: sam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249
May 23 11:41:38 freenas winbindd29827: [2014/05/23 11:41:38.849524, 0] ../source3/winbindd/winbindd_samr.c:769(sam_rids_to_names)
May 23 11:41:38 freenas winbindd29827: sam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249
May 23 11:41:38 freenas winbindd29827: [2014/05/23 11:41:38.876414, 0] ../source3/winbindd/winbindd_samr.c:694(sam_sid_to_name)
May 23 11:41:38 freenas winbindd29827: sam_sid_to_name: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249-1002
May 23 11:41:38 freenas winbindd29827: [2014/05/23 11:41:38.876717, 0] ../source3/winbindd/winbindd_samr.c:694(sam_sid_to_name)
May 23 11:41:38 freenas winbindd29827: sam_sid_to_name: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249-1008
May 23 11:41:38 freenas winbindd29827: [2014/05/23 11:41:38.876966, 0] ../source3/winbindd/winbindd_samr.c:694(sam_sid_to_name)
May 23 11:41:38 freenas winbindd29827: sam_sid_to_name: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249-1004
May 23 11:41:38 freenas winbindd29827: [2014/05/23 11:41:38.877184, 0] ../source3/winbindd/winbindd_samr.c:694(sam_sid_to_name)
May 23 11:41:38 freenas winbindd29827: sam_sid_to_name: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249-1009
May 23 11:47:28 freenas winbindd29827: [2014/05/23 11:47:28.699661, 0] ../source3/winbindd/winbindd_samr.c:769(sam_rids_to_names)
May 23 11:47:28 freenas winbindd29827: sam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249
May 23 11:47:28 freenas winbindd29827: [2014/05/23 11:47:28.814528, 0] ../source3/winbindd/winbindd_samr.c:769(sam_rids_to_names)
May 23 11:47:28 freenas winbindd29827: sam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249
May 23 11:47:28 freenas winbindd29827: [2014/05/23 11:47:28.836006, 0] ../source3/winbindd/winbindd_samr.c:694(sam_sid_to_name)
May 23 11:47:28 freenas winbindd29827: sam_sid_to_name: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249-1010
May 23 11:47:28 freenas winbindd29827: [2014/05/23 11:47:28.836286, 0] ../source3/winbindd/winbindd_samr.c:694(sam_sid_to_name)
May 23 11:47:28 freenas winbindd29827: sam_sid_to_name: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249-1008
May 23 11:47:28 freenas winbindd29827: [2014/05/23 11:47:28.836514, 0] ../source3/winbindd/winbindd_samr.c:694(sam_sid_to_name)
May 23 11:47:28 freenas winbindd29827: sam_sid_to_name: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249-1004
May 23 11:47:28 freenas winbindd29827: [2014/05/23 11:47:28.836743, 0] ../source3/winbindd/winbindd_samr.c:694(sam_sid_to_name)
May 23 11:47:28 freenas winbindd29827: sam_sid_to_name: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249-1002

#9 Updated by Josh Paetzel over 4 years ago

  • Related to Bug #4432: sam_sid_to_name: possible deadlock added

#10 Updated by Josh Paetzel over 4 years ago

Here's the samba bug tracking this:

https://bugzilla.samba.org/show_bug.cgi?id=10600

#11 Updated by Josh Paetzel over 4 years ago

The samba team has requested that you turn samba logging to debug and attach the log of the event.

#12 Updated by Craig Schappacher over 4 years ago

  • File SyslogCatchAll-2014-05-23.txt added

I just added my syslog to the Bugzilla Samba site as well.

#13 Updated by Jordan Hubbard over 4 years ago

From the samba ticket: "I just noticed, when I restart winbindd, the smb4.conf reverts back to original, debug info is gone."

If you set this from the GUI, this won't happen. You can set it in the auxiliary parameters field in Services->CIFS. All you need to set is
debug level = 10
debug pid = true
Because we already set the max log size to something huge.

#14 Updated by Josh Paetzel over 4 years ago

Still waiting on the samba team to comment on this.

#15 Updated by Josh Paetzel over 4 years ago

The newest nightly has a new version of samba. Can you test with that please?

#16 Updated by Craig Schappacher over 4 years ago

Was able to update, still getting same error.

#17 Updated by Josh Paetzel over 4 years ago

Man, this has to be annoying as hell. I'm sorry.

I wish we could get some traction with the samba team to sort this out.

Can you detail a repro case to me. What client are you using and what are you doing when the error occurs?

If you switch max protocol to smb2 do the errors stop?

#18 Updated by Cyber Jock over 4 years ago

I'm running the 9.2.1.6-beta from 6/6/2014 and I'm getting this too. I have a script that runs on login to my desktop and mounts my pool and has worked just fine for all of the 9.2.1.6 releases(been using the same script since the 8.0.4 days). I got this error upon logging into my desktop today(I installed the 6/6/2014 nightly last night before bed). In any case, the command that is run from the command prompt in Windows 7 x64 Ultimate was net use z: \\192.168.2.109\tank password /user:WORKGROUP\username /persistent:no. It did end up mounting the drive letter(which means the credentials validated) but the drive letter wasn't actually accessible(had the red X through it). Usually this means the share was disconnected from my desktop(example: reboot the FreeNAS box). I'm hard wired throughout the house and I didn't reboot my server so I don't think that's the problem. When I double click my Z drive I got this deadlock error again(but the drive did open after a 20 second or so delay).

I can easily reproduce this right now on my Mini. All I have to do is disconnect my server and then run my script again. Poof, instant error.

Edit: I did change to SMB2 for maximum protocol and the error continues.

Another edit: So I rebooted my Mini and the error is gone. SMB2 is still set. So then I changed back to SMB3 for maximum protocol and the error returns.

#19 Updated by Josh Paetzel over 4 years ago

Seeing as the samba team seems to have abandoned this issue, smb2 seems to be the workaround that solves the issue. We've set that as the default for new shares.

#20 Updated by Josh Paetzel over 4 years ago

  • Target version changed from 95 to 103

#21 Updated by Diedrich Guenther over 4 years ago

Seen in FreeNAS-9.2.1.6-BETA-2c5ce6b-x64
Both in SMB2 & SMB3 in CIFS settings with server reboot on each change

Jun 12 17:35:31 DVGMARServer winbindd[2543]: sam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-3730092111-1165699350-1323353831
Jun 12 17:36:16 DVGMARServer winbindd[2543]: [2014/06/12 17:36:16.537125, 0] ../source3/winbindd/winbindd_samr.c:769(sam_rids_to_names)

#22 Updated by Jörg Altendorf over 4 years ago

After Upgrading from FreeNAS 9.2.1.5 to 9.2.1.6 RC we also find this error every five minutes in our logs.
We use FreeNAS as Backup-to-Disk media for Backup Exec 2014. This Backup-to-Disk folder is configured as UNC path in Backup Exec. After reading the message from Cyber Jock I simply disabled the Backup Exec services for 15 minutes and the error messages are gone. So it looks like to me, that this error is coming from programs, services etc., which are accessing the CIFS share via UNC path.
We have to revert back to 9.2.1.5, but I have saved the Logfiles and will update the bug description and upload the files to the SAMBA site.

#23 Updated by John Hixson over 4 years ago

Can you try adding this to your cifs auxiliary parameters and confirm if it gets rid of the error messages?

idmap config *:backend = tdb
idmap config *:range = 90000000-100000000

#24 Updated by Craig Schappacher over 4 years ago

I was able to enter the info in Auxiliary Parameters and when I tried to access shares it let me in on the 1st try.(Even after a reboot)
There are still errors in the log though.

Jun 25 09:00:31 freenas notifier: Waiting for PIDS: 2542.
Jun 25 09:00:31 freenas notifier: Stopping nmbd.
Jun 25 09:00:31 freenas nmbd2539: [2014/06/25 09:00:31.865326, 0] ../source3/nmbd/nmbd.c:57(terminate)
Jun 25 09:00:31 freenas nmbd2539: Got SIGTERM: going down...
Jun 25 09:00:32 freenas notifier: Waiting for PIDS: 2539, 2539.
Jun 25 09:00:33 freenas notifier: Performing sanity check on Samba configuration: OK
Jun 25 09:00:33 freenas notifier: winbindd not running? (check /var/run/samba/winbindd.pid).
Jun 25 09:00:33 freenas notifier: smbd not running? (check /var/run/samba/smbd.pid).
Jun 25 09:00:33 freenas notifier: nmbd not running? (check /var/run/samba/nmbd.pid).
Jun 25 09:00:33 freenas notifier: Performing sanity check on Samba configuration: OK
Jun 25 09:00:33 freenas notifier: Starting nmbd.
Jun 25 09:00:33 freenas notifier: Starting smbd.
Jun 25 09:00:33 freenas notifier: Starting winbindd.
Jun 25 09:00:33 freenas nmbd25168: [2014/06/25 09:00:33.612423, 0] ../lib/util/become_daemon.c:136(daemon_ready)
Jun 25 09:00:33 freenas smbd25172: [2014/06/25 09:00:33.650373, 0] ../lib/util/become_daemon.c:136(daemon_ready)
Jun 25 09:00:33 freenas winbindd25177: [2014/06/25 09:00:33.668793, 0] ../source3/winbindd/winbindd_cache.c:3196(initialize_winbindd_cache)
Jun 25 09:00:33 freenas winbindd25177: initialize_winbindd_cache: clearing cache and re-creating with version number 2
Jun 25 09:00:33 freenas winbindd25177: [2014/06/25 09:00:33.684770, 0] ../lib/util/become_daemon.c:136(daemon_ready)
Jun 25 09:03:44 freenas winbindd25415: STATUS=daemon 'winbindd' finished starting up and ready to serve connectionsidmap range not specified for domain FREENAS
Jun 25 09:03:44 freenas winbindd25179: STATUS=daemon 'winbindd' finished starting up and ready to serve connectionssam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249
Jun 25 09:13:58 freenas kernel: arp: 192.168.4.200 moved from 02:a6:37:00:10:0a to 00:0f:fe:c9:ad:b8 on epair3b
Jun 25 09:13:58 freenas kernel: arp: 192.168.4.200 moved from 02:a0:37:00:0f:0a to 00:0f:fe:c9:ad:b8 on epair2b
Jun 25 09:13:58 freenas kernel: arp: 192.168.4.200 moved from 02:b3:37:00:0e:0a to 00:0f:fe:c9:ad:b8 on epair1b
Jun 25 09:13:58 freenas kernel: arp: 192.168.4.200 moved from 02:16:d0:00:0d:0a to 00:0f:fe:c9:ad:b8 on epair0b
Jun 25 09:25:19 freenas smbd28094: STATUS=daemon 'smbd' finished starting up and ready to serve connectionscreate_connection_session_info failed: NT_STATUS_ACCESS_DENIED
Jun 25 09:25:27 freenas winbindd25179: [2014/06/25 09:25:27.996123, 0] ../source3/winbindd/winbindd_samr.c:769(sam_rids_to_names)
Jun 25 09:25:27 freenas winbindd25179: sam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249
Jun 25 09:25:45 freenas smbd28102: STATUS=daemon 'smbd' finished starting up and ready to serve connectionsmicros (ipv4:192.168.4.113:62958) closed connection to service public
Jun 25 09:28:33 freenas winbindd25179: [2014/06/25 09:28:33.668460, 0] ../source3/winbindd/winbindd_samr.c:769(sam_rids_to_names)
Jun 25 09:28:33 freenas winbindd25179: sam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249
Jun 25 09:28:33 freenas winbindd25179: [2014/06/25 09:28:33.954978, 0] ../source3/winbindd/winbindd_samr.c:769(sam_rids_to_names)
Jun 25 09:28:33 freenas winbindd25179: sam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-2803706266-3940992467-408568249

#25 Updated by The m0nkey_ over 4 years ago

I was getting the same deadlock error after upgrading for 9.2.1.5 to 9.2.1.6. Found it's related to the UNIX/Windows group mappings. I did post what I did to resolve in the forum: http://forums.freenas.org/index.php?threads/sam_rids_to_names-possible-deadlock-trying-to-lookup-sid.21982/page-2#post-130794

From my log:

Jul 12 09:56:37 freenas winbindd[91046]: [2014/07/12 09:56:37.565281,  0] ../source3/winbindd/winbindd_samr.c:769(sam_rids_to_names)
Jul 12 09:56:37 freenas winbindd[91046]:   sam_rids_to_names: possible deadlock - trying to lookup SID S-1-5-21-3520457182-3639793677-2598286886

Fixed by remapping the UNIX to Windows group:

[root@freenas] ~# net groupmap list
users (S-1-5-21-3520457182-3639793677-2598286886-1001) -> users
[root@freenas] ~# net groupmap delete sid="S-1-5-21-1170145438-4009580803-3350505473-1001" 
Sucessfully removed S-1-5-21-1170145438-4009580803-3350505473-1001 from the mapping db
[root@freenas] ~# net groupmap add unixgroup=users rid=1001
Successfully added group users to the mapping db as a domain group​

This fixed it for me. I've not seen the deadlock error appear since and no issues with SMB clients.

#26 Updated by The m0nkey_ over 4 years ago

Quick update, looks like the above fix wasn't permanent. After rebooting my FreeNAS box I started to get the same error as above. Again, applied the fix and no more errors. Maybe something in the start-up of the Samba service that breaks?

#27 Updated by Jordan Hubbard over 4 years ago

  • Assignee changed from Josh Paetzel to John Hixson

#28 Updated by Roger Wilco over 4 years ago

Can confirm comment # 26 on FreeNAS-9.2.1.6-RELEASE-x64 (ddd1e39)

The reason why the deadlock issue reappears after a reboot is the adding of group mappings in /etc/ix.rc.d/ix-passwd through the function samba_groupmap().

On my quest to find out the reason I went through the Samba manuals, and FreeNAS' startup scripts and think that there are a few more related issues in the Samba startup scripts. But as I am a Samba noob, who is just unhappy with the deadlock issue, please excuse in case I am wasting your time...

Anyway.
The described modification fixes the deadlock issue permanently, through bypassing the cause for one certain configuration scenario.

My installation is a "Standalone Server" in terms of smb.conf.
This means, as stated at least here

https://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/winbind.html

the Winbind functionality is not needed at all for a standalone server.
Not starting winbindd upon system startup fixes two (configuration) issues:

  • The deadlock issue
  • The "idmap range not specified for domain XYZ" configuration issue (fixed by idmap config MYDOM : range = 1000 - 2000)

The Winbind daemon is started through /etc/local/rc.d/samba_server. See this file for

Issue # 1

samba_server_config_init() {
    local name
    # Determine what daemons are necessary to run Samba in the current role
    samba_server_role=$(${testparm_command} --parameter-name='server role' 2>/dev/null)
    case "${samba_server_role}" in
        active\ directory\ domain\ controller)
            samba_daemons="samba" 
            ;;
        auto|*)
            samba_daemons="nmbd smbd winbindd" 
            ;;
    esac

I think this is partially wrong - if we are something other than "active directory domain controller" then Winbind will be started.
There should be at least another case for "standalone server":

samba_server_config_init() {
    local name
    # Determine what daemons are necessary to run Samba in the current role
    samba_server_role=$(${testparm_command} --parameter-name='server role' 2>/dev/null)
    case "${samba_server_role}" in
        active\ directory\ domain\ controller)
            samba_daemons="samba" 
            ;;
        standalone\ server)
            samba_daemons="nmbd smbd" 
            ;;
        auto|*)
            samba_daemons="nmbd smbd winbindd" 
            ;;
    esac

This eliminates both mentioned issues, as winbindd is not started for a standalone server at all. But I cannot tell whether Winbind is never needed in a standalone configuration...

Issue # 2
Again in /etc/local/rc.d/samba_server just a few lines later:

            # Winbindd
            if [ "${name}" = "winbindd" ]; then
                samba_server_idmap=$(${testparm_command} --parameter-name='idmap uid' 2>/dev/null)
                if [ -n "${samba_server_idmap}" ]; then
                    winbindd_enable="YES" 
                fi
            fi

If there is no modified idmap uid setting in smb.conf then Winbind will be started. But, idmap uid is deprecated, so chances are good, that users will not use it anymore but will use idmap config * : range instead. See

https://wiki.samba.org/index.php/Samba_3.6_Features_added/changed#ID_Mapping_Changes

So whyever Winbind is necessary for idmap uid it will also be necessary for idmap config * : range , I guess. The script should therefore check for both parameters.

#29 Updated by Jeff Shankin over 4 years ago

Roger Wilco: your patch doesn't fix it for me. I also have a standalone box.

#30 Updated by Josh Paetzel over 4 years ago

Give 9.2.1.7 a try when it's released any day now. We made some changes that may fix this.

Also winbind is required for a standalone server. It maps local unix groups to windows groups.

#31 Updated by Roger Wilco over 4 years ago

Josh Paetzel: Could you provide any docs where is explained why IDMAP / Winbind is needed for a standalone server? (Just wondering how it really works)
All I can say is what I've written in comment #28 (it works for me but I cannot tell whether it works for all standalone server configurations).
Here two more samba.org docs where they say it's not needed for standalone servers (or the other way round, that it's needed in a multi-domain-environment):

https://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/idmapper.html

A standalone Samba server is an implementation that is not a member of a Windows NT4 domain, 
a Windows 200X Active Directory domain, or a Samba domain.

By definition, this means that users and groups will be created and controlled locally, 
and the identity of a network user must match a local UNIX/Linux user login. The IDMAP facility 
is therefore of little to no interest, winbind will not be necessary, and the IDMAP facility will not be 
relevant or of interest.

https://www.samba.org/samba/docs/man/Samba-HOWTO-Collection/winbind.html

Winbind is targeted at organizations that have an existing NT-based domain infrastructure 
into which they wish to put UNIX workstations or servers. Winbind will allow these organizations 
to deploy UNIX workstations without having to maintain a separate account infrastructure.

#32 Updated by Roger Wilco over 4 years ago

Jeff Shankin: This is not a proposed patch - it is - if at all - a workaround for the "deadlock" issue and the "idmap range" warning. These two come both from winbindd, so if Winbind is not running at all, there's no way for any of these two messages to appear.

If you did what I wrote and you are still getting the messages, then winbindd got started for some other reason I haven't found, or you didn't do the modification on your startup volume (USB stick or what ever)...

#33 Updated by Jordan Hubbard over 4 years ago

  • Target version changed from 103 to 9.3-BETA

#34 Updated by John Hixson over 4 years ago

  • Status changed from Screened to Resolved

I believe I have this issue finally sorted out. There were several key factors over the course of time that contributed to this, however, the final nail in the coffin was the fact that a new samba SID was being generated on every boot and not being saved. The samba SID is not persistent across reboots, unfortunately, it will not be available until 9.2.1.9. If the issue persists after that, please re-open this ticket.

#35 Updated by Dru Lavigne about 1 year ago

  • File deleted (samba.gdb)

#36 Updated by Dru Lavigne about 1 year ago

  • File deleted (smb4.conf)

#37 Updated by Dru Lavigne about 1 year ago

  • File deleted (samba)

#38 Updated by Dru Lavigne about 1 year ago

  • File deleted (samba_dnsupdate)

#39 Updated by Dru Lavigne about 1 year ago

  • File deleted (samba_spnupdate)

#40 Updated by Dru Lavigne about 1 year ago

  • File deleted (samba_upgradedns)

#41 Updated by Dru Lavigne about 1 year ago

  • File deleted (samba_kcc)

#42 Updated by Dru Lavigne about 1 year ago

  • File deleted (smbd)

#43 Updated by Dru Lavigne about 1 year ago

  • File deleted (log.smbd)

#44 Updated by Dru Lavigne about 1 year ago

  • File deleted (SyslogCatchAll-2014-05-23.txt)

Also available in: Atom PDF