Project

General

Profile

Bug #50775

Remove f_not_consul program filter from syslog-ng.conf

Added by Bug Clerk about 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Caleb St. John
Category:
Middleware
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

master PR: https://github.com/freenas/freenas/pull/1811

commit d333dcc7f368035f3c9a239274edd4e1dd333287 removed the consul alerting service from syslog-ng.

commit e7a7ab8333add24d81cc7a08c8267bcf3ee8b36f added the ability to use syslog-ng to log across the heartbeat interface on TrueNAS HA appliances. I added the "f_not_consul" filter to that change.

Simply remove that program filter altogether since the consul facility was removed altogether.

#47096


Related issues

Related to FreeNAS - Bug #47096: Remove f_not_consul program filter from syslog-ng.confDone

History

#1 Updated by William Grzybowski about 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

#2 Updated by William Grzybowski about 2 years ago

  • Is duplicate of Bug #47096: Remove f_not_consul program filter from syslog-ng.conf added

#3 Updated by Dru Lavigne about 2 years ago

  • Subject changed from fix(master) remove f_not_consul program filter from syslog-ng.conf to Remove f_not_consul program filter from syslog-ng.conf
  • Description updated (diff)
  • Category deleted (Middleware)
  • Status changed from Closed to Ready for Testing
  • Target version changed from N/A to 11.3
  • Reason for Closing deleted (Duplicate Issue)
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#4 Updated by Dru Lavigne about 2 years ago

  • Is duplicate of deleted (Bug #47096: Remove f_not_consul program filter from syslog-ng.conf)

#5 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #47096: Remove f_not_consul program filter from syslog-ng.conf added

#6 Updated by Dru Lavigne about 2 years ago

  • Category set to Middleware

#7 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3 to Master - FreeNAS Nightlies

Also available in: Atom PDF