Project

General

Profile

Bug #51986

Add the ability to update boot_scrub field via APIv1 and v2

Added by sam haas over 1 year ago. Updated about 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When changing the number of days for the boot pool automatic scrub interval in the new 11.2 interface there is no way to update the new value. This does work correctly in the old interface.

scrub.png (167 KB) scrub.png sam haas, 10/19/2018 02:30 AM
Screen Shot 2018-10-23 at 4.31.56 PM.png (304 KB) Screen Shot 2018-10-23 at 4.31.56 PM.png Jeff Ervin, 10/23/2018 01:33 PM
Screen Shot 2018-10-23 at 4.32.10 PM.png (295 KB) Screen Shot 2018-10-23 at 4.32.10 PM.png Jeff Ervin, 10/23/2018 01:33 PM
35330
36315
36324

Related issues

Has duplicate FreeNAS - Bug #54252: No way to save setting change Closed
Copied to FreeNAS - Bug #53129: Add the ability to update boot_scrub field via APIv1 and v2Done

Associated revisions

Revision 37c3d240 (diff)
Added by Waqar Ahmed over 1 year ago

Make boot_scrub editable This commit introducs the ability to update boot_scrub field via api v1 and v2. Ticket: #51986

Revision df477c28 (diff)
Added by Waqar Ahmed over 1 year ago

tkt-51986: Make boot_scrub editable (#1940) Make boot_scrub editable This commit introducs the ability to update boot_scrub field via api v1 and v2. Ticket: #51986

Revision ed81df61 (diff)
Added by Waqar Ahmed over 1 year ago

Make boot_scrub editable This commit introducs the ability to update boot_scrub field via api v1 and v2. Ticket: #51986 (cherry picked from commit 37c3d240bd7080fe515a11b0cd6541a92285c8b9)

Revision e7759a43 (diff)
Added by Bug Clerk over 1 year ago

tkt-53129: Make boot_scrub editable (by sonicaj) (#1948) Make boot_scrub editable This commit introducs the ability to update boot_scrub field via api v1 and v2. Ticket: #51986

History

#1 Updated by Dru Lavigne over 1 year ago

  • Reason for Blocked set to Need additional information from Author

Sam: to make this clearer for the dev, can you attach a screenshot of what you are seeing when you try to do this?

#2 Updated by sam haas over 1 year ago

35330

The screen shot shows no means of saving the days value.

#3 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to Lola Yang
  • Target version changed from Backlog to 11.2-RC2
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by Vaibhav Chauhan over 1 year ago

  • Assignee changed from Lola Yang to Vaibhav Chauhan

#5 Updated by Vaibhav Chauhan over 1 year ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Vaibhav Chauhan to William Grzybowski

#6 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Waqar Ahmed
  • Severity changed from New to Medium

Waqar, we need a way to make adv_boot_scrub work in the old API for /system/advanced/.

#7 Updated by Waqar Ahmed over 1 year ago

  • Status changed from Unscreened to In Progress

#8 Updated by Bug Clerk over 1 year ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Bug Clerk over 1 year ago

  • Copied to Bug #53129: Add the ability to update boot_scrub field via APIv1 and v2 added

#10 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Cannot save days value for boot pool automatic scrub interval to Add the ability to update boot_scrub field via APIv1 and v2
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#11 Updated by Jeff Ervin over 1 year ago

36315
36324

Test Passed FreeNAS-11.2-INTERNAL27

#12 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

#13 Updated by Dru Lavigne over 1 year ago

  • Has duplicate Bug #54252: No way to save setting change added

#14 Updated by Rickard von Essen about 1 year ago

Could we get an updated target version, because it still seems like it's not possible to change (and persist that change) in 11.2-RELEASE-U1.

#15 Updated by William Grzybowski about 1 year ago

Rickard von Essen wrote:

Could we get an updated target version, because it still seems like it's not possible to change (and persist that change) in 11.2-RELEASE-U1.

This has been marked as fixed and its was verified by QA.

If you still have a similar issue please open a new ticket with a reproduction case.

Also available in: Atom PDF