Project

General

Profile

Bug #52237

Cherrypick iocage exec commits to fix jail shell issues

Added by Adam Brown almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After upgrading from '11.2 BETA3' to '11.2 RC1', all text files inside all jails are unreadable, just blank white space and a borked text editor command list displayed at bottom of page.
Tested by accessing jail via SSH or via GUI shell using nano or ee text editors.

example:

iocage exec plex
nano /var/log/messages
output is blank

I think this is a permissions issue, but everything was working fine before update.
This issue is only linked to files inside jails, when accessing a text file from smb share can read fine.


Related issues

Has duplicate FreeNAS - Bug #52479: Jail shell env are wrong after update to RC1Closed
Has duplicate FreeNAS - Bug #53179: VI (VIM) Editor display error within IOCAGEClosed

History

#1 Updated by Adam Brown almost 2 years ago

  • Description updated (diff)

#2 Updated by Adam Brown almost 2 years ago

  • Description updated (diff)

#3 Updated by Adam Brown almost 2 years ago

  • Description updated (diff)

#4 Updated by Dru Lavigne almost 2 years ago

  • Category changed from OS to Middleware
  • Assignee changed from Release Council to William Grzybowski

#6 Updated by Mathieu Aumont almost 2 years ago

In fact this is the same probleme that me with the ticket Bug #52479

The probleme is env xterm param is wrong.

I reproduce your problem myself with nano.

Adam neovim is working correctly for editing (but not vim) (but obsiously is not as simple as nano ...)

#7 Updated by Dru Lavigne almost 2 years ago

  • Related to Bug #52479: Jail shell env are wrong after update to RC1 added

#8 Updated by William Grzybowski almost 2 years ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.2-RC2
  • Severity changed from New to Medium

#9 Updated by William Grzybowski almost 2 years ago

  • Related to deleted (Bug #52479: Jail shell env are wrong after update to RC1)

#10 Updated by William Grzybowski almost 2 years ago

  • Has duplicate Bug #52479: Jail shell env are wrong after update to RC1 added

#11 Updated by Lulu G almost 2 years ago

The same bug for me.
Only vi works for me I was forced to learn commands lol

#12 Updated by Brandon Schneider almost 2 years ago

  • Status changed from Unscreened to In Progress

This issue doesn't affect nightlies, trying to hunt down if there's missing commits for RC1/11.2

#13 Updated by Jurgen Segaert almost 2 years ago

Not sure about the FreeNAS fork, but in iocage master:

#14 Updated by Dru Lavigne almost 2 years ago

  • Has duplicate Bug #53179: VI (VIM) Editor display error within IOCAGE added

#16 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Unable to read files inside iocage jails after freenas 11.2 RC1 update to Cherry pick iocage exec commits to fix jail shell issues
  • Status changed from In Progress to Ready for Testing
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#17 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Cherry pick iocage exec commits to fix jail shell issues to Cherrypick iocage exec commits to fix jail shell issues

#18 Updated by Brandon Schneider almost 2 years ago

  • Status changed from Ready for Testing to In Progress
  • Needs Merging changed from No to Yes

#20 Updated by Brandon Schneider almost 2 years ago

We're going to try this with a much smaller set of diffs, this fixes the issue for me.

PR: https://github.com/freenas/iocage/pull/71
STABLE PR: https://github.com/freenas/iocage/pull/72

#21 Updated by Brandon Schneider almost 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#23 Updated by Bonnie Follweiler almost 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

#25 Updated by Bonnie Follweiler almost 2 years ago

Test Passed in FreeNAS-11.2-INTERNAL32

#26 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF