Project

General

Profile

Bug #52450

Force entity forms in new UI to load at full-width of their containing card

Added by Hans Vos about 3 years ago. Updated over 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

ACCEPTANCE CRITERIA
- Go to storage/pools (this seems to trigger the problem)
- Then go to storage/snapshots/add. The input fields should stretch all the way across the card on which they appear, allowing for reasonable margins.
- Also visit Accounts/Groups/Add and look for the fields to span the whole card in the same way.

ORIGINAL DESCRIPTION
I have a 1440p monitor and when my browser is maximized the tooltips on various pages don't display properly.

When I move my browser window to my second monitor which is 1080p it does work properly, similarly when I manually resize my browser windows on my main monitor.

I've attached two screenshots. This happens when using the default theme. So far I've encountered it on every page where I can edit something.

I just browsed to the UI and tested it on the following pages where the problem occurs.

  • Editing a Disk
  • Editing a Pool
  • Editing a SMB share
  • Editing Rsync module
  • Configuring the SMB service
  • On the Global Configuration page of network settings
freenas1.png (36.3 KB) freenas1.png Hans Vos, 10/20/2018 01:18 AM
freenas2.png (34.7 KB) freenas2.png Hans Vos, 10/20/2018 01:18 AM
freenas17.png (25.6 KB) freenas17.png Hans Vos, 11/01/2018 08:47 AM
Hints Hidden.JPG (51.2 KB) Hints Hidden.JPG Dennis Mullen, 02/26/2019 07:56 AM
freenas_hints-1.jpg (215 KB) freenas_hints-1.jpg Dennis Mullen, 02/26/2019 07:56 AM
FreeNAS GUI help bubble.JPG (16.1 KB) FreeNAS GUI help bubble.JPG Dennis Mullen, 02/26/2019 07:56 AM
Screenshot from 2019-02-26 10-17-13.png (33.9 KB) Screenshot from 2019-02-26 10-17-13.png Dennis Mullen, 02/26/2019 08:01 AM
Screenshot from 2019-02-26 12-31-48.png (44.6 KB) Screenshot from 2019-02-26 12-31-48.png Dennis Mullen, 02/26/2019 09:32 AM
Screen Shot 2019-03-06 at 11.35.14 AM.png (36.2 KB) Screen Shot 2019-03-06 at 11.35.14 AM.png Jeff Ervin, 03/06/2019 08:36 AM
Screen Shot 2019-03-06 at 11.34.35 AM.png (32.5 KB) Screen Shot 2019-03-06 at 11.34.35 AM.png Jeff Ervin, 03/06/2019 08:36 AM
35665
35674
38358
56244
56253
56262
56271
56326
59025
59034

Related issues

Related to FreeNAS - Bug #62550: Position and size tooltips in new UI to stay within marginsDone
Has duplicate FreeNAS - Bug #65430: Hint displays behind right side border of GUIClosed

History

#1 Updated by Dru Lavigne about 3 years ago

  • Assignee changed from Release Council to Anonymous
  • Target version changed from Backlog to 11.2-U2

#2 Updated by Anonymous about 3 years ago

  • Assignee changed from Anonymous to Dennis Mullen

#3 Updated by Anonymous about 3 years ago Private

I believe this just needs a little CSS work

#4 Updated by Dennis Mullen about 3 years ago

  • Status changed from Unscreened to Screened

Progress: Changed method of calculating available screen space from pixels to percent. May help on hi-res displays, but I need to run some tests on hi res equipment, plus get a bit more info from poster.

Hans, when this problem appears, does refreshing the page have any effect? Also could you tell me what browser and OS you use? Thank you.

#5 Updated by Hans Vos about 3 years ago

38358

Hi Dennis,

when this problem appears, does refreshing the page have any effect?

Yes actually, I just checked this. I opened up the "Edit Disk" page and as usual the tool tip was mostly hidden. I then pressed F5 and now the tool tip did appear. See new screenshot.

Also could you tell me what browser and OS you use? Thank you.

Running Windows 10 with the latest updates and Google Chrome with version 70.0.3538.77.

Regards,

Hans

#6 Updated by Dennis Mullen almost 3 years ago

  • Related to Bug #62550: Position and size tooltips in new UI to stay within margins added

#7 Updated by Anonymous almost 3 years ago

  • Target version changed from 11.2-U2 to 11.2-U3

#8 Updated by Anonymous almost 3 years ago Private

A workaround that should help with this has been merged but we should keep looking for possibly better ways to keep this from happening.

#9 Updated by Dru Lavigne almost 3 years ago

  • Related to Bug #65430: Hint displays behind right side border of GUI added

#10 Updated by Dennis Mullen almost 3 years ago

Haven't seen an occurrence of this we re positioned tool tips to not overflow the edge of the page they originate from.

#12 Updated by Dennis Mullen almost 3 years ago

  • Related to deleted (Bug #65430: Hint displays behind right side border of GUI)

#13 Updated by Dennis Mullen almost 3 years ago

  • Has duplicate Bug #65430: Hint displays behind right side border of GUI added

#14 Updated by Dennis Mullen almost 3 years ago

56271

PS - Sometimes forms still fail to span the whole width (see picture of Snapshots/Add, which is where I can most reliably reproduce this, about one time in 30?). The tool tips seem to display fine now (they've been re positioned) but still, the form has misloaded, possibly leading to other problems. All the examples I have of this are from entity forms. I wonder if there are other examples of tables or other elements not fully loading.

#15 Updated by Dennis Mullen almost 3 years ago

56326

MASTER: https://github.com/freenas/webui/pull/1993
STABLE: https://github.com/freenas/webui/pull/1992

Testing:
- Go to storage/pools (this seems to trigger the problem)
- Then go to storage/snapshots/add. The input fields should stretch all the way across the card on which they appear, allowing for reasonable margins.
- Also visit Accounts/Groups/Add and look for the fields to span the whole card in the same way.

In this pic, top shows the wrong condition, bottom is correct:

#16 Updated by Dennis Mullen almost 3 years ago

  • Status changed from Screened to In Progress

#17 Updated by Anonymous almost 3 years ago

  • Status changed from In Progress to Ready for Testing

#18 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from Tooltip not visible on high resolutions (verified on "Edit dataset" and "Edit disk" pages) does display properly when I scale down the browser viewport to Force entity forms in new UI to load at full-width of their containing card
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#19 Updated by Dennis Mullen over 2 years ago

  • Description updated (diff)

#21 Updated by Jeff Ervin over 2 years ago

59025
59034

Test Passed FreeNAS-11.2-U2-INTERNAL93

#22 Updated by Dru Lavigne over 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF