Project

General

Profile

Bug #5273

Cannot get disks serial number of a Backblaze server using a Rocket 750

Added by Todd Kaehler about 5 years ago. Updated about 5 years ago.

Status:
Closed: Behaves correctly
Priority:
Nice to have
Assignee:
-
Category:
-
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Using a Backblaze server (http://www.backblaze.com/) with a rocket 750 (http://www.highpoint-tech.com/USA_new/series_R750-Overview.htm). When I check for the serial number using the web interface the Serial column is blank. smartctl does not finish.

smartctl -a /dev/da1
smartctl 6.2 2013-07-26 r3841 [FreeBSD 9.2-RELEASE-p4 amd64] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Vendor: HPT
Product: DISK 0_1
Revision: 4.00
User Capacity: 3,000,592,982,016 bytes [3.00 TB]
Logical block size: 512 bytes
(pass2:hptnr0:0:1:0): MODE SENSE. CDB: 1a 00 84 00 40 00
(pass2:hptnr0:0:1:0): CAM status: CCB request was invalid
(pass2:hptnr0:0:1:0): MODE SENSE. CDB: 1a 00 1c 00 40 00
(pass2:hptnr0:0:1:0): CAM status: CCB request was invalid

Terminate command early due to bad response to IEC mode page

A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options.

History

#1 Updated by Anonymous about 5 years ago

Looks like this is a hardware RAID device, so raw access to the disks isn't available. You'll need to use Highpoint management tools to get drive-side information through it.

Same problem exists on Adaptec, LSI MegaRAID, etc.

#2 Updated by Todd Kaehler about 5 years ago

I did that but I cannot figure out how to map the drive using freeNAS to the drive using the Highpoint tool. From freeNAS I get "da2" and from the Highpoint tool it gives me "Device_1_21" I do not see anyway to map a "da" to a "Device_".

When a disk goes bad FreeNAS tells me which "da" is bad so I need to know how this maps to the "Device_" so I can get the serial number so I can find the bad disk.

Todd Kaehler
IT System Administrator
Pacific States Marine Fisheries Commission
205 SE Spokane Street, Suite 100
Portland, Oregon 97202-6487
Phone: 503-595-3100
Email:

#3 Updated by Anonymous about 5 years ago

Right, you would need to use a Highpoint management tool to retrieve that information. I am not aware of whether one exists for FreeBSD for their products, you will have to check their support website.

#4 Updated by Todd Kaehler about 5 years ago

I just stated I am using the Hipoint management tool but disks are revered to as "Device_1_25" for example. How do I map that to a "da" device which FreeNAS uses. That is my question.

--Todd

#5 Updated by Anonymous about 5 years ago

  • Status changed from Unscreened to Closed: Behaves correctly

This is evolving into a usage question, not a bug. You might find more assistance on the forums where other Highpoint users can tell you how they solved this problem.

Going to mark this "Behaves correctly" for now, but if there's a change that FreeNAS can apply that would help your situation feel free to update this ticket.

Also available in: Atom PDF