Project

General

Profile

Feature #53039

Allow force deletion of datasets through v1 and v2 API

Added by Travis Hansen about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

I've implemented a kubernetes provisioner: https://redmine.ixsystems.com/issues/36303

In the course of operation I've bumped into issues deleting the dataset: https://redmine.ixsystems.com/issues/34056#note-11

Ultimately, this is a case of 'no really, I know what I'm doing' so it would be nice to have available at the API layer a parameter to get pushed down to the appropriate code paths.

Thanks for the consideration!


Related issues

Related to FreeNAS - Feature #36303: officially supported kubernetes provisionerClosed
Is duplicate of FreeNAS - Feature #28215: Allow force deletion of datasets in middleware and alert If busyDone

History

#1 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to Screened
  • Assignee changed from Release Council to William Grzybowski
  • Severity changed from New to Medium

#2 Updated by Travis Hansen about 1 year ago

If I dig into this would the preference be query parameter or sent as body data?

#3 Updated by ios man about 1 year ago

Im in love with your content and also gain some knowledge from your blog.
https://appvalleyandroid.com
https://192-168-l-254-ip.com
https://psiphonapp.com

#4 Updated by William Grzybowski about 1 year ago

Travis Hansen wrote:

If I dig into this would the preference be query parameter or sent as body data?

body data, we accept JSON in all our APIs.

Thanks

#5 Updated by Dru Lavigne about 1 year ago

  • Related to Feature #36303: officially supported kubernetes provisioner added

#6 Updated by William Grzybowski 12 months ago

  • Status changed from Screened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

#7 Updated by William Grzybowski 12 months ago

This is implemented in #28215

#8 Updated by William Grzybowski 12 months ago

  • Is duplicate of Feature #28215: Allow force deletion of datasets in middleware and alert If busy added

#9 Updated by Travis Hansen 12 months ago

The referenced ticket appears to be v2 only. No love for v1? :)

#10 Updated by William Grzybowski 12 months ago

Travis Hansen wrote:

The referenced ticket appears to be v2 only. No love for v1? :)

No, we are not going to spend time on something being deprecated really soon.

#11 Updated by Travis Hansen 12 months ago

If a patch was drafted up would it be considered for inclusion?

#12 Updated by William Grzybowski 12 months ago

Travis Hansen wrote:

If a patch was drafted up would it be considered for inclusion?

As long as the change is not too intrusive.

Also available in: Atom PDF