Project

General

Profile

Bug #53149

Fix traceback when using device extents with many snapshots

Added by charles selfridge about 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Seen in:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Both in the New and old UI I am unable to modify or add iSCSI extents/devices. After trying I get some fun errors and something around the same time really pissed off the new UI. Here is the debug and some screenshots, hope this is helpful if it has not already been reported.

It says it was unable to connect to the NAS but SMB, iSCSI/FC and ssh were all working fine.

Unable to connect over 100G link.PNG (24.6 KB) Unable to connect over 100G link.PNG charles selfridge, 10/22/2018 09:37 PM
OldGUI iSCSi.PNG (100 KB) OldGUI iSCSi.PNG charles selfridge, 10/22/2018 09:37 PM
new GUI iSCSI.PNG (25.1 KB) new GUI iSCSI.PNG charles selfridge, 10/22/2018 09:37 PM
36147
36157
36167

Related issues

Copied to FreeNAS - Bug #54630: Fix traceback when using device extents with many snapshotsDone

Associated revisions

Revision f52fc035 (diff)
Added by William Grzybowski almost 2 years ago

feat(middlewared): allow to select a subset of attributes Ticket: #53149

Revision 1bf9f94a (diff)
Added by William Grzybowski almost 2 years ago

feat(middlewared/zfs): special cases for faster zfs.snapshot.query Ticket: #53149

Revision 19587f09 (diff)
Added by William Grzybowski almost 2 years ago

fix(middlewared/iscsi): select only snapshot names for faster listing Ticket: #53149

Revision a86255c4 (diff)
Added by William Grzybowski almost 2 years ago

fix(middlewared/iscsi): select only snapshot names for faster listing Ticket: #53149

Revision 17a2e12d (diff)
Added by William Grzybowski almost 2 years ago

feat(middlewared): allow to select a subset of attributes Ticket: #53149

Revision 40d329a1 (diff)
Added by William Grzybowski almost 2 years ago

feat(middlewared/zfs): special cases for faster zfs.snapshot.query Ticket: #53149

Revision 3839cbd6 (diff)
Added by William Grzybowski almost 2 years ago

fix(middlewared/iscsi): select only snapshot names for faster listing Ticket: #53149

Revision 84f05d7f (diff)
Added by William Grzybowski almost 2 years ago

feat(middlewared): allow to select a subset of attributes Ticket: #53149

Revision a7bb4ddf (diff)
Added by William Grzybowski almost 2 years ago

feat(middlewared/zfs): special cases for faster zfs.snapshot.query Ticket: #53149

Revision e382869c (diff)
Added by William Grzybowski almost 2 years ago

fix(middlewared/iscsi): select only snapshot names for faster listing Ticket: #53149

History

#1 Updated by charles selfridge about 2 years ago

  • File debug-The-Archive-20181023000640.tgz added
  • Private changed from No to Yes

#2 Updated by charles selfridge about 2 years ago

  • File page time out 2018-10-22.pdf added

#4 Updated by charles selfridge about 2 years ago

36157

#5 Updated by charles selfridge about 2 years ago

36167

#6 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to William Grzybowski

#7 Updated by William Grzybowski almost 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

I dont seem to be able to reproduce the issue nor there is anything useful in the logs.

Are you available for a team view session?

#8 Updated by charles selfridge almost 2 years ago

Yeah, just let me know what is open on your schedule and I will try and move mine around for you.

#9 Updated by charles selfridge almost 2 years ago

Just had to make sure I could still make it do it on command, you can half ignore the below if it is not useful to ya.

```Request Method: GET
Request URL: http://10.13.37.10/legacy/admin/services/iscsitargetextent/add/
Software Version: FreeNAS-11.2-RC1 (c831a6a98)
Exception Type: CallTimeout
Exception Value:
Call timeout
Exception Location: /usr/local/lib/python3.6/site-packages/middlewared/client/client.py in call, line 447
Server time: Thu, 25 Oct 2018 21:41:34 -0400
Traceback

Environment:

Software Version: FreeNAS-11.2-RC1 (c831a6a98)
Request Method: GET
Request URL: http://10.13.37.10/legacy/admin/services/iscsitargetextent/add/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
42. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
163. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in wrapper
216. return self._admin.admin_view(view)(*args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/utils/decorators.py" in _wrapped_view
149. response = view_func(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/decorators/cache.py" in _wrapped_view_func
57. response = view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/site.py" in inner
143. return view(request, *args, **kwargs)
File "./freenasUI/freeadmin/options.py" in add
403. mf = mf()
File "./freenasUI/services/forms.py" in init
831. 'iscsi.extent.disk_choices').items())
File "./freenasUI/services/forms.py" in init
831. 'iscsi.extent.disk_choices').items())
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in call
447. raise CallTimeout("Call timeout")

Exception Type: CallTimeout at /legacy/admin/services/iscsitargetextent/add/
Exception Value: Call timeout

Request information
GET
No GET data

POST
No POST data

FILES
No FILES data

COOKIES
Variable Value
fntreeSaveStateCookie 'root%2Croot%2F604%2Croot%2F1%2Croot%2F1%2F10%2Croot%2F1%2F11%2Croot%2F615%2Croot%2F627%2Croot%2F631%2Croot%2F1%2F2%2Croot%2F1%2F12%2Croot%2F633%2Croot%2F637%2Croot%2F646'
csrftoken '********'
sessionid '2bkasqjvf702rc5u4jsu0ut54d8khv44'
META
Variable Value```

#10 Updated by William Grzybowski almost 2 years ago

charles selfridge wrote:

Yeah, just let me know what is open on your schedule and I will try and move mine around for you.

Would any time between 10AM-2PM UTC work for you? Either tomorrow or the day after?

#11 Updated by charles selfridge almost 2 years ago

Between 1PM and 2PM UTC works for me. I have a meeting I have to be at @ 2:30PM UTC, worse case the day after that time range should work for me.

#12 Updated by William Grzybowski almost 2 years ago

charles selfridge wrote:

Between 1PM and 2PM UTC works for me. I have a meeting I have to be at @ 2:30PM UTC, worse case the day after that time range should work for me.

Ok, send me credentials when you're ready

william at ixsystems com

#13 Updated by William Grzybowski almost 2 years ago

William Grzybowski wrote:

charles selfridge wrote:

Between 1PM and 2PM UTC works for me. I have a meeting I have to be at @ 2:30PM UTC, worse case the day after that time range should work for me.

Ok, send me credentials when you're ready

william at ixsystems com

Or it could be between 4PM and 8PM UTC.

#14 Updated by charles selfridge almost 2 years ago

I am ready now, let's see how far we can get.

#15 Updated by William Grzybowski almost 2 years ago

  • Status changed from Blocked to Not Started
  • Target version changed from Backlog to 11.2-U2
  • Severity changed from New to Med High
  • Reason for Blocked deleted (Waiting for feedback)

After TV session we discovered its due the fact the middleware is not ready to handle systems with 20k snapshots.

In the example middleware gets stuck handling the iscsi.extent.disk_choices call.

#16 Updated by William Grzybowski almost 2 years ago

charles, I have tried to reproduce the problem with 20k snapshots locally and could not. There must be something else going on.

When can we resume TeamViewer?

#17 Updated by charles selfridge almost 2 years ago

1-1:30PM UTC work for you?

#18 Updated by Bug Clerk almost 2 years ago

  • Status changed from Not Started to In Progress

#19 Updated by Bug Clerk almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#20 Updated by Bug Clerk almost 2 years ago

  • Target version changed from 11.2-U2 to 11.3

#21 Updated by Bug Clerk almost 2 years ago

  • Copied to Bug #54630: Fix traceback when using device extents with many snapshots added

#22 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from iSCSI seems to be "broken to Fix traceback when using device extents with many snapshots
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#23 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-The-Archive-20181023000640.tgz)

#24 Updated by Dru Lavigne almost 2 years ago

  • File deleted (page time out 2018-10-22.pdf)

#25 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3 to Master - FreeNAS Nightlies
  • Needs QA changed from Yes to No

Also available in: Atom PDF