Project

General

Profile

Bug #53235

Fix traceback on pool resilver priority update

Added by William Grzybowski about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

[2018/10/21 17:01:35] (WARNING) application.call_method():189 - Exception while calling pool.resilver.update(*[{'enabled': False, 'begin': '18:00', 'end': '09:00', 'weekday': []}])
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 161, in call_method
    result = await self.middleware.call_method(self, message)
  File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 1043, in call_method
    return await self._call(message['method'], serviceobj, methodobj, params, app=app, io_thread=False)
  File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 983, in _call
    return await methodobj(*args)
  File "/usr/local/lib/python3.6/site-packages/middlewared/service.py", line 201, in update
    f'{self._config.namespace}.update', self, self.do_update, [data]
  File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 983, in _call
    return await methodobj(*args)
  File "/usr/local/lib/python3.6/site-packages/middlewared/schema.py", line 664, in nf
    return await f(*args, **kwargs)
  File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/pool.py", line 147, in do_update
    if len(set(original_config.items()) ^ set(new_config.items())) > 0:
TypeError: unhashable type: 'list'
config    
{
'begin': datetime.time(18, 0), 
'enabled': False, 
'end': datetime.time(9, 0), 
'id': 1, 
'weekday': []
}
data    
{
'begin': '18:00', 
'enabled': False, 
'end': '09:00', 
'weekday': []
}
new_config    
{
'begin': datetime.time(18, 0), 
'enabled': False, 
'end': datetime.time(9, 0), 
'id': 1, 
'weekday': []
}
original_config    
{
'begin': datetime.time(18, 0), 
'enabled': False, 
'end': datetime.time(9, 0), 
'id': 1, 
'weekday': '7'
}

https://sentry.ixsystems.com/ixsystems/freenas-middleware/issues/17306/


Related issues

Is duplicate of FreeNAS - Bug #53946: Fix traceback on pool resilver priority updateDone
Copied to FreeNAS - Bug #53604: Fix traceback on pool resilver priority updateDone

Associated revisions

Revision 1e8c1536 (diff)
Added by Waqar Ahmed about 2 years ago

Bug fix for Resilver and Periodic Snapshots This commit fixes an issue with resilver service making sure that a weekday is selected at all times and adds a migration which reflects this across periodic snapshots and resilver model. Ticket: #53235

Revision 028018d9 (diff)
Added by Waqar Ahmed about 2 years ago

Bug fix for Resilver and Periodic Snapshots This commit fixes an issue with resilver service making sure that a weekday is selected at all times and adds a migration which reflects this across periodic snapshots and resilver model. Ticket: #53235 (cherry picked from commit 1e8c1536f0d69fb80c80c26597622e5aadd373a9)

Revision e9a5cb2e (diff)
Added by Bug Clerk about 2 years ago

tkt-53604: Bug fix for Resilver and Periodic Snapshots (by sonicaj) (#1959) Bug fix for Resilver and Periodic Snapshots This commit fixes an issue with resilver service making sure that a weekday is selected at all times and adds a migration which reflects this across periodic snapshots and resilver model. Ticket: #53235

Revision a3935e08 (diff)
Added by Waqar Ahmed about 2 years ago

Bug fix for Resilver and Periodic Snapshots This commit fixes an issue with resilver service making sure that a weekday is selected at all times and adds a migration which reflects this across periodic snapshots and resilver model. Ticket: #53235 (cherry picked from commit 1e8c1536f0d69fb80c80c26597622e5aadd373a9) (cherry picked from commit 028018d9f997bde25c6a765797c2935716a224f2)

Revision 3a107408 (diff)
Added by Bug Clerk about 2 years ago

tkt-53946: Bug fix for Resilver and Periodic Snapshots (by sonicaj) (by bugclerk) (#1970) Bug fix for Resilver and Periodic Snapshots This commit fixes an issue with resilver service making sure that a weekday is selected at all times and adds a migration which reflects this across periodic snapshots and resilver model. Ticket: #53235

History

#1 Updated by William Grzybowski about 2 years ago

  • Target version changed from 11.3 to 11.2-RC2

#2 Updated by Waqar Ahmed about 2 years ago

  • Status changed from Unscreened to In Progress

#3 Updated by Bug Clerk about 2 years ago

  • Status changed from In Progress to Ready for Testing

#4 Updated by Bug Clerk about 2 years ago

  • Target version changed from 11.2-RC2 to 11.3

#5 Updated by Bug Clerk about 2 years ago

  • Copied to Bug #53604: Fix traceback on pool resilver priority update added

#6 Updated by Dru Lavigne about 2 years ago

  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#7 Updated by Dru Lavigne about 2 years ago

  • Status changed from Ready for Testing to In Progress
  • Needs Merging changed from No to Yes

#8 Updated by Waqar Ahmed about 2 years ago

  • Status changed from In Progress to Closed
  • Target version changed from 11.3 to N/A
  • Needs QA changed from Yes to No
  • Needs Merging changed from Yes to No

#9 Updated by Waqar Ahmed about 2 years ago

  • Is duplicate of Bug #53946: Fix traceback on pool resilver priority update added

#10 Updated by Dru Lavigne about 2 years ago

  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF