Project

General

Profile

Bug #5330

ActiveDirectory service PUT example does not work

Added by Anonymous over 6 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
William Grzybowski
Category:
Middleware
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In this link http://api.freenas.org/resources/services.html#id3, the example in documentation does not work:

ad_bindname : [u'This field is required.']
ad_workgroup : [u'This field is required.']
ad_bindpw : [u'This field is required.']

Associated revisions

Revision b6464430 (diff)
Added by William Grzybowski over 6 years ago

ad_adminpw and ad_adminname have been renamed Ticket: #5330

History

#1 Updated by William Grzybowski over 6 years ago

  • Status changed from Unscreened to Closed: Cannot reproduce

These fields do not even exist, are you sure you got it right?

#2 Updated by William Grzybowski over 6 years ago

Ok I see whats going on, the api.freenas.org docs is for the master branch, and you're running 9.2.1.X

#3 Updated by Anonymous over 6 years ago

I will build a new system and retest it.

#4 Updated by Anonymous over 6 years ago

William Grzybowski wrote:

Ok I see whats going on, the api.freenas.org docs is for the master branch, and you're running 9.2.1.X

I just checked the system I am using is 9.3 and the problem still exists.

#5 Updated by William Grzybowski over 6 years ago

Pretty sure the error is not the same, its not possible, the fields does not exist anymore, check again with a CURRENT version.

Thank you

#6 Updated by William Grzybowski over 6 years ago

  • Status changed from Closed: Cannot reproduce to Investigation

#7 Updated by William Grzybowski over 6 years ago

My mistake here, I got it in the inverse order, the API docs is for 9.2.1, sorry. However the ad_workgroup field is indeed gone.

#8 Updated by William Grzybowski over 6 years ago

  • Status changed from Investigation to Resolved

#9 Updated by Dru Lavigne almost 3 years ago

  • Target version set to Master - FreeNAS Nightlies
  • Seen in changed from to Unspecified

Also available in: Atom PDF