Project

General

Profile

Bug #53638

Set background color of pool in new UI based on its status

Added by G Smith 5 months ago. Updated about 1 month ago.

Status:
Done
Priority:
No priority
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

One of my pools is degraded (one of the disks is offline), but a new disk is currently resilvering. During the process, the Disk Widget on the Dashboard correctly shows the pool as "Degraded". However, it colors the widget green and has a checkmark next to the status. Both of these are deceiving since the pool is still degraded.
I would prefer to see it colored yellow and the checkmark removed. (It may make sense to have some type of icon or text indicating resilvering is in progress and a healthy status will be resulting soon instead.)

FreeNAS_dashboard_degraded_pool.PNG (17.1 KB) FreeNAS_dashboard_degraded_pool.PNG G Smith, 10/24/2018 07:58 PM
Degraded.png (145 KB) Degraded.png Jeff Ervin, 02/14/2019 06:48 AM
Normal.png (143 KB) Normal.png Jeff Ervin, 02/14/2019 06:52 AM
36603
54525
54526

Related issues

Has duplicate FreeNAS - Bug #73362: Same icon for both, healthy and degraded, pools in dashboardClosed
Has duplicate FreeNAS - Feature #63081: Have green box around the pool turn yellow when the pool is in a degraded state.Closed

History

#2 Updated by Dru Lavigne 5 months ago

  • Assignee changed from Release Council to Damian Szidiropulosz
  • Target version changed from Backlog to 11.2-U2

#3 Updated by Damian Szidiropulosz 2 months ago

  • Status changed from Unscreened to Screened

#4 Updated by Dru Lavigne 2 months ago

  • Status changed from Screened to In Progress

#5 Updated by Erin Clark 2 months ago

  • Status changed from In Progress to Ready for Testing

#6 Updated by Dru Lavigne 2 months ago

  • Subject changed from Do not show degraded pools in green on the Dashboard to Sets background color of pool in new UI based on its status
  • Needs Merging changed from Yes to No

#7 Updated by Dru Lavigne 2 months ago

  • Subject changed from Sets background color of pool in new UI based on its status to Set background color of pool in new UI based on its status

#12 Updated by Dru Lavigne about 2 months ago

  • Has duplicate Bug #73362: Same icon for both, healthy and degraded, pools in dashboard added

#13 Updated by Dru Lavigne about 2 months ago

  • Has duplicate Feature #63081: Have green box around the pool turn yellow when the pool is in a degraded state. added

#14 Updated by Dru Lavigne about 1 month ago

  • Needs Doc changed from Yes to No

#15 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 month ago

I am able to confirm green for healthy, locked, and unavailable, and yellow for degraded and unknown. Unable to replicate neither an offline state nor a faulted or removed state to see a red background. Only getting degraded when I inject a fault. Maybe this is enough, since the addition of the yellow background is part of it.

#16 Updated by Jeff Ervin about 1 month ago

  • File Screen Shot 2019-02-14 at 9.06.19 AM.png added
  • File Screen Shot 2019-02-14 at 9.08.29 AM.png added
  • File Degraded.png Degraded.png added
54525

#17 Updated by Jeff Ervin about 1 month ago

54526

#18 Updated by Jeff Ervin about 1 month ago

Results similar to Zach's. Green/yellow I can see, unable to reproduce red.

#19 Updated by Jeff Ervin about 1 month ago

  • File deleted (Screen Shot 2019-02-14 at 9.08.29 AM.png)

#20 Updated by Jeff Ervin about 1 month ago

  • File deleted (Screen Shot 2019-02-14 at 9.06.19 AM.png)

#21 Updated by Bonnie Follweiler about 1 month ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

#23 Updated by Dru Lavigne about 1 month ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF