Project

General

Profile

Bug #53961

Unable to 'Attach' or 'Replace' a Boot Device

Added by Matthew Steinhoff almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Using both the classic interface and the new GUI...

  • Inserted two new SAS drives which were recognized by FreeNAS
  • Tried to 'Attach' the first SAS drive to the mirror boot group. Received message:
'async for' requires an object with __aiter__ method, got generator
  • Tried to 'Replace' one of the USB sticks with the SAS drive. Received message:
'async for' requires an object with __aiter__ method, got generator

From the new GUI, I'm able to get the full message...

TypeError

Error: Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 155, in call_method
    result = await self.middleware.call_method(self, message)
  File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 1033, in call_method
    return await self._call(message['method'], serviceobj, methodobj, params, app=app, io_thread=False)
  File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 973, in _call
    return await methodobj(*args)
  File "/usr/local/lib/python3.6/site-packages/middlewared/schema.py", line 664, in nf
    return await f(*args, **kwargs)
  File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/boot.py", line 194, in replace
    boottype = await self.format(dev)
  File "/usr/local/lib/python3.6/site-packages/middlewared/schema.py", line 664, in nf
    return await f(*args, **kwargs)
  File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/boot.py", line 65, in format
    boottype = await self.get_boot_type()
  File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/boot.py", line 37, in get_boot_type
    async for disk in await self.get_disks():
TypeError: 'async for' requires an object with __aiter__ method, got generator

Per William Grzybowski, may already be fixed in RC1 (https://redmine.ixsystems.com/issues/53485#change-363591).


Related issues

Is duplicate of FreeNAS - Bug #45072: Fix regression on boot device attach and replaceDone

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from Release Council to William Grzybowski

#2 Updated by William Grzybowski almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

Sorry, I wish I had found the other ticket in time.

#3 Updated by William Grzybowski almost 2 years ago

  • Is duplicate of Bug #45072: Fix regression on boot device attach and replace added

Also available in: Atom PDF