Project

General

Profile

Bug #5398

updating OwnCloud loses all saved Owncloud users

Added by Dan Trass about 6 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Nice to have
Assignee:
Joshua Ruehlig
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When updating ownCloud from 6.0.2 to 6.0.3 via the pbi plugin jail it seems the users db is not kept in tact. All users that are in the ownCloud system are lost except for the admin user. old user data is safe but the accounts are gone. The internets say the problem is because of the SQLite db that is used be default. all suggestions say to user MySQL instead.


Related issues

Related to FreeNAS - Feature #5389: Request to update ownCloud plugin to 6.0.4 (or latest)Resolved2014-07-27

History

#1 Updated by Jordan Hubbard about 6 years ago

  • Category set to 33
  • Assignee set to Sean Fagan
  • Target version set to 49

#2 Updated by Cyber Jock about 6 years ago

This was asked for a few weeks ago. There's 2 problems:

1. SQLite works very well for small servers with one or two users. It doesn't provide good performance with large numbers of users, but doesn't have much overhead.
2. MySQL scales to very large sizes and provides good performance but has horrendous overhead. One forum user tried to setup MySQL for Owncloud and MySQL needed 1GB of RAM with no user accounts created yet. For the vast majority of FreeNAS users this overhead is far too high and would make the pbi something that they cannot handle because of hardware constraints.

In short, you may want to research what you really want. You may find that you can solve the problem yourself by not using the pbi and instead creating your own jail that you can manage however you see fit. I run my own jail for unrelated reasons and I recommend users that plan to use Owncloud as a long-term option choose to build and manage their own jail. There are several guides in the forum on how to make your own Owncloud jail and some of them are step-by-step.

#3 Updated by Sean Fagan about 6 years ago

  • Related to Feature #5389: Request to update ownCloud plugin to 6.0.4 (or latest) added

#4 Updated by Sean Fagan about 6 years ago

  • Status changed from Unscreened to Screened

This sounds like a problem with owncloud, then?

I have no idea what happens when a plugin updates itself.

#5 Updated by Johnathan Winslow about 6 years ago

I experienced this issue as well, when upgrading the official plugin via the FreeNAS GUI's "Update" button from 6.0.2 -> 6.0.3.

#6 Updated by Jordan Hubbard over 5 years ago

  • Assignee changed from Sean Fagan to Joshua Ruehlig

#7 Updated by Joshua Ruehlig over 5 years ago

I don't think this is still applicable and can be 'Closed', but I'll wait for someone else to weigh in.

#8 Updated by Joshua Ruehlig over 5 years ago

  • Status changed from Screened to Resolved

I fixed this with version 8 of this plugin as verified with my local testing.
https://forums.freenas.org/index.php?threads/owncloud-plugin-now-available-in-plugins-menu.15046/page-7#post-179792

#9 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Target version changed from 49 to N/A

Also available in: Atom PDF