Project

General

Profile

Bug #54105

Fix mDNS middleware traceback

Added by Bug Clerk almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

future: <Task finished coro=<Middleware.call() done, defined at /usr/local/lib/python3.7/site-packages/middlewared/main.py:1026> exception=AttributeError("'NoneType' object has no attribute 'cancel'")>
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/middlewared/main.py", line 1028, in call
    return await self._call(name, serviceobj, methodobj, params, app=app, pipes=pipes, io_thread=True)
  File "/usr/local/lib/python3.7/site-packages/middlewared/main.py", line 979, in _call
    return await run_method(methodobj, *args)
  File "/usr/local/lib/python3.7/site-packages/middlewared/main.py", line 925, in run_in_thread
    return await self.loop.run_in_executor(executor, functools.partial(method, *args, **kwargs))
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.7/site-packages/middlewared/plugins/mdns.py", line 618, in start
    self.dthread = DiscoverThread(queue=self.dq, middleware=self.middleware, timeout=5)
  File "/usr/local/lib/python3.7/site-packages/middlewared/plugins/mdns.py", line 292, in __init__
    super(DiscoverThread, self).__init__(**kwargs)
  File "/usr/local/lib/python3.7/site-packages/middlewared/plugins/mdns.py", line 284, in __init__
    self.mdnsd.wait(timeout=10)
  File "/usr/local/lib/python3.7/site-packages/middlewared/plugins/mdns.py", line 210, in wait
    self.middleware.call_sync('mdnsbrowser.restart')
  File "/usr/local/lib/python3.7/site-packages/middlewared/main.py", line 1054, in call_sync
    return fut.result()
  File "/usr/local/lib/python3.7/concurrent/futures/_base.py", line 425, in result
    return self.__get_result()
  File "/usr/local/lib/python3.7/concurrent/futures/_base.py", line 384, in __get_result
    raise self._exception
  File "/usr/local/lib/python3.7/site-packages/middlewared/main.py", line 979, in _call
    return await run_method(methodobj, *args)
  File "/usr/local/lib/python3.7/site-packages/middlewared/main.py", line 925, in run_in_thread
    return await self.loop.run_in_executor(executor, functools.partial(method, *args, **kwargs))
  File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.7/site-packages/middlewared/plugins/mdns.py", line 646, in restart
    self.stop()
  File "/usr/local/lib/python3.7/site-packages/middlewared/plugins/mdns.py", line 634, in stop
    self.rthread.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'

Acceptance Criteria
After fresh install above traceback should not be seen on middlewared.log


Related issues

Is duplicate of FreeNAS - Bug #54324: Fix mDNS middleware tracebackClosed
Copied from FreeNAS - Bug #53898: Fix mDNS middleware tracebackDone

History

#1 Updated by Bug Clerk almost 2 years ago

  • Copied from Bug #53898: Fix mDNS middleware traceback added

#2 Updated by Bug Clerk almost 2 years ago

  • Target version changed from Master - FreeNAS Nightlies to 11.2-RC2

#3 Updated by Bug Clerk almost 2 years ago

  • Status changed from Unscreened to In Progress

#4 Updated by Bug Clerk almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#5 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Fix mdns middleware tracebacks to Fix mDNS middleware traceback
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#6 Updated by William Grzybowski almost 2 years ago

  • Status changed from Ready for Testing to In Progress

#7 Updated by William Grzybowski almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#8 Updated by Dru Lavigne almost 2 years ago

  • Is duplicate of Bug #54324: Fix mDNS middleware traceback added

#9 Updated by Bonnie Follweiler almost 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreeNAS-11.2-INTERNAL39

#10 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF