Project

General

Profile

Bug #54204

winacl high WCPU in 11.2RC1

Added by Packetloss none over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Andrew Walker
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
User Configuration Error
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After upgrading from 11.2beta3 to 11.2RC1, I noticed slow performance on my box, even without running VM's and not (heavy) disk activity. What I saw with top was

  PID USERNAME    THR PRI NICE   SIZE    RES STATE   C   TIME    WCPU COMMAND
72873 root          1  87    0 12464K  2856K RUN     1   4:19  94.86% winacl

In this thread: https://forums.freenas.org/index.php?threads/my-experiences-with-fn-11-2-rc1.70813/ the user dlavigne.2 asked me to file a bug.

History

#1 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Blocked
  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Please attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Packetloss none over 2 years ago

  • File ixdiagnose.rar added

#3 Updated by Packetloss none over 2 years ago

Dru Lavigne wrote:

Please attach a debug (System -> Advanced -> Save debug) to this ticket.

done, thank you for taking the time to investigate.

#4 Updated by Dru Lavigne over 2 years ago

  • Category changed from Console to Services
  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#5 Updated by William Grzybowski over 2 years ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from William Grzybowski to Andrew Walker
  • Target version changed from Backlog to 11.2-RC2

Andrew, do you think that may be a regression from latest changes in there?

#6 Updated by Andrew Walker over 2 years ago

I'm having problems extracting the debug you attached. Please generate a fresh one and attach it unmodified to the ticket.

Winacl will typically show high CPU while it's resetting permissions. The question is why it's resetting permissions. Did you recently create a new SMB share, modify an existing SMB share, or configure S3?

#7 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

#8 Updated by Dru Lavigne over 2 years ago

  • File ixdiagnose.tgz added
  • Status changed from Blocked to Unscreened
  • Reason for Blocked deleted (Need additional information from Author)

#10 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-RC2 to 11.2-U2

#11 Updated by Andrew Walker over 2 years ago

High CPU usage for winacl was caused by a permissions reset for zoneminder:

[2018/10/25 05:12:28] (DEBUG) middleware.notifier.winacl_reset():1397 - winacl_reset: cmd = /usr/local/bin/winacl -a reset -O 'zoneminder' -G 'zoneminder' -r  -p '/mnt/bert/zoneminder' -x

Depending on contents of that path, this is expected behavior.

#12 Updated by Dru Lavigne over 2 years ago

  • File deleted (ixdiagnose.rar)

#13 Updated by Dru Lavigne over 2 years ago

  • File deleted (ixdiagnose.tgz)

#14 Updated by Dru Lavigne over 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from 11.2-U2 to N/A
  • Private changed from Yes to No
  • Reason for Closing set to User Configuration Error

Also available in: Atom PDF