Project

General

Profile

Bug #54366

Fix tracebacks in preferences page of new UI

Added by Timothy Moore II over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Testing with FreeNAS system installed with INTERNAL30:

I went to System/Update and clicked Fetch and Install Updates to download the available 11.2-RC1 version. Nothing happened. Tried again, and the loading popup appears for a few moments, then disappears - nothing happens. I expected to see a popup asking to continue with the download.
After discussing with Jeff in QA, I went to Settings/Preferences and unset "Hide warning config prompt on upgrade" option. I went back to System/Update and clicked "Fetch and Install". Popups now appear: the first asks if I want to save a copy of the config and the next if I want to continue with the download.

I would expect that unsetting that checkbox would disable the first "save a copy of the config" popup and not prevent downloading an update entirely.

Screen Shot 2018-10-31 at 3.01.52 PM.png (126 KB) Screen Shot 2018-10-31 at 3.01.52 PM.png Jeff Ervin, 10/31/2018 12:07 PM
Screen Shot 2018-10-31 at 3.02.05 PM.png (126 KB) Screen Shot 2018-10-31 at 3.02.05 PM.png Jeff Ervin, 10/31/2018 12:07 PM
Screen Shot 2018-10-31 at 3.37.29 PM.png (38.4 KB) Screen Shot 2018-10-31 at 3.37.29 PM.png Jeff Ervin, 10/31/2018 01:39 PM
Screen Shot 2018-10-31 at 3.38.04 PM.png (95.6 KB) Screen Shot 2018-10-31 at 3.38.04 PM.png Jeff Ervin, 10/31/2018 01:39 PM
Screen Shot 2018-10-31 at 3.50.42 PM.png (116 KB) Screen Shot 2018-10-31 at 3.50.42 PM.png Jeff Ervin, 10/31/2018 01:39 PM
Screen Shot 2018-10-31 at 3.40.25 PM.png (120 KB) Screen Shot 2018-10-31 at 3.40.25 PM.png Jeff Ervin, 10/31/2018 01:39 PM
Screen Shot 2018-10-31 at 3.50.51 PM.png (51.2 KB) Screen Shot 2018-10-31 at 3.50.51 PM.png Jeff Ervin, 10/31/2018 01:39 PM
Screen Shot 2018-10-31 at 3.51.58 PM.png (42.6 KB) Screen Shot 2018-10-31 at 3.51.58 PM.png Jeff Ervin, 10/31/2018 01:39 PM
Screen Shot 2018-10-31 at 3.54.32 PM.png (114 KB) Screen Shot 2018-10-31 at 3.54.32 PM.png Jeff Ervin, 10/31/2018 01:39 PM
Screen Shot 2018-11-05 at 9.14.11 AM.png (41.3 KB) Screen Shot 2018-11-05 at 9.14.11 AM.png Jeff Ervin, 11/05/2018 06:59 AM
Screen Shot 2018-11-05 at 9.15.03 AM.png (135 KB) Screen Shot 2018-11-05 at 9.15.03 AM.png Jeff Ervin, 11/05/2018 06:59 AM
Screen Shot 2018-11-05 at 9.15.47 AM.png (132 KB) Screen Shot 2018-11-05 at 9.15.47 AM.png Jeff Ervin, 11/05/2018 06:59 AM
Screen Shot 2018-11-05 at 9.16.39 AM.png (114 KB) Screen Shot 2018-11-05 at 9.16.39 AM.png Jeff Ervin, 11/05/2018 06:59 AM
Screen Shot 2018-11-05 at 9.23.03 AM.png (99.8 KB) Screen Shot 2018-11-05 at 9.23.03 AM.png Jeff Ervin, 11/05/2018 06:59 AM
Screen Shot 2018-11-05 at 9.17.14 AM.png (112 KB) Screen Shot 2018-11-05 at 9.17.14 AM.png Jeff Ervin, 11/05/2018 06:59 AM
Screen Shot 2018-11-05 at 9.31.18 AM.png (40.1 KB) Screen Shot 2018-11-05 at 9.31.18 AM.png Jeff Ervin, 11/05/2018 06:59 AM
Screen Shot 2018-11-05 at 9.31.43 AM.png (117 KB) Screen Shot 2018-11-05 at 9.31.43 AM.png Jeff Ervin, 11/05/2018 06:59 AM
Screen Shot 2018-11-05 at 9.32.07 AM.png (53.5 KB) Screen Shot 2018-11-05 at 9.32.07 AM.png Jeff Ervin, 11/05/2018 06:59 AM
Middleware Log 11_5_18.rtf (66.4 KB) Middleware Log 11_5_18.rtf Jeff Ervin, 11/05/2018 07:11 AM
37878
37881
37995
37998
38004
38007
38013
38016
38022
38889
38898
38907
38916
38925
38934
38943
38952
38961

Related issues

Related to FreeNAS - Feature #26198: Give opportunity to save config when installing updates in new UIDone
Related to FreeNAS - Bug #51656: Feature parity for Save Debug in new UIDone

History

#1 Updated by Timothy Moore II over 1 year ago

  • Related to Feature #26198: Give opportunity to save config when installing updates in new UI added

#2 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-RC2

#4 Updated by Erin Clark over 1 year ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

#5 Updated by Vaibhav Chauhan over 1 year ago

  • Assignee changed from Vaibhav Chauhan to Timothy Moore II

#6 Updated by Vaibhav Chauhan over 1 year ago

I cannot reproduce issue where I am not allowed to download the updates as a part of save config, however there was an issue where configs were not getting downloaded due to commented code which was handling this part. please retry this code after its merged to master or you can try building Gui files locally(let me know If you need any help)

PR for download part:
STABLE: https://github.com/freenas/webui/pull/1455
MASTER: https://github.com/freenas/webui/pull/1454

#7 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to In Progress

#8 Updated by Dru Lavigne over 1 year ago

  • Subject changed from System/Update: Fetch and Install Updates doesn't work when Settings/Preferences "Hide warning config prompt on upgrade" field is set to Fix tracebacks in preferences page of new UI
  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#9 Updated by Jeff Ervin over 1 year ago

37878
37881

#10 Updated by Jeff Ervin over 1 year ago

  • Status changed from Passed Testing to Ready for Testing

#11 Updated by Jeff Ervin over 1 year ago

37995
37998
38004
38007
38013
38016
38022

Test Failed FreeNAS-11.2-INTERNAL32

1. In Preferences, unchecked the box "Hide warning Config prompt on upgrade"
2. On the Updates page I clicked the "Fetch and Install Updates" button
3. Brief spinner, then I get the dialog box "Before doing update, would you like to save a copy of the config?" If I say "cancel" here, the update file downloads.
4. If I say "OK" to the save config option, I get taken to the login page where there's a dialog box with the option to save the config file. Login page? Why?
5. After saving file, the option to download the updates is shown. I didn't check the box to "apply updates and reboot system after downloading". I hit "Continue"
6. I get the "Starting Job" dialog box while at the login screen. There it sits without any progress (30 minutes). Hit cancel, log back in.

#12 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Timothy Moore II to Vaibhav Chauhan

#13 Updated by Vaibhav Chauhan over 1 year ago

  • Related to Bug #51656: Feature parity for Save Debug in new UI added

#14 Updated by Vaibhav Chauhan over 1 year ago

  • Status changed from Failed Testing to Closed

#16 Updated by Dru Lavigne over 1 year ago

  • Status changed from Closed to Ready for Testing

#18 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF