Project

General

Profile

Bug #54459

Fix bug that prevented disks from appearing in Reporting screen of new UI

Added by Jeff Alperin almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Reporting > Disk showing only two of eight disks. ada0-1 in ts140pool show properly. da0-5 in ts140tank do not. Both pools are healthy and all disks show on dashboard and in Storage > Pools. Reporting for disks is correct in legacy UI.

01 Dashboard 2018-11-01 at 8.48.57 AM.jpg (429 KB) 01 Dashboard 2018-11-01 at 8.48.57 AM.jpg Jeff Alperin, 11/01/2018 08:21 AM
02 Pools and Disks 2018-11-01 at 8.50.21 AM.jpg (392 KB) 02 Pools and Disks 2018-11-01 at 8.50.21 AM.jpg Jeff Alperin, 11/01/2018 08:21 AM
03 Reports Disks 1 2018-11-01 at 8.53.58 AM.jpg (428 KB) 03 Reports Disks 1 2018-11-01 at 8.53.58 AM.jpg Jeff Alperin, 11/01/2018 08:21 AM
04 Reports Disks 2 2018-11-01 at 8.55.36 AM.jpg (412 KB) 04 Reports Disks 2 2018-11-01 at 8.55.36 AM.jpg Jeff Alperin, 11/01/2018 08:21 AM
05 Reports Disks 3 2018-11-01 at 8.56.22 AM.jpg (410 KB) 05 Reports Disks 3 2018-11-01 at 8.56.22 AM.jpg Jeff Alperin, 11/01/2018 08:21 AM
06 Reports Disks 4 2018-11-01 at 8.57.07 AM.jpg (425 KB) 06 Reports Disks 4 2018-11-01 at 8.57.07 AM.jpg Jeff Alperin, 11/01/2018 08:22 AM
07 Reports Disks 5 2018-11-01 at 8.59.14 AM.jpg (456 KB) 07 Reports Disks 5 2018-11-01 at 8.59.14 AM.jpg Jeff Alperin, 11/01/2018 08:22 AM
08 Legacy 2018-11-01 at 11.09.03 AM.jpg (527 KB) 08 Legacy 2018-11-01 at 11.09.03 AM.jpg Jeff Alperin, 11/01/2018 08:22 AM
09 Reports Disk 1 2018-11-01 at 11.13.28 AM.jpg (626 KB) 09 Reports Disk 1 2018-11-01 at 11.13.28 AM.jpg Jeff Alperin, 11/01/2018 08:22 AM
10 Reports Disk 2 2018-11-01 at 11.14.38 AM.jpg (586 KB) 10 Reports Disk 2 2018-11-01 at 11.14.38 AM.jpg Jeff Alperin, 11/01/2018 08:22 AM
11 Reports Disk 3 2018-11-01 at 11.15.22 AM.jpg (603 KB) 11 Reports Disk 3 2018-11-01 at 11.15.22 AM.jpg Jeff Alperin, 11/01/2018 08:29 AM
12 11.1-U6 2018-11-01 at 9.53.54 AM.jpg (515 KB) 12 11.1-U6 2018-11-01 at 9.53.54 AM.jpg Jeff Alperin, 11/01/2018 08:29 AM
13 11.1-U6 Reports Disks 2018-11-01 at 9.58.23 AM.jpg (576 KB) 13 11.1-U6 Reports Disks 2018-11-01 at 9.58.23 AM.jpg Jeff Alperin, 11/01/2018 08:29 AM
Screen Shot 2018-11-01 at 3.15.09 PM.jpg (598 KB) Screen Shot 2018-11-01 at 3.15.09 PM.jpg No report data for externally attached sas disks (da0-5) Jeff Alperin, 11/01/2018 12:19 PM
38238
38241
38250
38256
38259
38265
38268
38274
38277
38283
38286
38292
38295
38427

Related issues

Copied to FreeNAS - Bug #55860: Fix bug that prevented disks from appearing in Reporting screen of new UIClosed

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Jeff: to assist the dev in diagnosing the cause, please attach the following to this ticket:
1. a screenshot of the incorrect listing in the new UI
2. a screenshot of the correct listing in the legacy UI
3. a debug (System -> Advanced -> Save debug)

#3 Updated by Jeff Alperin almost 2 years ago

38286
38292
38295

Attachcment 11 continues 11.2-RC1 legacy reports > disk.

Attachcment 12 to 13 show 11.1-U6 legacy reports > disk. Also sparse.

debug file is from 11.2_RC1

#4 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-U2
  • Reason for Blocked deleted (Need additional information from Author)

#5 Updated by Erin Clark almost 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Could you please try 11.2 release when it comes out and see if you are still having this issue? The disks reporting section has been reworked to let the user select which disks they want to view to alleviate issues with viewing disks.

#6 Updated by Jeff Alperin almost 2 years ago

38427

OK, but my problem may go beyond merely selecting what to view. In the attached screenshot you can see that I have no data for my SAS connected drives. And, the earlier screenshots I sent showed this same issue in 11.1-U6. Do you think that is fixed in 11.2?

#7 Updated by Erin Clark almost 2 years ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Erin Clark to Damian Szidiropulosz
  • Reason for Blocked deleted (Waiting for feedback)

Damian, could you look into this and see whether or not any work needs to be done to fix these issues?

#8 Updated by Jeff Alperin almost 2 years ago

Hello, Damian.

If you need access to my FN system we can arrange that.

Thank you for your help.

#10 Updated by Dru Lavigne almost 2 years ago

  • Assignee changed from Damian Szidiropulosz to Erin Clark
  • Target version changed from 11.2-U2 to 11.2-RC2

#11 Updated by Erin Clark almost 2 years ago

  • Assignee changed from Erin Clark to Damian Szidiropulosz

#13 Updated by Damian Szidiropulosz almost 2 years ago

  • Status changed from Unscreened to In Progress

The Report Builder form implementation broke the pager. PRs 1485 fixes this.

#14 Updated by Dru Lavigne almost 2 years ago

  • File deleted (debug-ts140-20181101091823.tgz)

#15 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Reporting > Disk Incomplete in new GUI to Fix bug that prevented disks from appearing in Reporting screen of new UI
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No

#16 Updated by Erin Clark almost 2 years ago

  • Copied to Bug #55860: Fix bug that prevented disks from appearing in Reporting screen of new UI added

#17 Updated by Erin Clark almost 2 years ago

  • Status changed from In Progress to Ready for Testing

#18 Updated by Dru Lavigne almost 2 years ago

  • Needs Merging changed from Yes to No

#19 Updated by Jeff Ervin almost 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed FreeNAS-11.2-RC2

All Disks show in reporting section in both the new GUI and Legacy.

#20 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF