Project

General

Profile

Bug #54900

Plugins (Emby) not updating

Added by Silvan Burch about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Martin Wilke
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

II recently updated to FreeNAS 11.2 and I'm mostly using Docker for all my Plugins / additional software now.
However, I used the Emby plugin since I was thinking Emby will need a lot of CPU power and it would be better than using a VM for running it.

Anyway, everything works fine so far but today I tried to update the plugin to the newest version (from 3.5.2.0 --> 3.5.3.0) over the 'Jails' menu as stated in the user manual. FreeNAS prints the message 'Jail updated sucessfully' immediately but it is not updated.

Thread in forum:
https://forums.freenas.org/index.php?threads/freenas-11-2-update-plugins.70975/


Related issues

Related to FreeNAS - Bug #57465: Updating plugins brokenClosed

History

#1 Updated by Silvan Burch about 1 year ago

  • File debug-fenix4k-20181102145117.txz added
  • Private changed from No to Yes

#2 Updated by Silvan Burch about 1 year ago

  • Private changed from Yes to No

#3 Updated by Silvan Burch about 1 year ago

  • File deleted (debug-fenix4k-20181102145117.txz)

#4 Updated by Dru Lavigne about 1 year ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Silvan: please reattach the debug as we'll need that to see what is going on. The ticket is marked private and we will remove the debug once the dev is able to diagnose the issue.

#5 Updated by Silvan Burch about 1 year ago

I'm sorry, didn't realise. Could you tell me how to generate the debug again so I can add it?

#6 Updated by Dru Lavigne about 1 year ago

System -> Advanced -> Save debug. Thanks!

#7 Updated by Silvan Burch about 1 year ago

  • File debug.tgz added

#8 Updated by Dru Lavigne about 1 year ago

  • Category changed from Services to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#10 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to Blocked

Can you confirm where exactly you updated?

I will note that updating a Jail under the jail menu will update the jail version, not the plugin.

#11 Updated by Silvan Burch about 1 year ago

which is of course exactly what I tried ... sorry I have misunderstood the instructions in the manual and as it seems there are a few other on the forum with the same mistake.

what is the right way to update the plugin in said jail, then?

#12 Updated by William Grzybowski about 1 year ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.2-U2

Good question, sending to Brandon for verification.

#13 Updated by Brandon Schneider about 1 year ago

  • Status changed from Unscreened to In Progress

#14 Updated by Brandon Schneider about 1 year ago

Silvan: Does updating on the CLI work for you? iocage update JAILNAME

#15 Updated by Silvan Burch about 1 year ago

may I ask how I do that correctly?
and what should be the outcome? that the plugin is updated?

#16 Updated by Brandon Schneider about 1 year ago

Sure!

First use this on the command line:

iocage list

Find your jail (likely named emby)

Then do:

iocage update emby

and wait. If anything comes back with an error, post that here. But the end result should be an updated plugin.

#17 Updated by Silvan Burch 12 months ago

hey there

I did that and it updates! thanks for this

however, it seems not to be installing the right dependencies since i get the following error:
"Playback Error - No compatible streams are currently available. Please try again later or contact your system administrator for details."

a quick look in the log file showed the following:
"Shared object "libx264.so.152" not found, required by "libavcodec.so.58""

is this a bug?

#18 Updated by Brandon Schneider 12 months ago

  • Status changed from In Progress to Blocked
  • Reason for Blocked set to Need verification

Silvan: Hmm perhaps something is amiss in the update code. Can you do the following?

iocage console JAIL_NAME
pkg upgrade -f
service emby_server restart

Does the same error show in the logs?

#19 Updated by Silvan Burch 12 months ago

the line

service emby_server restart

does not work --> emby_server does not exist in /etc/rc.d or the local startup

i restarted the jail from the webgui and tried again, still the same error in the log file:

Shared object "libx264.so.152" not found, required by "libavcodec.so.58"

#20 Updated by Brandon Schneider 12 months ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Brandon Schneider to Martin Wilke

Passing to miwi to investigate as it's a plugin issue and not iocage

#21 Updated by Silvan Burch 12 months ago

hey i updated to Version 3.6.0.64 ... this fixes the problem :)

thanks for all your help

#22 Updated by Dru Lavigne 12 months ago

  • File deleted (debug.tgz)

#23 Updated by Dru Lavigne 12 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from 11.2-U2 to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Not Applicable
  • Reason for Blocked deleted (Need verification)

Thanks for the update Silvan.

#24 Updated by Brandon Schneider 12 months ago

  • Related to Bug #57465: Updating plugins broken added

Also available in: Atom PDF