Project

General

Profile

Bug #55053

Dashboard glitch in disk section

Added by Patrick M. Hausen almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Damian Szidiropulosz
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In the dashboard you can click on the individual disks' icons to get information like serialnumber or temperature.

My system has got 4 spinning hard disks (ada0 - ada3), one M.2 SSD (ada4) and a SATA-DOM (ada5).

This works as intended for the hard disks - ada3 to ada0 from left to right as marked in the screenshots.
Clicking the next icon works, too, and displays the data of ada4. Clicking on the rightmost icon just shows
the same data (of ada4) instead of the remaining disk ada5.

  • Why is the order of disks in the dashboard ada3, ada2, ada1, ada0, ada4, (ada5)?
  • Why can't I get the data for ada5?

Thanks,
Patrick

root@freenas-pmh:~ # dmesg |grep ada
ada0 at ahcich0 bus 0 scbus0 target 0 lun 0
ada0: <TOSHIBA HDWQ140 FJ1M> ATA8-ACS SATA 3.x device
ada0: Serial Number 6779K0VYFPBE
ada0: 600.000MB/s transfers (SATA 3.x, UDMA5, PIO 8192bytes)
ada0: Command Queueing enabled
ada0: 3815447MB (7814037168 512 byte sectors)
ada1 at ahcich1 bus 0 scbus1 target 0 lun 0
ada1: <TOSHIBA HDWQ140 FJ1M> ATA8-ACS SATA 3.x device
ada1: Serial Number 6761K1IQFPBE
ada1: 600.000MB/s transfers (SATA 3.x, UDMA5, PIO 8192bytes)
ada1: Command Queueing enabled
ada1: 3815447MB (7814037168 512 byte sectors)
ada2 at ahcich2 bus 0 scbus2 target 0 lun 0
ada2: <TOSHIBA HDWQ140 FJ1M> ATA8-ACS SATA 3.x device
ada2: Serial Number 6779K0VZFPBE
ada2: 600.000MB/s transfers (SATA 3.x, UDMA5, PIO 8192bytes)
ada2: Command Queueing enabled
ada2: 3815447MB (7814037168 512 byte sectors)
ada3 at ahcich3 bus 0 scbus3 target 0 lun 0
ada3: <TOSHIBA HDWQ140 FJ1M> ATA8-ACS SATA 3.x device
ada3: Serial Number 677FK0OUFPBE
ada3: 600.000MB/s transfers (SATA 3.x, UDMA5, PIO 8192bytes)
ada3: Command Queueing enabled
ada3: 3815447MB (7814037168 512 byte sectors)
ada4 at ahcich8 bus 0 scbus8 target 0 lun 0
ada4: <Crucial CT275MX300SSD4 M0CR060> ACS-3 ATA SATA 3.x device
ada4: Serial Number 18021A6C8C0F
ada4: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 8192bytes)
ada4: Command Queueing enabled
ada4: 262321MB (537234768 512 byte sectors)
ada5 at ahcich14 bus 0 scbus13 target 0 lun 0
ada5: <SuperMicro SSD SOB20R> ACS-2 ATA SATA 3.x device
ada5: Serial Number SMC0515D90717B682013
ada5: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 512bytes)
ada5: Command Queueing enabled
ada5: 30208MB (61865984 512 byte sectors)
ada1.jpg (25.9 KB) ada1.jpg Patrick M. Hausen, 11/05/2018 03:57 AM
ada0.jpg (26 KB) ada0.jpg Patrick M. Hausen, 11/05/2018 03:57 AM
ada3.jpg (26 KB) ada3.jpg Patrick M. Hausen, 11/05/2018 03:57 AM
ada2.jpg (25.9 KB) ada2.jpg Patrick M. Hausen, 11/05/2018 03:57 AM
ada4.jpg (26.2 KB) ada4.jpg Patrick M. Hausen, 11/05/2018 03:57 AM
ada5.jpg (28.8 KB) ada5.jpg Patrick M. Hausen, 11/05/2018 03:57 AM
debug.tgz (761 KB) debug.tgz Patrick M. Hausen, 11/05/2018 04:11 AM
38673
38679
38682
38691
38697
38700

Related issues

Related to FreeNAS - Bug #84219: Disk Health dashboard widget is showing the wrong disk numbersClosed

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from Release Council to Anonymous
  • Target version changed from Backlog to 11.2-U2

#2 Updated by Patrick M. Hausen almost 3 years ago

  • Seen in changed from 11.2-BETA3 to 11.2-RC1

#3 Updated by Anonymous almost 3 years ago

  • Assignee changed from Anonymous to Damian Szidiropulosz

#4 Updated by Patrick M. Hausen almost 3 years ago

Problem gone after I repurposed my SSD changing the partition and the role in the zpool in the process. Since I provided a complete debug.tgz you might want to look into that to catch rare edge cases, but i would not mind if you close it as "cannot reproduce", either.

Kind regards,
Patrick

#5 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 11.2-U2 to 11.2-U3

#6 Updated by Dru Lavigne over 2 years ago

  • Target version changed from 11.2-U3 to 11.2-U4

#7 Updated by Dru Lavigne over 2 years ago

  • Related to Bug #84219: Disk Health dashboard widget is showing the wrong disk numbers added

#8 Avatar?id=14398&size=24x24 Updated by Kris Moore over 2 years ago

  • Status changed from Unscreened to Closed

Also available in: Atom PDF