Project

General

Profile

Bug #55734

Remove showmount from freenas-debug to prevent hang condition

Added by Caleb St. John 8 months ago. Updated 8 months ago.

Status:
Done
Priority:
No priority
Assignee:
Caleb St. John
Category:
Middleware
Target version:
Seen in:
TrueNAS - TrueNAS-11.1-U6.1
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

freenas-debug being run on an HA system, will sometimes fail to capture the passive controllers debug because of this traceback

Nov 5 07:48:26 truenas-node-A uwsgi: [system.utils:406] Failed to get debug from standby node
Traceback (most recent call last):
File "./freenasUI/system/utils.py", line 404, in debug_generate
standby_debug = c.call('failover.call_remote', 'system.debug', [], {'job': True}, timeout=300)
File "./freenasUI/system/utils.py", line 404, in debug_generate
standby_debug = c.call('failover.call_remote', 'system.debug', [], {'job': True}, timeout=300)
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py", line 429, in call
raise CallTimeout("Call timeout")
middlewared.client.client.CallTimeout: Call timeout

This is because freenas-debug is running job=True with timeout=300 and the "showmount -e" command is hanging so the entire debug process is failing.

This bug is to create a workaround for "showmount -e" command.


Related issues

Has duplicate FreeNAS - Bug #56157: Download of Debug from an HA system appears as a single node system within that debug fileClosed
Copied to FreeNAS - Bug #60390: Remove showmount from freenas-debug to prevent hang conditionDone

History

#1 Avatar?id=14398&size=24x24 Updated by Kris Moore 8 months ago

  • Project changed from TrueNAS to FreeNAS
  • Category deleted (HA)
  • Private changed from No to Yes
  • Migration Needed deleted (No)
  • Hide from ChangeLog deleted (No)
  • Support Department Priority deleted (0)

#3 Updated by Dru Lavigne 8 months ago

  • Target version changed from TrueNAS 11.1-U7 to TrueNAS 11.1-U6.2

#4 Updated by Caleb St. John 8 months ago

  • Category set to Middleware
  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#6 Updated by Dru Lavigne 8 months ago

This will also appear in the U7 Release notes.

#7 Updated by Dru Lavigne 8 months ago

  • Subject changed from freenas-debug failing on passive controller to Remove showmount from freenas-debug to prevent hang condition
  • Private changed from Yes to No

#8 Updated by Dru Lavigne 8 months ago

  • Target version changed from TrueNAS 11.1-U6.2 to 11.2-RC2

#9 Updated by William Grzybowski 8 months ago

  • Has duplicate Bug #56157: Download of Debug from an HA system appears as a single node system within that debug file added

#10 Updated by Bonnie Follweiler 8 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreeNAS-11.2-INTERNAL41

#11 Updated by Dru Lavigne 8 months ago

  • Status changed from Passed Testing to Done

#12 Updated by Dru Lavigne 7 months ago

  • Copied to Bug #60390: Remove showmount from freenas-debug to prevent hang condition added

Also available in: Atom PDF