Project

General

Profile

Bug #55908

Umbrella #55899: Prevent Cloud Sync Tasks from overflowing /mnt

stop running cron jobs on passive controller

Added by Caleb St. John almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Services
Target version:
Seen in:
Severity:
High
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When you have a cloud sync task configured, it will auto-create a cronjob based on the interval chosen in the webUI.

On a TrueNAS HA system, the passive node will run the same cronjob. If you configure a PULL job, the passive controller will download the files as configured and will place them in /mnt directory.

Because the /mnt directory is a tmpfs directory of only 4MB in size, this fills up very trivially.

When this occurs, a failover won't happen because the zpools won't import therefore causing a production outage.


Related issues

Is duplicate of FreeNAS - Bug #28182: Do not run cron jobs on TrueNAS passive controllersDone

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Is duplicate of Bug #28182: Do not run cron jobs on TrueNAS passive controllers added

#2 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from TrueNAS 11.1-U6.2 to N/A
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF